Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Can 2.2.0M5a be installed with eclipse 3.5M5?
Can 2.2.0M5a be installed with eclipse 3.5M5? [message #219044] Tue, 17 February 2009 02:24 Go to next message
Eclipse UserFriend
Originally posted by: eclipse-newsgroups.scharf.gr

Hi

is 2.2.0M5a supposed to work with eclipse 3.5M5?
My update manager complains about:
Cannot find a solution satisfying the following requirements org.eclipse.ltk.core.refactoring [3.4.0.v20080603-2000].

It seems to me it requires eclipse 3.4???


Michael
--
Michael Scharf
Wind River Systems GmbH
http://www.WindRiver.com
http://MichaelScharf.blogspot.com/
Re: Can 2.2.0M5a be installed with eclipse 3.5M5? [message #219066 is a reply to message #219044] Tue, 17 February 2009 11:16 Go to previous messageGo to next message
Richard Gronback is currently offline Richard GronbackFriend
Messages: 605
Registered: July 2009
Senior Member
The Galileo build uses p2 to install each project and then construct a
product, so it's effectively installed twice (once from our update site, and
again from the repo generated by the build process). I'm quite certain it
works with the platform's M5.

Are you sure you have all of the required dependencies installed correctly?
I'd say grab it from the Hudson staging site used to build Galileo, but
there are still some server issues at Eclipse, it seems.

- Rich


On 2/16/09 9:24 PM, in article gnd75m$c0c$1@build.eclipse.org, "Michael
Scharf" <eclipse-newsgroups@scharf.gr> wrote:

> Hi
>
> is 2.2.0M5a supposed to work with eclipse 3.5M5?
> My update manager complains about:
> Cannot find a solution satisfying the following requirements
> org.eclipse.ltk.core.refactoring [3.4.0.v20080603-2000].
>
> It seems to me it requires eclipse 3.4???
>
>
> Michael
Re: Can 2.2.0M5a be installed with eclipse 3.5M5? [message #219107 is a reply to message #219066] Tue, 17 February 2009 15:02 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse-newsgroups.scharf.gr

Really strange! I use a freshly installed eclipse SDK 3.5M5 and
I tried to install 2.2.0.M5a from:
http://download.eclipse.org/modeling/gmf/updates/milestones/
(do I need any other update site)

the ltk plugin is there and can be started!
org.eclipse.ltk.core.refactoring [3.4.0.v20080603-2000]
but p2 complains that it cannot find a solution satisfying
org.eclipse.ltk.core.refactoring [3.4.0.v20080603-2000]

Hmm, maybe this is a p2 problem....

Michael

> The Galileo build uses p2 to install each project and then construct a
> product, so it's effectively installed twice (once from our update site, and
> again from the repo generated by the build process). I'm quite certain it
> works with the platform's M5.
>
> Are you sure you have all of the required dependencies installed correctly?
> I'd say grab it from the Hudson staging site used to build Galileo, but
> there are still some server issues at Eclipse, it seems.
>
> - Rich
>
>
> On 2/16/09 9:24 PM, in article gnd75m$c0c$1@build.eclipse.org, "Michael
> Scharf" <eclipse-newsgroups@scharf.gr> wrote:
>
>> Hi
>>
>> is 2.2.0M5a supposed to work with eclipse 3.5M5?
>> My update manager complains about:
>> Cannot find a solution satisfying the following requirements
>> org.eclipse.ltk.core.refactoring [3.4.0.v20080603-2000].
>>
>> It seems to me it requires eclipse 3.4???
>>
>>
>> Michael
>


--
Michael Scharf
Wind River Systems GmbH
http://www.WindRiver.com
http://MichaelScharf.blogspot.com/
Solution for: Can 2.2.0M5a be installed with eclipse 3.5M5? [message #219114 is a reply to message #219107] Tue, 17 February 2009 16:15 Go to previous message
Eclipse UserFriend
Originally posted by: eclipse-newsgroups.scharf.gr

Here is the p2 bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=264525

The message has nothing to do with the real problem.

One solution is to add the GMF, the EMF *and* the staging update site:
http://download.eclipse.org/modeling/gmf/updates/milestones/
http://build.eclipse.org/galileo/staging/
http://download.eclipse.org/modeling/emf/updates/milestones/

Michael

> Really strange! I use a freshly installed eclipse SDK 3.5M5 and
> I tried to install 2.2.0.M5a from:
> http://download.eclipse.org/modeling/gmf/updates/milestones/
> (do I need any other update site)
>
> the ltk plugin is there and can be started!
> org.eclipse.ltk.core.refactoring [3.4.0.v20080603-2000]
> but p2 complains that it cannot find a solution satisfying
> org.eclipse.ltk.core.refactoring [3.4.0.v20080603-2000]
>
> Hmm, maybe this is a p2 problem....
>
> Michael
>
>> The Galileo build uses p2 to install each project and then construct a
>> product, so it's effectively installed twice (once from our update
>> site, and
>> again from the repo generated by the build process). I'm quite
>> certain it
>> works with the platform's M5.
>>
>> Are you sure you have all of the required dependencies installed
>> correctly?
>> I'd say grab it from the Hudson staging site used to build Galileo, but
>> there are still some server issues at Eclipse, it seems.
>>
>> - Rich
>>
>>
>> On 2/16/09 9:24 PM, in article gnd75m$c0c$1@build.eclipse.org, "Michael
>> Scharf" <eclipse-newsgroups@scharf.gr> wrote:
>>
>>> Hi
>>>
>>> is 2.2.0M5a supposed to work with eclipse 3.5M5?
>>> My update manager complains about:
>>> Cannot find a solution satisfying the following requirements
>>> org.eclipse.ltk.core.refactoring [3.4.0.v20080603-2000].
>>>
>>> It seems to me it requires eclipse 3.4???
>>>
>>>
>>> Michael
>>
>
>


--
Michael Scharf
Wind River Systems GmbH
http://www.WindRiver.com
http://MichaelScharf.blogspot.com/
Previous Topic:Auto-generating tool commands.
Next Topic:[Templates] Couldn't find operation 'eContainer()'
Goto Forum:
  


Current Time: Sat Mar 06 22:50:16 GMT 2021

Powered by FUDForum. Page generated in 0.02378 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top