Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » validation warning in an IBD (bug or wrong use?)(strange warning after validating a simple model of 1 BDD and 1 IBD)
icon5.gif  validation warning in an IBD (bug or wrong use?) [message #1300322] Thu, 17 April 2014 13:45 Go to next message
benjamin schmitz is currently offline benjamin schmitzFriend
Messages: 1
Registered: April 2014
Junior Member
Hello everyone,

I am using Eclipse Papyrus SysML for a few weeks now and I have got to a slight problem. I am not sure if I got the concept wrong or if it is a kind of bug.

So in short, I tried to use the validation function in papyrus, to make sure that my model is "logical". But I ended up getting a strange warning for a connector in an IBD, which I have typed with an association between the two blocks, which are connected by the connector over flow ports.

Warning: "Connector SysMLmodel::Block::connector must be typed by an association with compatible end types." <Connector> connector SysMLmodel::Block EMF Problem

Warning: "Connector '<Connector> connector' must be typed by an association with compatible end types." <Connector> connector SysMLmodel::Block EMF Problem


Basicly the model looks like this:
BDD:
"Block" is an composition of "block1" and "block2"
"block1" is associated with "block2"
IBD of "Block":
"block1" has tow "Flowport"s (in, out one each)
"block2" the same
The flow ports are connected with "connectors"
(I will upload the model here)

What is really confusing for me, is the fact, that the warning appears only for one of the tow connectors. I have figured out, that it depends on the direction of the association. From my point of view it should make no difference, since an association should be bidirectional.
If I click first on block 1 and then end the association at block 2, than the connection from block 1 to 2 gets a warning and the other one not. If I click for the association first on block 2 and then block 1, it is the other way around.

I am not sure, if I used the "Type" of the elements completely wrong, or if this might be really a bug. I hope you canhelp me to clear up my confusion.

It might be helpful to know the software version I am using:

Eclipse:
Version: Kepler Service Release 2
Build id: 20140224-0627
Papyrus: Version 0.10.2.v201402281227
OS: Windows 8.1 and Windows 7

Thank you very much in advanced and happy eastern,

Benjamin
  • Attachment: bug hunt.zip
    (Size: 5.68KB, Downloaded 88 times)
Re: validation warning in an IBD (bug or wrong use?) [message #1314049 is a reply to message #1300322] Fri, 25 April 2014 06:18 Go to previous message
deepak varadam is currently offline deepak varadamFriend
Messages: 2
Registered: March 2014
Junior Member
If you need to make the data flow from Block 1 to Block2, the navigable option should be in TRUE for both cases. For more details, please check the Sysml manual in my profile to create the confusion as i given a clear explanation in the uploaded pdf file.

Cheers,
Deepak.
Previous Topic:Missing Composition edge in UML Class Diagram palette
Next Topic:Class equivalent to ModelElementItem
Goto Forum:
  


Current Time: Thu Dec 03 08:24:49 GMT 2020

Powered by FUDForum. Page generated in 0.01625 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top