Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » ECP Editor not showing Volatile or Transient EAttributes
ECP Editor not showing Volatile or Transient EAttributes [message #1277981] Wed, 26 March 2014 18:49 Go to next message
Annamalai Mising name is currently offline Annamalai Mising nameFriend
Messages: 126
Registered: July 2009
Senior Member
Hi There

If my ecore contains Volatile or Transient EAttributes, they are not shown in ECP Editor. We have a usecase where some of the EAttributes are calculated based on other EAttributes in the ecore model.

Therefore while modeling, those attributes were made as Volatile and Transient, but they are not appearing in ECP Editors. The same is visible in Properties View.

So shouldnt we support even display of EAttributes with Volatile and Transient properties set to true.

Regards
Maali
Re: ECP Editor not showing Volatile or Transient EAttributes [message #1278428 is a reply to message #1277981] Thu, 27 March 2014 10:21 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

I quickly checked that. The default view model generator, which creates
a view model for an entity, if there is not explicit model currently
ignores volatile and transient features. I do not know a good reason for
that. As a work around, you could create an explicit view model and
test, whether it works then. Please create a BR for the default generation.

Best Regards

Jonas

Am 26.03.2014 19:49, schrieb Annamalai Chockalingam:
> Hi There
>
> If my ecore contains Volatile or Transient EAttributes, they are not
> shown in ECP Editor. We have a usecase where some of the EAttributes are
> calculated based on other EAttributes in the ecore model.
>
> Therefore while modeling, those attributes were made as Volatile and
> Transient, but they are not appearing in ECP Editors. The same is
> visible in Properties View.
>
> So shouldnt we support even display of EAttributes with Volatile and
> Transient properties set to true.
>
> Regards
> Maali
Re: ECP Editor not showing Volatile or Transient EAttributes [message #1278482 is a reply to message #1278428] Thu, 27 March 2014 11:45 Go to previous message
Annamalai Mising name is currently offline Annamalai Mising nameFriend
Messages: 126
Registered: July 2009
Senior Member
BR raised : https://bugs.eclipse.org/bugs/show_bug.cgi?id=431344
I will try the workaround and see if it works.
Previous Topic:ECP Not able to execute Example
Next Topic:[Teneo] Inheritence mapping annotation on Ecore
Goto Forum:
  


Current Time: Sat Mar 06 12:19:48 GMT 2021

Powered by FUDForum. Page generated in 0.01892 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top