Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dynamic Languages Toolkit (DLTK) » can't find package(having a problem with running tcl code)
can't find package [message #1264420] Wed, 05 March 2014 08:00
Doug Rawlings is currently offline Doug RawlingsFriend
Messages: 1
Registered: March 2014
Junior Member
Hello,

I've used eclipse for a while but am still a beginner. This is the first time using the forum.

I'm hoping this is a really trivial problem, or trivial for someone with more experience than I have.

I have a USB oscilloscope tool (CGR-101) that uses open source software written in tcl and have previously modified the software for my own uses. But I've not used it for some time and have now come back to it. in the meantime I've upgraded my laptop OS (Vista to Windows Cool and have a newer version of Eclipse (Kepler).

I can run the CGR-101 software, either my hacked about version (based on v1.18) or the latest version (v1.21), but not through Eclipse. When I try to run them in Eclipse I get the following error messages:
v1.21
---------
can't find package twapi
while executing
"package require twapi"
invoked from within
"if {$::osType == "windows"} {
package require twapi
}"
(file "capture.tcl" line 27)
invoked from within
"source capture.tcl"
(file "C:\Program Files\Syscomp\CGR101-1.21\Source\main.tcl" line 503)
---------

v1.18b
---------
D D 0
0
W A 0
W F 0 0 0 1
Querying device...
incomingData:
No match
incomingData: Error: Unknown Command

No match
incomingData: *Syscomp CircuitGear V1.4

Connected.
Offsets 123 118 129 129
trigger level 506
trigger level 506
Unable to open custom calibration file, using defaults.
can't find package math::fourier 1.0.1
while executing
"package require math::fourier 1.0.1"
(file "FFT.tcl" line 25)
invoked from within
"source FFT.tcl"
(file "C:\Program Files\Syscomp\cgr101-1.18b\main.tcl" line 540)
---------

It may be that I've set Eclipse up incorrectly, or Windows is interfering. One pointer to this is that when I try to click on the links to the errors I get more errors, for example when I click on :
---------
(file "FFT.tcl" line 25)
---------
I get :
---------
Source not found for FFT.tcl
---------

If you have any pointers I'd appreciate them. I apologise if I've missed something; as I said I've just picked it up again.

Any suggestions or comments would be appreciated.

Regards,

Doug.
Previous Topic:Can DLTK be used for mixed Python and TCL Code
Next Topic:Make DLTK not case sensitive
Goto Forum:
  


Current Time: Sun Mar 01 19:36:43 GMT 2015

Powered by FUDForum. Page generated in 0.06565 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software