Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IAM (Eclipse Integration for Apache Maven) » Installation Failure
Installation Failure [message #19482] Tue, 26 May 2009 17:39 Go to next message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
Hello

I have just downloaded a 3.4.0 release of Eclipse EE, and I try to install
IAM. When I try to install the plugin through
http://q4e.googlecode.com/svn/trunk/updatesite-iam/ by using "Software
updates", the following error occurs, somone can help me, please ?

Cannot complete the request. See the details.


Unsatisfied dependency: [org.eclipse.iam.feature.teamsupport.feature.group
0.9.0.200905051159] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.ui/[0.7.7,1.0 .0)
Unsatisfied dependency: [org.eclipse.iam.feature.teamsupport.feature.group
0.9.0.200905051159] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.core/[0.7.7,1 .0.0)
Unsatisfied dependency: [org.eclipse.iam.teamsupport 0.9.0.200905051159]
requiredCapability: osgi.bundle/org.eclipse.team.svn.ui/[0.7.7,0.8.0)
Unsatisfied dependency: [org.eclipse.iam.teamsupport 0.9.0.200905051159]
requiredCapability: osgi.bundle/org.eclipse.team.svn.core/[0.7.7,0.8.0)
Unsatisfied dependency: [org.eclipse.platform.ide 3.4.0.I20080617-2000]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group /[3.4.0.v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M,3.4 .0.v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M]
Unsatisfied dependency: [org.eclipse.iam.teamsupport 0.9.0.200905051159]
requiredCapability: osgi.bundle/org.eclipse.team.svn.core/[0.7.7,0.8.0)
Unsatisfied dependency: [org.eclipse.iam.teamsupport 0.9.0.200905051159]
requiredCapability: osgi.bundle/org.eclipse.team.svn.ui/[0.7.7,0.8.0)
Unsatisfied dependency: [org.eclipse.iam.feature.buckminster.feature.group
0.9.0.200905051159] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.iam.buckminster.core/[ 0.9.0.200905051159,0.9.0.200905051159]
Unsatisfied dependency: [org.eclipse.iam.feature.teamsupport.feature.group
0.9.0.200905051159] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.core/[0.7.7,1 .0.0)
Unsatisfied dependency: [org.eclipse.iam.feature.teamsupport.feature.group
0.9.0.200905051159] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.team.svn.ui/[0.7.7,1.0 .0)
Unsatisfied dependency: [org.eclipse.iam.feature.teamsupport.feature.group
0.9.0.200905051159] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.iam.teamsupport/[0.9.0 .200905051159,0.9.0.200905051159]
Unsatisfied dependency: [org.eclipse.platform.feature.group
3.4.0.v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80612,3.4.0.v20080612]
Unsatisfied dependency: [org.eclipse.platform.feature.group
3.4.0.v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.group/[1. 0.0.v20080603-7r7xEHJEJkZu5nE6Q4Qrtvu6JZ9L,1.0.0.v20080603-7 r7xEHJEJkZu5nE6Q4Qrtvu6JZ9L]
Unsatisfied dependency: [org.eclipse.help.feature.group
1.0.0.v20080603-7r7xEHJEJkZu5nE6Q4Qrtvu6JZ9L] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.group/[3.4 .0.v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989J ERhEk-jWnd5IY8K5tjxB]
Re: Installation Failure [message #19529 is a reply to message #19482] Tue, 26 May 2009 19:56 Go to previous messageGo to next message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Hello Stéphane,

You should not install the Subversive or Buckminster integrations, since
the required dependencies are not installed in Eclipse EE.

--
Abel Muiño
Re: Installation Failure [message #19619 is a reply to message #19529] Wed, 27 May 2009 09:29 Go to previous messageGo to next message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
Hello Abel,

Thanks for your help.
Now, it's ok with the install.

My installation is an upgrade from a previous version. When I activate the
plugin with selecting Maven 2 -> "Use Maven dependency management". Errors
are displayed which where not there with the previous release :

Build path contains duplicate entry:
.../.m2/repository/org/osgi/osgi_R4_core/1.0/osgi_R4_core-1. 0.jar' for
project 'mngtlib'

The error is only in Eclipse, when I use the Maven CLI the compilation is
ok :(
Re: Installation Failure [message #19664 is a reply to message #19619] Wed, 27 May 2009 09:43 Go to previous messageGo to next message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
I found a duplicate entry in "Maven Classpath Container" in my Eclipse but
I don't know how to sync this container with my pom :(
Re: Installation Failure [message #19709 is a reply to message #19664] Wed, 27 May 2009 10:45 Go to previous messageGo to next message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
It seems that an exclusion in a denpendency is not well managed so the
excluded artifact seems to be added to "Maven Classpath Container"
So I changed my pom to avoid this problem but now another problems occurs.
Lots of errors "the type ... is not generic". It ssems that the project
has switch in 1.4 java style.

I have checked that my project in Eclipse is 1.6 and in my pom :
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<configuration>
<source>1.6</source>
<target>1.6</target>
</configuration>
</plugin>

Any idea, please ?
Re: Installation Failure [message #19770 is a reply to message #19709] Wed, 27 May 2009 13:01 Go to previous messageGo to next message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
To resolve my problems :

- I have deleted the following line in the .classpath of my projects :
<classpathentry kind="con"
path="org.devzuz.q.maven.jdt.core.mavenClasspathContainer"/ >

- I have added in my pom exclusions for duplicate artefact to avoid
duplicate entries in the "Maven Classpath Container"
Re: Installation Failure [message #19810 is a reply to message #19709] Wed, 27 May 2009 14:58 Go to previous messageGo to next message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Hello Stéphane,

IAM will set the java compliance options for Eclise's JDT. Somehow, this
seemed not to work for your project, so if you're able to reproduce this,
please file a bugzilla with instructions.

If the problem shows again, you can try the following workaround:
- Cleaning your project (inside eclipse). This will re-process your pom.
- (Optionally) you can disable and enable Maven support for the project,
to force IAM to start from scratch.
- Setting the java settings in the project properties manually

Thanks!

Stephane wrote:

> It seems that an exclusion in a denpendency is not well managed so the
> excluded artifact seems to be added to "Maven Classpath Container"
> So I changed my pom to avoid this problem but now another problems occurs.
> Lots of errors "the type ... is not generic". It ssems that the project
> has switch in 1.4 java style.

> I have checked that my project in Eclipse is 1.6 and in my pom :
> <plugin>
> <groupId>org.apache.maven.plugins</groupId>
> <artifactId>maven-compiler-plugin</artifactId>
> <configuration>
> <source>1.6</source>
> <target>1.6</target>
> </configuration>
> </plugin>

> Any idea, please ?

--
Abel Muiño
Re: Installation Failure [message #19853 is a reply to message #19770] Wed, 27 May 2009 15:02 Go to previous messageGo to next message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Helo Stéphane,

Stephane wrote:

> To resolve my problems :

> - I have deleted the following line in the .classpath of my projects :
> <classpathentry kind="con"
> path="org.devzuz.q.maven.jdt.core.mavenClasspathContainer"/ >

This is the old classpath container name, used by q4e. So I am guessing
that you didn't uninstall q4e before installing IAM ?

> - I have added in my pom exclusions for duplicate artefact to avoid
> duplicate entries in the "Maven Classpath Container"

Could you open a bugzilla with a sample pom showing the problem? The Maven
Classpath Container should not allow duplicate entries, so this might be a
bug.

Thanks for your feedback!
--
Abel Muiño
Re: Installation Failure [message #19920 is a reply to message #19810] Wed, 27 May 2009 16:06 Go to previous messageGo to next message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
> IAM will set the java compliance options for Eclise's JDT. Somehow, this
> seemed not to work for your project, so if you're able to reproduce this,
> please file a bugzilla with instructions.
It seems that the issue occurs when I try to add a specific dependency.
(but it works well with the mvn CLI)
I'm going to try to reproduce the issue in a simple project to file a
bugzilla.

> If the problem shows again, you can try the following workaround:
> - Cleaning your project (inside eclipse). This will re-process your pom.
> - (Optionally) you can disable and enable Maven support for the project,
> to force IAM to start from scratch.
> - Setting the java settings in the project properties manually

I tried this workaround. The issue is always there :(

> Thanks!

> Stephane wrote:

>> It seems that an exclusion in a denpendency is not well managed so the
>> excluded artifact seems to be added to "Maven Classpath Container"
>> So I changed my pom to avoid this problem but now another problems occurs.
>> Lots of errors "the type ... is not generic". It ssems that the project
>> has switch in 1.4 java style.

>> I have checked that my project in Eclipse is 1.6 and in my pom :
>> <plugin>
>> <groupId>org.apache.maven.plugins</groupId>
>> <artifactId>maven-compiler-plugin</artifactId>
>> <configuration>
>> <source>1.6</source>
>> <target>1.6</target>
>> </configuration>
>> </plugin>

>> Any idea, please ?
Re: Installation Failure [message #19949 is a reply to message #19853] Wed, 27 May 2009 16:18 Go to previous messageGo to next message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
>> - I have deleted the following line in the .classpath of my projects :
>> <classpathentry kind="con"
>> path="org.devzuz.q.maven.jdt.core.mavenClasspathContainer"/ >

> This is the old classpath container name, used by q4e. So I am guessing
> that you didn't uninstall q4e before installing IAM ?

Previously, I have uninstalled q4e as described in the documentation
(plugin uninstallation, file plugin deletion in plugins folder, eclipse
-clean)

>> - I have added in my pom exclusions for duplicate artefact to avoid
>> duplicate entries in the "Maven Classpath Container"

> Could you open a bugzilla with a sample pom showing the problem? The Maven
> Classpath Container should not allow duplicate entries, so this might be a
> bug.

I'm going to try to reproduce in a sample project
Re: Installation Failure [message #19995 is a reply to message #19853] Wed, 27 May 2009 22:16 Go to previous message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 114
Registered: July 2009
Senior Member
On 5/27/09 8:02 AM, Abel Muiño wrote:
> Helo Stéphane,
>
> Stephane wrote:
>
>> To resolve my problems :
>
>> - I have deleted the following line in the .classpath of my projects :
>> <classpathentry kind="con"
>> path="org.devzuz.q.maven.jdt.core.mavenClasspathContainer"/ >
>
> This is the old classpath container name, used by q4e. So I am guessing
> that you didn't uninstall q4e before installing IAM ?


I've seen this problem, Eclipse caches the contents of the old classpath
container even if you uninstall the plugin. I guess the only solution is
to remove it from the .classpath or delete it completely and reimport


>
>> - I have added in my pom exclusions for duplicate artefact to avoid
>> duplicate entries in the "Maven Classpath Container"
>
> Could you open a bugzilla with a sample pom showing the problem? The
> Maven Classpath Container should not allow duplicate entries, so this
> might be a bug.
>
> Thanks for your feedback!
> --
> Abel Muiño
>
Re: Installation Failure [message #569387 is a reply to message #19482] Tue, 26 May 2009 19:56 Go to previous message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Hello Stéphane,

You should not install the Subversive or Buckminster integrations, since
the required dependencies are not installed in Eclipse EE.

--
Abel Muiño
Re: Installation Failure [message #569412 is a reply to message #19529] Wed, 27 May 2009 09:29 Go to previous message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
Hello Abel,

Thanks for your help.
Now, it's ok with the install.

My installation is an upgrade from a previous version. When I activate the
plugin with selecting Maven 2 -> "Use Maven dependency management". Errors
are displayed which where not there with the previous release :

Build path contains duplicate entry:
.../.m2/repository/org/osgi/osgi_R4_core/1.0/osgi_R4_core-1. 0.jar' for
project 'mngtlib'

The error is only in Eclipse, when I use the Maven CLI the compilation is
ok :(
Re: Installation Failure [message #569437 is a reply to message #19619] Wed, 27 May 2009 09:43 Go to previous message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
I found a duplicate entry in "Maven Classpath Container" in my Eclipse but
I don't know how to sync this container with my pom :(
Re: Installation Failure [message #569466 is a reply to message #19664] Wed, 27 May 2009 10:45 Go to previous message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
It seems that an exclusion in a denpendency is not well managed so the
excluded artifact seems to be added to "Maven Classpath Container"
So I changed my pom to avoid this problem but now another problems occurs.
Lots of errors "the type ... is not generic". It ssems that the project
has switch in 1.4 java style.

I have checked that my project in Eclipse is 1.6 and in my pom :
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<configuration>
<source>1.6</source>
<target>1.6</target>
</configuration>
</plugin>

Any idea, please ?
Re: Installation Failure [message #569486 is a reply to message #19709] Wed, 27 May 2009 13:01 Go to previous message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
To resolve my problems :

- I have deleted the following line in the .classpath of my projects :
<classpathentry kind="con"
path="org.devzuz.q.maven.jdt.core.mavenClasspathContainer"/ >

- I have added in my pom exclusions for duplicate artefact to avoid
duplicate entries in the "Maven Classpath Container"
Re: Installation Failure [message #569513 is a reply to message #19709] Wed, 27 May 2009 14:58 Go to previous message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Hello Stéphane,

IAM will set the java compliance options for Eclise's JDT. Somehow, this
seemed not to work for your project, so if you're able to reproduce this,
please file a bugzilla with instructions.

If the problem shows again, you can try the following workaround:
- Cleaning your project (inside eclipse). This will re-process your pom.
- (Optionally) you can disable and enable Maven support for the project,
to force IAM to start from scratch.
- Setting the java settings in the project properties manually

Thanks!

Stephane wrote:

> It seems that an exclusion in a denpendency is not well managed so the
> excluded artifact seems to be added to "Maven Classpath Container"
> So I changed my pom to avoid this problem but now another problems occurs.
> Lots of errors "the type ... is not generic". It ssems that the project
> has switch in 1.4 java style.

> I have checked that my project in Eclipse is 1.6 and in my pom :
> <plugin>
> <groupId>org.apache.maven.plugins</groupId>
> <artifactId>maven-compiler-plugin</artifactId>
> <configuration>
> <source>1.6</source>
> <target>1.6</target>
> </configuration>
> </plugin>

> Any idea, please ?

--
Abel Muiño
Re: Installation Failure [message #569539 is a reply to message #19770] Wed, 27 May 2009 15:02 Go to previous message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Helo Stéphane,

Stephane wrote:

> To resolve my problems :

> - I have deleted the following line in the .classpath of my projects :
> <classpathentry kind="con"
> path="org.devzuz.q.maven.jdt.core.mavenClasspathContainer"/ >

This is the old classpath container name, used by q4e. So I am guessing
that you didn't uninstall q4e before installing IAM ?

> - I have added in my pom exclusions for duplicate artefact to avoid
> duplicate entries in the "Maven Classpath Container"

Could you open a bugzilla with a sample pom showing the problem? The Maven
Classpath Container should not allow duplicate entries, so this might be a
bug.

Thanks for your feedback!
--
Abel Muiño
Re: Installation Failure [message #569563 is a reply to message #19810] Wed, 27 May 2009 16:06 Go to previous message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
> IAM will set the java compliance options for Eclise's JDT. Somehow, this
> seemed not to work for your project, so if you're able to reproduce this,
> please file a bugzilla with instructions.
It seems that the issue occurs when I try to add a specific dependency.
(but it works well with the mvn CLI)
I'm going to try to reproduce the issue in a simple project to file a
bugzilla.

> If the problem shows again, you can try the following workaround:
> - Cleaning your project (inside eclipse). This will re-process your pom.
> - (Optionally) you can disable and enable Maven support for the project,
> to force IAM to start from scratch.
> - Setting the java settings in the project properties manually

I tried this workaround. The issue is always there :(

> Thanks!

> Stephane wrote:

>> It seems that an exclusion in a denpendency is not well managed so the
>> excluded artifact seems to be added to "Maven Classpath Container"
>> So I changed my pom to avoid this problem but now another problems occurs.
>> Lots of errors "the type ... is not generic". It ssems that the project
>> has switch in 1.4 java style.

>> I have checked that my project in Eclipse is 1.6 and in my pom :
>> <plugin>
>> <groupId>org.apache.maven.plugins</groupId>
>> <artifactId>maven-compiler-plugin</artifactId>
>> <configuration>
>> <source>1.6</source>
>> <target>1.6</target>
>> </configuration>
>> </plugin>

>> Any idea, please ?
Re: Installation Failure [message #569583 is a reply to message #19853] Wed, 27 May 2009 16:18 Go to previous message
Stephane is currently offline StephaneFriend
Messages: 14
Registered: July 2009
Junior Member
>> - I have deleted the following line in the .classpath of my projects :
>> <classpathentry kind="con"
>> path="org.devzuz.q.maven.jdt.core.mavenClasspathContainer"/ >

> This is the old classpath container name, used by q4e. So I am guessing
> that you didn't uninstall q4e before installing IAM ?

Previously, I have uninstalled q4e as described in the documentation
(plugin uninstallation, file plugin deletion in plugins folder, eclipse
-clean)

>> - I have added in my pom exclusions for duplicate artefact to avoid
>> duplicate entries in the "Maven Classpath Container"

> Could you open a bugzilla with a sample pom showing the problem? The Maven
> Classpath Container should not allow duplicate entries, so this might be a
> bug.

I'm going to try to reproduce in a sample project
Re: Installation Failure [message #569609 is a reply to message #19853] Wed, 27 May 2009 22:16 Go to previous message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 114
Registered: July 2009
Senior Member
On 5/27/09 8:02 AM, Abel Muiño wrote:
> Helo Stéphane,
>
> Stephane wrote:
>
>> To resolve my problems :
>
>> - I have deleted the following line in the .classpath of my projects :
>> <classpathentry kind="con"
>> path="org.devzuz.q.maven.jdt.core.mavenClasspathContainer"/ >
>
> This is the old classpath container name, used by q4e. So I am guessing
> that you didn't uninstall q4e before installing IAM ?


I've seen this problem, Eclipse caches the contents of the old classpath
container even if you uninstall the plugin. I guess the only solution is
to remove it from the .classpath or delete it completely and reimport


>
>> - I have added in my pom exclusions for duplicate artefact to avoid
>> duplicate entries in the "Maven Classpath Container"
>
> Could you open a bugzilla with a sample pom showing the problem? The
> Maven Classpath Container should not allow duplicate entries, so this
> might be a bug.
>
> Thanks for your feedback!
> --
> Abel Muiño
>
Previous Topic:Apparent Maven / JUnit clash in eclipse
Next Topic:IAM maven builder not copying resources?
Goto Forum:
  


Current Time: Wed Nov 14 16:24:52 GMT 2018

Powered by FUDForum. Page generated in 0.04544 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top