Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Problems xText - RCP integration
Problems xText - RCP integration [message #1235569] Fri, 24 January 2014 17:34 Go to next message
Michael Fzy is currently offline Michael FzyFriend
Messages: 9
Registered: December 2013
Junior Member
Hi all,

I'm working with xText and I need export my application into a RCP app.

I'm trying to do that but there must be a little thing that I'm ignoring because it doesn't work at all.

The thing is that my RCP is working properly, I mean, I write a file in the language I have depeloved and that works! The auto-completed function, syntax highlighting... but when I save my file, a set of files must generate and here it is the error...

Errors occurred during the build.
Errors running builder 'Xtext Project Builder' on project 'example'.
org/eclipse/xtend2/lib/StringConcatenation

I guess there is some dependency that it's missing but... nothing I try works.

Do you have any idea of how I can solve it?

Thank you in advanced.
Re: Problems xText - RCP integration [message #1235575 is a reply to message #1235569] Fri, 24 January 2014 17:56 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13661
Registered: July 2009
Senior Member
Hi,

can you have a look at the error log for a complete trace?
the StringConcatenation class should be in xbase.lib plugin.


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Problems xText - RCP integration [message #1236216 is a reply to message #1235575] Sun, 26 January 2014 15:59 Go to previous messageGo to next message
Michael Fzy is currently offline Michael FzyFriend
Messages: 9
Registered: December 2013
Junior Member
Hi again,

the actual situation is that:

I have discovered the problem of the error I was talking before. As I thought, I needed one more dependecy in my proyect, and this is: org.eclipse.xtext.xbase.

Now, when I launch the application via Eclipse -> run configuration, everything works fine! But I have tried to export the product as a RCP application. In this case there is no error, but the set of files must be generated automatically don't appear and there is no error or any useful information I can use to solve the problem.

Thank you in advanced if you have any idea could be interesting.
Re: Problems xText - RCP integration [message #1236219 is a reply to message #1236216] Sun, 26 January 2014 16:01 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13661
Registered: July 2009
Senior Member
sorry

hard to diagnose without any hints...


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Problems xText - RCP integration [message #1236222 is a reply to message #1236219] Sun, 26 January 2014 16:14 Go to previous messageGo to next message
Michael Fzy is currently offline Michael FzyFriend
Messages: 9
Registered: December 2013
Junior Member
When I launch the application via run configuration, I have to change one of the dependencies, com.google.guava, because by default it is used version 11.0.2 and it's necessary to use version 10.0.1. This change is only possible to do it in run configuration, the versions of the dependencies of the product can not be changed until I know... maybe this is the problem...
Re: Problems xText - RCP integration [message #1236231 is a reply to message #1236222] Sun, 26 January 2014 16:55 Go to previous messageGo to next message
Michael Fzy is currently offline Michael FzyFriend
Messages: 9
Registered: December 2013
Junior Member
Another question, in case everything can work fine.

One of the files I generate is a .java. Once it has been generated, I have to execute it via right-click, run as, java application. I don't see the option of running any file inside the RCP product. Is this possible to do it?
Re: Problems xText - RCP integration [message #1236235 is a reply to message #1236231] Sun, 26 January 2014 17:10 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13661
Registered: July 2009
Senior Member
Hi,

do you have jdt.ui in your product? did you open the java perspective? is the project a java project?


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de

[Updated on: Sun, 26 January 2014 17:23]

Report message to a moderator

Re: Problems xText - RCP integration [message #1238465 is a reply to message #1236235] Sat, 01 February 2014 12:39 Go to previous messageGo to next message
Michael Fzy is currently offline Michael FzyFriend
Messages: 9
Registered: December 2013
Junior Member
Hi again,

this last problem is solved. So, right now, when I run the application via Eclipse application everything works properly.

When I export it, the files should be generated thanks to xtend code has been programmed don't work. I save the xtext query, and no files are generated.

If there is a way everything works, I guess it's not a problem of dependencies, so if there is neither error nor warnings, do you know if there is a way to check where the fail is? I'm really desperate because I don't know the way to start with this problem...

Thank you in advanced.
Re: Problems xText - RCP integration [message #1238481 is a reply to message #1238465] Sat, 01 February 2014 13:53 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13661
Registered: July 2009
Senior Member
Hi do you have any warnings on build.properties files? Did you try to
remote debug into xtextbuilder ?

--
Need training, onsite consulting or any other kind of help for Xtext?
Go visit http://xtext.itemis.com or send a mail to xtext at itemis dot de


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Problems xText - RCP integration [message #1238502 is a reply to message #1238481] Sat, 01 February 2014 15:00 Go to previous messageGo to next message
Michael Fzy is currently offline Michael FzyFriend
Messages: 9
Registered: December 2013
Junior Member
I don't have any warnings in the whole proyect. That was the first I did to try to solve it.

What do you mean exactly with "remote debug into xtextbuilder"? Because the application, when it has been exported, it's totally independient from the, we could say, Eclipse where we have the code and we can debug it.
Re: Problems xText - RCP integration [message #1238504 is a reply to message #1238502] Sat, 01 February 2014 15:05 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13661
Registered: July 2009
Senior Member
hi as any other java app you can configure the rcp to be connectable with a remote debugger.
googling should help e.g. http://stackoverflow.com/questions/13385558/how-can-i-remote-debug-my-rcp-application
additionaly you could start eclipse with console/console log or have a look at the log files to see if there is any error.

what looks strange to me is that you say the the code generation is the only thing not working


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Problems xText - RCP integration [message #1238511 is a reply to message #1238504] Sat, 01 February 2014 15:20 Go to previous message
Michael Fzy is currently offline Michael FzyFriend
Messages: 9
Registered: December 2013
Junior Member
I wanted really thank you your support.

I was totally obfuscated because the console wasn't showing me any message of error but it was in the log file... Embarrassed

Now it's working perfectly!!!

THANK YOU!!

Best regards my friend!!
Previous Topic:Get XtextResource from IProject
Next Topic:Creating new Xtext resource through code
Goto Forum:
  


Current Time: Thu Nov 26 10:35:45 GMT 2020

Powered by FUDForum. Page generated in 0.07681 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top