Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Cannot set up InitialValues in SysML model(I try, without success, to define initial values for part properties values)
icon5.gif  Cannot set up InitialValues in SysML model [message #1231844] Wed, 15 January 2014 14:43
Thomas Bardot is currently offline Thomas BardotFriend
Messages: 5
Registered: January 2014
Junior Member
Let the following example.
I've created two blocks, Block_A and Block_B. Block_B has a property named Id typed as an integer.
Block_A has two parts properties: Part_A1 and Part_A2. These parts are typed with Block_B. So, Part_A1 and Part_A2 are two instances of Block_B.

I would like to set a different value to the Id property for Part_A1 and Part_A2.

In the reference book "A practical guide to SysML", ยง7.3, p.141 : "The initial values for a part can be specified using a dedicated compartment labeled initial Values. The initial values over-ride the default values of the properties in the block that types the part."

Is it possible to specify initial values for a part in Papyrus?

Previous Topic:display different/derived label for stereotyped transitions
Next Topic:Parse UML2 diagrams with Papyrus
Goto Forum:
  


Current Time: Fri Dec 04 15:37:57 GMT 2020

Powered by FUDForum. Page generated in 0.01510 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top