Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » First Time User Guide User - Help on Following Directions
First Time User Guide User - Help on Following Directions [message #1230429] Sun, 12 January 2014 00:43
Ray Joseph is currently offline Ray JosephFriend
Messages: 87
Registered: July 2009
Member
I would like to use Papyrus for SysML. I started here:
http://www.eclipse.org/papyrus/
I have installed Papyrus on Kepler with Windows 7 on a 64bit machine.

I have a couple questions at to the user guide. I have also added some information on where the instruction do not match the installation.

Installation guide
http://eclipse.org/papyrus/updates/index.php
Direction say "Then, you have to use the discovery interface ("Help" => "Install Modeling Component") and select Papyrus.: But the only selection is Papyrus (Incubation). The incubation is what I choose. It would be useful if the instruction matched the content.

From user guide:
http://wiki.eclipse.org/Papyrus_User_Guide
It says to create a new model. It does not show how.
From the 'new' icon, 'model' is not a choice. Scroll down to other and there is an 'SysML Model'. It cannot be created as there is no project. So 'SysML Project' was selected. Then a model was defined.

On providing a name for the model, a request for diagram selection and a name is requested. It provides the selection of bdd, ibd, or req. Why isn't package listed? That is where I would like to start so I may define the context. When I try to add a package, the only selection is a Java package. Since this is an SysML model and not a Java model, it will not create a package.

The diagram palette has a package element; it does paste into the block definition diagram. But no package diagram is available.

The "Create a diagram from an existing uml file" direction does not match my installation. The guide shows a list of 'initialize' actions. Mine has none of these.

The user guide directs:
Apply a static profile
- Select a package element (ie a Model or a Package).
- Select the tab "Profile" on the "Properties" view
- Click on the plug-in icon
- Select your static profile
- Choose profiles to apply

After selecting 'properties' there is no profile or plug-in icon as the guide suggests. There is only a "resource" page.


To add a resource, the guide uses the model explorer. I have not been able to pull up the model explorer, how is that done? In the previous step, there was a resource page from the project explorer but it does not have a function to add a resource.

I would appreciate any help.

Thank you
Previous Topic:copy plug-in from laptop to another laptop but is not working
Next Topic:How model exception throws in Java
Goto Forum:
  


Current Time: Thu Nov 26 10:37:17 GMT 2020

Powered by FUDForum. Page generated in 0.01780 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top