Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Validation OK, Generate diagram code failed
Validation OK, Generate diagram code failed [message #199836] Fri, 01 August 2008 12:40 Go to next message
Eclipse UserFriend
Originally posted by: aya.topdanmark.dk

Hi all,

I am trying to generate the diagram code from my .gmfgen file. When I try
to validate it, it gives no validation errors. But when I ran "Generate
diagram code", it gave errors like these:

Error
Thu Jul 31 16:35:50 CEST 2008
Validation failed unexpectedly for 'Gen Shared Contribution Item'. See log
for details.

java.lang.NullPointerException
at
org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.getReoriente dIncomingLinks(GenNodeImpl.java:545)
at
org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.eIsSet(GenNo deImpl.java:337)
at
org.eclipse.gmf.codegen.gmfgen.impl.GenTopLevelNodeImpl.eIsS et(GenTopLevelNodeImpl.java:128)
... more

Error
Fri Aug 01 14:26:17 CEST 2008
Validation failed unexpectedly for 'Type Link Model Facet'. See log for
details.

java.lang.NullPointerException
at
org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.getReoriente dIncomingLinks(GenNodeImpl.java:545)
at
org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.eIsSet(GenNo deImpl.java:337)
at
org.eclipse.gmf.codegen.gmfgen.impl.GenTopLevelNodeImpl.eIsS et(GenTopLevelNodeImpl.java:128)
... and some more

Error
Fri Aug 01 14:26:17 CEST 2008
Validation failed unexpectedly for 'Gen Top Level Node BranchEditPart'.
See log for details.

java.lang.NullPointerException
at
org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.getReoriente dIncomingLinks(GenNodeImpl.java:545)
at
org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.eIsSet(GenNo deImpl.java:337)
at
org.eclipse.gmf.codegen.gmfgen.impl.GenTopLevelNodeImpl.eIsS et(GenTopLevelNodeImpl.java:128)
... and some more.

Do you know where I should start analyzing?
Re: Validation OK, Generate diagram code failed [message #199988 is a reply to message #199836] Mon, 04 August 2008 05:27 Go to previous messageGo to next message
Jevon  is currently offline Jevon Friend
Messages: 164
Registered: July 2009
Senior Member
Usually this means there is some problem in your .gmfgen file, but GMF
isn't very helpful in describing what could be the problem.

I got errors like these when I had a Link class, without having my
LinkMapping properly set (e.g. it was trying to draw a link without the
endpoints of the link properly configured). I needed to change my
"source meta feature", "target meta feature" and "diagram link" values
in my Link Mapping (located in .gmfgen > Editor > Diagram > Link > Type
Link).

Try simplifying your model and seeing if you can get it to work with a
smaller case.

Jevon

Allan wrote:
> Hi all,
>
> I am trying to generate the diagram code from my .gmfgen file. When I
> try to validate it, it gives no validation errors. But when I ran
> "Generate diagram code", it gave errors like these:
>
> Error
> Thu Jul 31 16:35:50 CEST 2008
> Validation failed unexpectedly for 'Gen Shared Contribution Item'. See
> log for details.
>
> java.lang.NullPointerException
> at
> org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.getReoriente dIncomingLinks(GenNodeImpl.java:545)
>
> at
> org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.eIsSet(GenNo deImpl.java:337)
>
> at
> org.eclipse.gmf.codegen.gmfgen.impl.GenTopLevelNodeImpl.eIsS et(GenTopLevelNodeImpl.java:128)
>
> .. more
>
> Error
> Fri Aug 01 14:26:17 CEST 2008
> Validation failed unexpectedly for 'Type Link Model Facet'. See log for
> details.
>
> java.lang.NullPointerException
> at
> org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.getReoriente dIncomingLinks(GenNodeImpl.java:545)
>
> at
> org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.eIsSet(GenNo deImpl.java:337)
>
> at
> org.eclipse.gmf.codegen.gmfgen.impl.GenTopLevelNodeImpl.eIsS et(GenTopLevelNodeImpl.java:128)
>
> .. and some more
>
> Error
> Fri Aug 01 14:26:17 CEST 2008
> Validation failed unexpectedly for 'Gen Top Level Node BranchEditPart'.
> See log for details.
>
> java.lang.NullPointerException
> at
> org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.getReoriente dIncomingLinks(GenNodeImpl.java:545)
>
> at
> org.eclipse.gmf.codegen.gmfgen.impl.GenNodeImpl.eIsSet(GenNo deImpl.java:337)
>
> at
> org.eclipse.gmf.codegen.gmfgen.impl.GenTopLevelNodeImpl.eIsS et(GenTopLevelNodeImpl.java:128)
>
> .. and some more.
>
> Do you know where I should start analyzing?
>
Re: Validation OK, Generate diagram code failed [message #200041 is a reply to message #199836] Mon, 04 August 2008 09:44 Go to previous message
Alexander Shatalin is currently offline Alexander ShatalinFriend
Messages: 2928
Registered: July 2009
Senior Member
Hello Allan,

Looks like link mapping has no TargetMetaFeature property specified.

-----------------
Alex Shatalin
Previous Topic:Create generator model errors
Next Topic:String trim function in an GMF Audit environment
Goto Forum:
  


Current Time: Sat Jun 06 12:19:27 GMT 2020

Powered by FUDForum. Page generated in 0.01656 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top