Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Integrating EMF / GMF editors - diagram changes not saving
Integrating EMF / GMF editors - diagram changes not saving [message #197989] Mon, 21 July 2008 00:04 Go to next message
Eclipse UserFriend
Originally posted by: nuclearpsyche.gmail.com

Hello,
This is my first time using the newsgroups so I hope I am posting in the
right place.
I have a project where I want to combine the EMF and GMF generated editors
and further customize them.
So far the editors are combined but all the changes made in the diagram tab
are not saved or reflected in the model (for example in the tree tab).
The model of the diagram gets initialized like the EMF model but does not
get updated or does not updated EMF model in the other direction.
It almost seems like the diagram is initialized with a model that is a copy
of the emf model instead of the model itself.
I am pretty new to EMF and GMF. Any help is greatly appreciated.
Thank you,

tamer
Re: Integrating EMF / GMF editors - diagram changes not saving [message #198050 is a reply to message #197989] Mon, 21 July 2008 11:34 Go to previous messageGo to next message
Alexander Shatalin is currently offline Alexander ShatalinFriend
Messages: 2928
Registered: July 2009
Senior Member
Hello Tamer,

This article can be halpfull for you: http://www.eclipse.org/articles/article.php?file=Article-Int egrating-EMF-GMF-Editors/index.html

-----------------
Alex Shatalin
Re: Integrating EMF / GMF editors - diagram changes not saving [message #198174 is a reply to message #198050] Tue, 22 July 2008 01:02 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: nuclearpsyche.gmail.com

Hi Alex,
This is the article I used to integrate my editors. I basically followed it
all the way to the RCP section using a different emf model but I am not
getting the expected behavior. The diagram tab does not update the model.
Any pointers would be helpful.
Thank you,

tamer

"Alex Shatalin" <vano@borland.com> wrote in message
news:3c3172e6248468cab94da1abd52b@news.eclipse.org...
> Hello Tamer,
>
> This article can be halpfull for you:
> http://www.eclipse.org/articles/article.php?file=Article-Int egrating-EMF-GMF-Editors/index.html
>
> -----------------
> Alex Shatalin
>
>
Re: Integrating EMF / GMF editors - diagram changes not saving [message #198290 is a reply to message #198174] Tue, 22 July 2008 11:54 Go to previous messageGo to next message
Alexander Shatalin is currently offline Alexander ShatalinFriend
Messages: 2928
Registered: July 2009
Senior Member
Hello Tamer,

So, you have non-RCP version of this combined editor, right?
In general this means you have used different instances of EditingDomain
(ResourceSet) to load data into the EMF- and GMF-generated editors..

Please re-check that you've correctly performed step http://www.eclipse.org/articles/Article-Integrating-EMF-GMF- Editors/index.html#extending_the_editor_input
- proper instance of EditingDomain used while constructing diagram document
in ???DocumentProvider.createEmptyDocument(). This instance of Editing domain
should be the same as one created in ???Editor.initializeEditingDomain()
- you can check it in a debugger.

-----------------
Alex Shatalin
Re: Integrating EMF / GMF editors - diagram changes not saving [message #199034 is a reply to message #198290] Fri, 25 July 2008 23:50 Go to previous message
Eclipse UserFriend
Originally posted by: nuclearpsyche.gmail.com

Thanks a lot for your help. I just started the project from scratch and
payed extra attention to the section you mentioned. It worked.
Thanks again!

tamer

"Alex Shatalin" <vano@borland.com> wrote in message
news:3c3172e6248f98caba19967839b8@news.eclipse.org...
> Hello Tamer,
>
> So, you have non-RCP version of this combined editor, right?
> In general this means you have used different instances of EditingDomain
> (ResourceSet) to load data into the EMF- and GMF-generated editors..
> Please re-check that you've correctly performed step
> http://www.eclipse.org/articles/Article-Integrating-EMF-GMF- Editors/index.html#extending_the_editor_input -
> proper instance of EditingDomain used while constructing diagram document
> in ???DocumentProvider.createEmptyDocument(). This instance of Editing
> domain should be the same as one created in
> ???Editor.initializeEditingDomain() - you can check it in a debugger.
>
> -----------------
> Alex Shatalin
>
>
Previous Topic:Creating external labels at runtime
Next Topic:Enable Problems View in RCP
Goto Forum:
  


Current Time: Mon May 25 06:19:15 GMT 2020

Powered by FUDForum. Page generated in 0.02106 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top