Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » arrow keys to move shapes not working
arrow keys to move shapes not working [message #196004] Mon, 07 July 2008 22:37 Go to next message
John Yotka is currently offline John YotkaFriend
Messages: 144
Registered: July 2009
Senior Member
I've just installed the Ganymede Modeling tools version, migrated my GMF
application over. Migrated the model files to 2.1 (via popup menu).
Regenerated the .gmfgen and then regenerated the code. When I run the
application the "arrow" keys still navigate from shape to shape instead
of moving the shape. According to the GMF New and Noteworthy, 2.1 M5
should have changed this behavior. I am running on under WinXP not a Mac.

Did I do something wrong in migrating from 2.0 to 2.1? Is there some
configuration item to set in order to get the desired behavior?
Re: arrow keys to move shapes not working [message #196104 is a reply to message #196004] Tue, 08 July 2008 16:48 Go to previous messageGo to next message
Anthony Hunter is currently offline Anthony HunterFriend
Messages: 446
Registered: July 2009
Senior Member
Hi John,

This is https://bugs.eclipse.org/bugs/show_bug.cgi?id=111901

Cheers...
Anthony

"John Yotka" <john.yotka@datria.com> wrote in message
news:g4u5qg$sgu$1@build.eclipse.org...
> I've just installed the Ganymede Modeling tools version, migrated my GMF
> application over. Migrated the model files to 2.1 (via popup menu).
> Regenerated the .gmfgen and then regenerated the code. When I run the
> application the "arrow" keys still navigate from shape to shape instead of
> moving the shape. According to the GMF New and Noteworthy, 2.1 M5 should
> have changed this behavior. I am running on under WinXP not a Mac.
>
> Did I do something wrong in migrating from 2.0 to 2.1? Is there some
> configuration item to set in order to get the desired behavior?
Re: arrow keys to move shapes not working [message #196133 is a reply to message #196104] Tue, 08 July 2008 22:58 Go to previous message
John Yotka is currently offline John YotkaFriend
Messages: 144
Registered: July 2009
Senior Member
Anthony Hunter wrote:
> Hi John,
>
> This is https://bugs.eclipse.org/bugs/show_bug.cgi?id=111901
>
> Cheers...
> Anthony
>
> "John Yotka" <john.yotka@datria.com> wrote in message
> news:g4u5qg$sgu$1@build.eclipse.org...
>> I've just installed the Ganymede Modeling tools version, migrated my GMF
>> application over. Migrated the model files to 2.1 (via popup menu).
>> Regenerated the .gmfgen and then regenerated the code. When I run the
>> application the "arrow" keys still navigate from shape to shape instead of
>> moving the shape. According to the GMF New and Noteworthy, 2.1 M5 should
>> have changed this behavior. I am running on under WinXP not a Mac.
>>
>> Did I do something wrong in migrating from 2.0 to 2.1? Is there some
>> configuration item to set in order to get the desired behavior?
>
>
Anthony,

So the bug was reopened for both Win XP and Mac? I'm running under Win
XP. The behavior I get is the same as the old behavior, arrow keys
navigate between shapes.
Previous Topic:Canvas mapping
Next Topic:GMF properties sheet
Goto Forum:
  


Current Time: Sat Jun 06 12:00:37 GMT 2020

Powered by FUDForum. Page generated in 0.02016 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top