Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » mime:multipartRelated not properly serialized?
mime:multipartRelated not properly serialized? [message #195129] Thu, 28 June 2007 00:10
Johann is currently offline JohannFriend
Messages: 8
Registered: July 2009
Junior Member
I'm programmatically generating a WSDL document using the
org.eclipse.wst.wsdl libraries. It's mostly working, except I'm having
trouble writing a mime:multipartRelated element. I set up my
mime:multipartRelated object and fill it with mime:parts containing
mime:contents. But when I serialize the WSDL document to a file, all I get
is an empty mime:multipartRelated element. I've tried to test using the code
in org.eclipse.wst.wsdl.tests.extensions.MIMEExtensionsTest, but that gives
me the same result. Here's the test code that I'm using (pretty much the
same as in

MIMEMultipartRelated multipart = MIME_FACTORY.createMIMEMultipartRelated();
MIMEPart mimePart = MIME_FACTORY.createMIMEPart();

SOAPBody soapBody = SOAP_FACTORY.createSOAPBody();
mimePart = MIME_FACTORY.createMIMEPart();

MIMEContent mimeContent = MIME_FACTORY.createMIMEContent();

Here's the result that I get from the above code.


My org.eclipse.wst.wsdl plugin is v1.0.102.

Can any one give some insight into this?


Previous Topic:multi projects dependencies: WebApp and an Applet
Next Topic:mime:multipartRelated not properly serialized?
Goto Forum:

Current Time: Fri Apr 16 15:36:05 GMT 2021

Powered by FUDForum. Page generated in 0.01950 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top