Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » Missing feedback layer
Missing feedback layer [message #176818] Tue, 12 April 2005 08:59 Go to next message
Eclipse UserFriend
Originally posted by: Johan.Kuijpers.ericsson.com

I'm running a gef editor similar to the logic sample. When placing a
component to
the gef editor and after that trying to move the component a null pointer
exception occurs in:

/**
* Adds the specified <code>Figure</code> to the {@link
LayerConstants#FEEDBACK_LAYER}.
* @param figure the feedback to add
*/
protected void addFeedback(IFigure figure) {
getFeedbackLayer().add(figure);
}

It seems that the methode getFeedbackLayer is returning null instead of the
expected feedback layer:

/**
* Returns the layer used for displaying feedback.
*
* @return the feedback layer
*/
protected IFigure getFeedbackLayer() {
return getLayer(LayerConstants.FEEDBACK_LAYER);
}

Why is there no feedback layer. Where is this layer created/initialized. I
couldn't find the code snippet responsible for this in the logic example.

It is clear that I don't understand something here. Who can point me in the
right direction
Re: Missing feedback layer [message #176844 is a reply to message #176818] Tue, 12 April 2005 09:49 Go to previous message
Pratik Shah is currently offline Pratik ShahFriend
Messages: 1077
Registered: July 2009
Senior Member
The root editpart. You must be modifying the
Scalable(Freeform)RootEditPart.

"Johan Kuijpers" <Johan.Kuijpers@ericsson.com> wrote in message
news:04151757472aba9604b851321aa2105d$1@www.eclipse.org...
> I'm running a gef editor similar to the logic sample. When placing a
> component to
> the gef editor and after that trying to move the component a null pointer
> exception occurs in:
>
> /**
> * Adds the specified <code>Figure</code> to the {@link
> LayerConstants#FEEDBACK_LAYER}.
> * @param figure the feedback to add
> */
> protected void addFeedback(IFigure figure) {
> getFeedbackLayer().add(figure);
> }
>
> It seems that the methode getFeedbackLayer is returning null instead of
the
> expected feedback layer:
>
> /**
> * Returns the layer used for displaying feedback.
> *
> * @return the feedback layer
> */
> protected IFigure getFeedbackLayer() {
> return getLayer(LayerConstants.FEEDBACK_LAYER);
> }
>
> Why is there no feedback layer. Where is this layer created/initialized. I
> couldn't find the code snippet responsible for this in the logic example.
>
> It is clear that I don't understand something here. Who can point me in
the
> right direction
>
Previous Topic:Getting the EditPart
Next Topic:Same Source Target- Bendpoint Problem
Goto Forum:
  


Current Time: Mon Jan 30 12:51:45 GMT 2023

Powered by FUDForum. Page generated in 0.02393 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top