Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Install of rserver-linux-3.5-GA.tar(Java error message when running daemon.pl)
Install of rserver-linux-3.5-GA.tar [message #1102548] Thu, 05 September 2013 22:06 Go to next message
Mark Loveday is currently offline Mark LovedayFriend
Messages: 1
Registered: September 2013
Junior Member
While following the steps defined in the eclipse help guide for setting up dstore on Linux.

Running Java -version reports:

java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 2.3)
IBM J9 VM (build 2.3, J2RE 1.4.2 IBM J9 2.3 Linux amd64-64 j9vmxa64142ifx-20090909 (JIT enabled)
J9VM - 20090908_41946_LHdSMr
JIT - 20090210_1447ifx1_r8
GC - 200902_24)

but when I run (as superuser) perl ./daemon.pl 4075 10000-10010
I just receive the message
'The java class could not be loaded. java.lang.UnsupportedClassVersionError: (org/eclipse/dstore/core/server/ServerLauncher) bad major version at offset=6'

What configuration step am I missing?

Re: Install of rserver-linux-3.5-GA.tar [message #1104901 is a reply to message #1102548] Mon, 09 September 2013 04:36 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3998
Registered: July 2009
Senior Member

You need a newer version of Java. 1.4.2 is way too old. You should be using at least 1.6, possibly even 1.7 (which is what's current).

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Error while running the project
Next Topic:Mylyn Integeration for Pydev
Goto Forum:
  


Current Time: Tue Mar 02 05:38:09 GMT 2021

Powered by FUDForum. Page generated in 0.03409 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top