Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Having problem with Ctrl + Space - Content Assist(Content assist won't work on Eclipse Kepler Java Ide for windows 7)
icon14.gif  Having problem with Ctrl + Space - Content Assist [message #1093463] Sat, 24 August 2013 04:59 Go to next message
Luis Cheng is currently offline Luis ChengFriend
Messages: 1
Registered: August 2013
Junior Member
Hello Fellas,


Im new to java programming and today I wanted to give it a try. Installed JDK and Eclipse IDE for Java. When I'm trying to work through some examples, I can't get the content assist (Ctrl + Space) for commands like sysout or main. The suggested proposal window does pop-up with I press Ctrl + Space, it just won't fill the command line for me. I searched online for some solutions, but none sees to work. Here are the ones I tried:

1. Go to preferences>Java>Editor>Content Assist>Advance then I check Java Proposal. I have also tried checking every type of Java related proposal. Click OK and even restarted, but nothing chances
2. I have tried changing the short-cut key for content assist using something like Shift + Q and again it just pops up the proposal window
3. I originally have 2 keyboard languages and maybe windows 7 was using Ctrl + space to switch languages so I when to Region and Languages and deleted the other language to keep it on english only.
4. I tried uninstalling the program and reinstalling it again, but nothing changes.
5. I tried creating new workspaces to each time but still nothing.

Anybody has any idea of how to get this content assist working. Also, is there anyway to completely uninstall Eclipse. I went to help > about eclipse > install and uninstalled but it seems that folders and other items are still there then I move the rest to the trash bin and try to resinstall it again.

Any help will be appreciated
Re: Having problem with Ctrl + Space - Content Assist [message #1094805 is a reply to message #1093463] Mon, 26 August 2013 08:02 Go to previous message
Jason Lynch is currently offline Jason LynchFriend
Messages: 11
Registered: July 2009
Junior Member
Ctrl + Space must be hijacked by other program; previously it can be used by switching different IMEs;

You can make a test through changing the key bindings and then have a try.

In eclipse:
-perf. page -> input Keys in the filter text; Go the keys setting page, input Content Assistent then you would go there to change keys for content assistent command.

Generally Ctrl + 0 is seldom used, you can have a try....

No need to uninstall eclipse, that's unrelated to this topic.
Previous Topic:exitcode=2 error
Next Topic:eclipse 4 rcp jpa2
Goto Forum:
  


Current Time: Mon Mar 08 01:19:18 GMT 2021

Powered by FUDForum. Page generated in 0.03092 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top