Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Unhandled event loop exception
Unhandled event loop exception [message #1081860] Wed, 07 August 2013 19:48 Go to next message
Mahsa P is currently offline Mahsa PFriend
Messages: 115
Registered: July 2013
Senior Member

I have .ecore file and generate .gmftool , .gmfmap , .gmfgraph from it by GMF dashboard. for creating .gmfgen, first i click on transform on dashboard but give this error: Unhandled event loop exception
by executaion stack trace :

java.lang.NoClassDefFoundError: org/eclipse/gmf/internal/bridge/genmodel/ModeledViewmapProducer
at org.eclipse.gmf.internal.bridge.ui.dashboard.HyperlinkFigure$1.mousePressed(
at org.eclipse.draw2d.Figure.handleMousePressed(
at org.eclipse.draw2d.SWTEventDispatcher.dispatchMousePressed(
at org.eclipse.draw2d.LightweightSystem$EventHandler.mouseDown(
at org.eclipse.swt.widgets.TypedListener.handleEvent(
at org.eclipse.swt.widgets.EventTable.sendEvent(
at org.eclipse.swt.widgets.Widget.sendEvent(
at org.eclipse.swt.widgets.Display.runDeferredEvents(
at org.eclipse.swt.widgets.Display.readAndDispatch(
at org.eclipse.ui.internal.Workbench.runEventLoop(
at org.eclipse.ui.internal.Workbench.runUI(
at org.eclipse.ui.internal.Workbench.access$4(
at org.eclipse.ui.internal.Workbench$
at org.eclipse.core.databinding.observable.Realm.runWithDefault(
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
at org.eclipse.ui.internal.ide.application.IDEApplication.start(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(
at org.eclipse.equinox.launcher.Main.main(
Caused by: java.lang.ClassNotFoundException: org.eclipse.gmf.internal.bridge.genmodel.ModeledViewmapProducer
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(Unknown Source)
... 31 more

what is this error ? what do i should do?
note: I didn't have this error but i deleted some project from my work space
and after it, i give this problem !
i'll be grateful if help me:)

[Updated on: Wed, 07 August 2013 20:32]

Report message to a moderator

Re: Unhandled event loop exception [message #1088902 is a reply to message #1081860] Sat, 17 August 2013 21:52 Go to previous message
Mahsa P is currently offline Mahsa PFriend
Messages: 115
Registered: July 2013
Senior Member
I solved this problem! by deleting all file about eclipse (even .android or .eclipse) and installed eclipse again! after this reinstalling, i get application error that solved this by uninstalling ADT!

for uninstalling the ADT (android development tools): help>about eclipse>installation details> installed software> select ADT> uninstall. and if require it, reinstall ADT with update eclipse or from marketplace:)

[Updated on: Sat, 17 August 2013 22:02]

Report message to a moderator

Previous Topic:Multiple Views on a same domainElement
Next Topic:no gmfgen created
Goto Forum:

Current Time: Thu Feb 25 17:16:11 GMT 2021

Powered by FUDForum. Page generated in 0.02314 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top