Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » two links being shown when diagrams are connected
two links being shown when diagrams are connected [message #160158] Wed, 14 November 2007 07:56 Go to next message
govind is currently offline govindFriend
Messages: 2
Registered: July 2009
Junior Member
hi all

in my gmf project when i try to connect two diagrams it shows to links.

but i want one link ..

plz help me

thanks

Govind R.
Re: two links being shown when diagrams are connected [message #160197 is a reply to message #160158] Wed, 14 November 2007 10:52 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: trommas.yahoo.com

govind wrote:
> hi all
>
> in my gmf project when i try to connect two diagrams it shows to links.

What do you mean by connect two diagrams. Do you mean figures? - In that
case you must specify in gmfgraph that you only want one of the links to
show graphically.

HTH,

Tomas Zijdemans

>
> but i want one link ..
>
> plz help me
> thanks
> Govind R.
>
Re: two links being shown when diagrams are connected [message #160281 is a reply to message #160197] Wed, 14 November 2007 13:59 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: govind.ashrit.xxx.com

thanks..

but where exactly it will be..(as i am new to gmf)

can be bit in detail.

Thanks and Regards
Govind R
Re: two links being shown when diagrams are connected [message #160305 is a reply to message #160197] Wed, 14 November 2007 14:05 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: govind.ashrit.xxx.com

hi..

i need to connect figures..
i think we need to specify in the gmfmap???
but where exactly in that.


Regards
Govind R.
Re: two links being shown when diagrams are connected [message #160394 is a reply to message #160305] Wed, 14 November 2007 15:21 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: trommas.yahoo.com

govind wrote:
> hi..
>
> i need to connect figures..
> i think we need to specify in the gmfmap???
> but where exactly in that.

You should really look in the tutorial, depending on your knowledge. In
gmfgraph you specify graphical element (including links). In gmfmap you
combine the graphics with tools. Then you generate. But again, this is
all covered in the tutorial:

http://wiki.eclipse.org/GMF_Tutorial

HTH,

Tomas Zijdemans
Re: two links being shown when diagrams are connected [message #160508 is a reply to message #160394] Thu, 15 November 2007 05:00 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: govind.ashrit.xxx.com

hi..

I have gone through documentation.

Let me explain..

In my project i have many figures

for ex:

fig1,fig2,fig3,fig4 etc.

when i connect fig 1 and fig 2 it creates a single connection.

my project has feature where in i can add fig 1 and fig2 in fig3

and when i try to connect fig1 and fig2 which are now in fig3 .it shows
two connections ..

hope i am clear

Regards
Govind R.
Re: two links being shown when diagrams are connected [message #160520 is a reply to message #160508] Thu, 15 November 2007 06:37 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: biju_gopinathan.rediffmail.com

Hi Govind,

Check the following bug: this may help you

https://bugs.eclipse.org/bugs/show_bug.cgi?id=148021

Regards, Biju

govind wrote:
> hi..
>
> I have gone through documentation.
> Let me explain..
>
> In my project i have many figures
>
> for ex:
>
> fig1,fig2,fig3,fig4 etc.
>
> when i connect fig 1 and fig 2 it creates a single connection.
>
> my project has feature where in i can add fig 1 and fig2 in fig3
>
> and when i try to connect fig1 and fig2 which are now in fig3 .it shows
> two connections ..
>
> hope i am clear
>
> Regards
> Govind R.
Re: two links being shown when diagrams are connected [message #160831 is a reply to message #160520] Fri, 16 November 2007 08:44 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: govind.ashrit.xxx.com

biju wrote:

> Hi Govind,

> Check the following bug: this may help you

> https://bugs.eclipse.org/bugs/show_bug.cgi?id=148021

> Regards, Biju

> govind wrote:
>> hi..
>>
>> I have gone through documentation.
>> Let me explain..
>>
>> In my project i have many figures
>>
>> for ex:
>>
>> fig1,fig2,fig3,fig4 etc.
>>
>> when i connect fig 1 and fig 2 it creates a single connection.
>>
>> my project has feature where in i can add fig 1 and fig2 in fig3
>>
>> and when i try to connect fig1 and fig2 which are now in fig3 .it shows
>> two connections ..
>>
>> hope i am clear
>>
>> Regards
>> Govind R.
hi biju..

i gone through through that..
i couldn't get any clues...


Regards
Govind R.
Re: two links being shown when diagrams are connected [message #160864 is a reply to message #160831] Fri, 16 November 2007 11:51 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: biju_gopinathan.rediffmail.com

Hi govind,

Did you try overriding:
CanonicalEditPolicy.shouldHandleNotificationEvent()return false;


Biju

govind wrote:
> biju wrote:
>
>> Hi Govind,
>
>> Check the following bug: this may help you
>
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=148021
>
>> Regards, Biju
>
>> govind wrote:
>>> hi..
>>>
>>> I have gone through documentation.
>>> Let me explain..
>>>
>>> In my project i have many figures
>>>
>>> for ex:
>>>
>>> fig1,fig2,fig3,fig4 etc.
>>>
>>> when i connect fig 1 and fig 2 it creates a single connection.
>>>
>>> my project has feature where in i can add fig 1 and fig2 in fig3
>>>
>>> and when i try to connect fig1 and fig2 which are now in fig3 .it
>>> shows two connections ..
>>>
>>> hope i am clear
>>>
>>> Regards
>>> Govind R.
> hi biju..
>
> i gone through through that..
> i couldn't get any clues...
>
>
> Regards
> Govind R.
>
Re: two links being shown when diagrams are connected [message #162104 is a reply to message #160864] Thu, 22 November 2007 16:11 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: govind.ashrit.xxx.com

hi biju

Actually i dont have any method as shouldHandleNotificationEvent();

or if it has to be explicitly added..
Please help in this regard

Regards
Govind R
Re: two links being shown when diagrams are connected [message #162218 is a reply to message #162104] Fri, 23 November 2007 09:07 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: biju_gopinathan.rediffmail.com

Hi Govind,

Check your edit policies, and look for one edit policy which
extends CanonicalConnectionEditPolicy, (That is, The CanonicalEditPolicy
of the container of your links). And there will only be one class that
extends CanonicalConnectionEditPolicy for your digram. In that class
overwirde CanonicalEditPolicy.shouldHandleNotificationEvent(), and
return false;

It worked for me earlier, when I faced the same problem, hope
it helps you.

Cheers, Biju


govind wrote:
> hi biju
>
> Actually i dont have any method as shouldHandleNotificationEvent();
>
> or if it has to be explicitly added..
> Please help in this regard
> Regards
> Govind R
>
Re: two links being shown when diagrams are connected [message #162627 is a reply to message #162218] Mon, 26 November 2007 03:21 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: govind.ashrit.xxx.com

hi..biju

i did the same as u told.. its working,,,,

Thanks a lot...

looking forward for help from u...in future if required....

Thanks & Regards
Govind R.
Re: two links being shown when diagrams are connected [message #1783318 is a reply to message #162627] Mon, 12 March 2018 02:09 Go to previous messageGo to next message
wang shiyu is currently offline wang shiyuFriend
Messages: 18
Registered: June 2017
Junior Member
i met the same question and i do not find some class extends CanonicalEditPolicy with the connection , and when i use this connection it report some mistakes in console : java.lang.IllegalArgumentException: Argument not valid

i do not know how to deal with this problem
Re: two links being shown when diagrams are connected [message #1783319 is a reply to message #1783318] Mon, 12 March 2018 02:38 Go to previous message
wang shiyu is currently offline wang shiyuFriend
Messages: 18
Registered: June 2017
Junior Member
i modified all the CanonicalEditPolicy in .diagram.edit.policies by adding ' protected boolean shouldHandleNotificationEvent(Notification event) {
return false;
} ' this sentence,it works!

the result is showing one link but it still report the errors in console 'java.lang.IllegalArgumentException: Argument not valid'
Previous Topic:Error message: Node is referenced from multiple containers with different 'List Layout' value
Next Topic:DiagramLinkStyle example
Goto Forum:
  


Current Time: Tue Sep 25 08:43:27 GMT 2018

Powered by FUDForum. Page generated in 0.02028 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top