Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Object Mapping Errors(Errors when trying using object mapping)
Object Mapping Errors [message #1049228] Thu, 25 April 2013 14:32 Go to next message
Diane Mising name is currently offline Diane Mising nameFriend
Messages: 22
Registered: June 2011
Junior Member
We have been running into some issues with the object mapping functionality. We have an application where the user fills in some information and clicks a button. When the button is clicked our application does some validation on the inputted information and either continues to the next screen of our application or returns an error message indicating the error. We are trying to test the error message scenario.

We are able to create the test to fill in the fields and click the button. The problem arises when we try to map to the error message field. Here are the things we have tried and the errors are that we are getting.

- If we turn the Object Mapper on before we click the button, the screen never actually processes, it just gets stuck, so the error message never shows up for us to map to.

- If we click the button first & generate the error, then turn on the Object Mapper - we cannot map to anything on the screen anymore. We click on various things & they all just flash red. In our log we see the following error:

2013-04-24 13:45:58.646 [Connection.ReaderThread:Socket[,port=60035,localport=51141]] ERROR c.b.jubula.rc.html.WebAUTServer - error starting object mapping mode due to exception: java.lang.reflect.InvocationTargetException

Is there anything we can do to get past this issue? Thanks for your help.
Re: Object Mapping Errors [message #1051887 is a reply to message #1049228] Mon, 29 April 2013 10:23 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member

From the log entry, it looks like you're working on a HTML AUT - is that correct?

If so, can you say whether the error message appears in its own window, or as a part of the current window? Do you know how it is produced?

Thanks for the info!
Re: Object Mapping Errors [message #1053121 is a reply to message #1051887] Thu, 02 May 2013 14:40 Go to previous message
Diane Mising name is currently offline Diane Mising nameFriend
Messages: 22
Registered: June 2011
Junior Member
Yes, we are working on a HTML AUT. The error message is displayed in the same window. As far as how the error message is produced... the user clicks a button, we pass the information to the server, do some validation and if there is an error, update a row on a table to contain the error message. Here is how we tried to map the table object. We run the application within the AUT and cause a validation edit. When the error message is displayed on the screen, we turn on object mapping and try to map the table. It always flashes red and we are unable to map it.
Previous Topic:New version of jar available to allow testing of dynamic menus
Next Topic:Missing Data in Data Set
Goto Forum:

Current Time: Sun Aug 09 06:05:29 GMT 2020

Powered by FUDForum. Page generated in 0.01579 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top