Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Locking is not possible in the directory(Problem with locking on startup)
Locking is not possible in the directory [message #1029520] Fri, 29 March 2013 20:27 Go to next message
Margaret doll is currently offline Margaret dollFriend
Messages: 1
Registered: March 2013
Junior Member
I downloaded and installed

in /usr/local/ as root.

root can run the program, but other users cannot. They get

Locking is not possible in the directory "/usr/local/eclipse/configuration/org.eclipse.osgi". A common reason is that the file system or Runtime Environment does not support file locking for that location. Please choose a different location, or disable file locking passing "-Dosgi.locking=none" as a VM argument.
/usr/local/eclipse/configuration/org.eclipse.osgi/.manager/.fileTableLock (Permission denied

even if they use

eclipse -vmargs -Dosgi.locking=none

How do I get this program working for ordinary users?

Also I see that logs are created in ../eclipse/configuration. It is inconvenient to clear out these files. Can the logs be sent to the user's home directory or to /var/log/eclipse instead?
Re: Locking is not possible in the directory [message #1053320 is a reply to message #1029520] Fri, 03 May 2013 20:59 Go to previous messageGo to next message
Daniel Jongeling is currently offline Daniel JongelingFriend
Messages: 1
Registered: May 2013
Junior Member
I ran into this problem trying to connect with a network drive. I have succesfully solved this on this environment by adding a line at the end of the config.ini file.


After that I was able to set up a workspace on the network drive. Hope that helps.

icon14.gif  Re: Locking is not possible in the directory [message #1451379 is a reply to message #1053320] Thu, 23 October 2014 18:58 Go to previous message
Ab B is currently offline Ab BFriend
Messages: 1
Registered: October 2014
Junior Member
Thank you so much. I was having the same problem and this fixed my problem with eclipse-jee-indigo-win32.
Previous Topic:Eclipse not starting on Mepis Linux
Next Topic:No Design view tab
Goto Forum:

Current Time: Mon Mar 08 06:19:12 GMT 2021

Powered by FUDForum. Page generated in 0.02933 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top