Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Visual Editor (VE) » Failure to Invoke Editor
Failure to Invoke Editor [message #144858] Fri, 16 May 2008 17:12 Go to next message
Eclipse UserFriend
Originally posted by: remande.alum.wpi.edu

I've installed Eclipse 3.2.2, GEF 3.2.0, and Visual Editor 1.2.1.
However, I can't seem to reach the visual editor. When I "Edit with..." a
file, I don't get a Visual Editor option. When I use the "new Java class"
button on the toolbar, my options are "JUnit test case", "class",
"interface", "enum", and "annotation". But when I go to Help->Software
Updates->Manage Configuration, my Visual Editor package is installed and
enabled, with a sub-package of Java EMF model 1.2.3.

So Eclipse says it's all installed...I just don't get the features.

I'm running on XP Pro over x86. Eclipse is configured to use Java 5.0
compliance.

Any ideas?

Thanks in advance,

--Rob Mandeville
Re: Failure to Invoke Editor [message #144867 is a reply to message #144858] Fri, 16 May 2008 21:11 Go to previous message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

Rob,

Are you sure you're using a 5.0 JVM? Trying running with -clean -debug
and look at the Error log view (<workspace>/.metadata/.log) for clues
why the features might be disabled.


Rob Mandeville wrote:
> I've installed Eclipse 3.2.2, GEF 3.2.0, and Visual Editor 1.2.1.
> However, I can't seem to reach the visual editor. When I "Edit
> with..." a file, I don't get a Visual Editor option. When I use the
> "new Java class" button on the toolbar, my options are "JUnit test
> case", "class", "interface", "enum", and "annotation". But when I go
> to Help->Software Updates->Manage Configuration, my Visual Editor
> package is installed and enabled, with a sub-package of Java EMF model
> 1.2.3.
>
> So Eclipse says it's all installed...I just don't get the features.
>
> I'm running on XP Pro over x86. Eclipse is configured to use Java 5.0
> compliance.
>
> Any ideas?
>
> Thanks in advance,
>
> --Rob Mandeville
>
>
Re: Failure to Invoke Editor [message #617203 is a reply to message #144858] Fri, 16 May 2008 21:11 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 28981
Registered: July 2009
Senior Member
Rob,

Are you sure you're using a 5.0 JVM? Trying running with -clean -debug
and look at the Error log view (<workspace>/.metadata/.log) for clues
why the features might be disabled.


Rob Mandeville wrote:
> I've installed Eclipse 3.2.2, GEF 3.2.0, and Visual Editor 1.2.1.
> However, I can't seem to reach the visual editor. When I "Edit
> with..." a file, I don't get a Visual Editor option. When I use the
> "new Java class" button on the toolbar, my options are "JUnit test
> case", "class", "interface", "enum", and "annotation". But when I go
> to Help->Software Updates->Manage Configuration, my Visual Editor
> package is installed and enabled, with a sub-package of Java EMF model
> 1.2.3.
>
> So Eclipse says it's all installed...I just don't get the features.
>
> I'm running on XP Pro over x86. Eclipse is configured to use Java 5.0
> compliance.
>
> Any ideas?
>
> Thanks in advance,
>
> --Rob Mandeville
>
>
Previous Topic:Failure to Invoke Editor
Next Topic:org.eclipse.emf.codegen.jet.JETException: Template not found: ComponentSetSizeSourceTemplate.javajet
Goto Forum:
  


Current Time: Sat Nov 25 05:56:50 GMT 2017

Powered by FUDForum. Page generated in 0.01817 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software