Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Multiple browser client problems during UIJob
Multiple browser client problems during UIJob [message #139152] Fri, 03 July 2009 03:02 Go to next message
jiamao liu is currently offline jiamao liuFriend
Messages: 9
Registered: July 2009
Junior Member
Dear friends,

I just faced a problem when more than one browser visit the web server.
The detailed situation is described as follows:

(1)I have RAP application which needs to updated the UI. And I use a timer
to call the UIJob defined, which is to refresh the UI as an interval.

(2)When only one browser visit the web server, there is no problem, and
the UI will be updated within an interval. But if there are more than one
browser trying to access, problem will happens "multiple problems have
occurred". Only one of the browser clients work correctly at the same time.

(3)Could anyone please tell me how to solve this problem? Because in one
of our Supervision applications, we need to use the RAP technology. And
this is critical for us.

Thanks in advance
Re: Multiple browser client problems during UIJob [message #141251 is a reply to message #139152] Wed, 22 July 2009 14:39 Go to previous message
Benjamin Muskalla is currently offline Benjamin MuskallaFriend
Messages: 338
Registered: July 2009
Senior Member
Hi,

do you have a snippet or a small application to reproduce the problem?
You may also take a look at the current list of bugs if there is
something which fits into the picture.

Greets
Ben

jiamao liu wrote:
> Dear friends,
>
> I just faced a problem when more than one browser visit the web server.
> The detailed situation is described as follows:
>
> (1)I have RAP application which needs to updated the UI. And I use a
> timer to call the UIJob defined, which is to refresh the UI as an interval.
>
> (2)When only one browser visit the web server, there is no problem, and
> the UI will be updated within an interval. But if there are more than
> one browser trying to access, problem will happens "multiple problems
> have occurred". Only one of the browser clients work correctly at the
> same time.
>
> (3)Could anyone please tell me how to solve this problem? Because in one
> of our Supervision applications, we need to use the RAP technology. And
> this is critical for us.
>
> Thanks in advance
>


--
Benjamin Muskalla | EclipseSource Karlsruhe
http://www.eclipsesource.com | http://twitter.com/eclipsesource
Previous Topic:Problems at RAP installation in Eclipse IDE 3.5
Next Topic:FileDialog
Goto Forum:
  


Current Time: Mon Dec 06 22:56:09 GMT 2021

Powered by FUDForum. Page generated in 0.02056 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top