Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » tearing out my hair trying to start the framework.
tearing out my hair trying to start the framework. [message #129753] Wed, 22 April 2009 22:41 Go to next message
Jason Henriksen is currently offline Jason HenriksenFriend
Messages: 231
Registered: July 2009
Senior Member
I'm getting this exception:

Exception in thread "main" java.lang.NoClassDefFoundError:
org.eclipse.osgi.internal.composite.CompositeImpl
at java.lang.J9VMInternals.verifyImpl(Native Method)
at java.lang.J9VMInternals.verify(J9VMInternals.java:68)
at java.lang.J9VMInternals.verify(J9VMInternals.java:66)
at java.lang.J9VMInternals.verify(J9VMInternals.java:66)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:129)
at
org.eclipse.osgi.framework.internal.core.Framework.createSys temBundle(Framework.java:280)
at
org.eclipse.osgi.framework.internal.core.Framework.initializ e(Framework.java:223)
at
org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:157)
at
org.eclipse.osgi.framework.internal.core.EquinoxLauncher.int ernalInit(EquinoxLauncher.java:68)
at
org.eclipse.osgi.framework.internal.core.EquinoxLauncher.int ernalStart(EquinoxLauncher.java:274)
at
org.eclipse.osgi.framework.internal.core.EquinoxLauncher.sta rt(EquinoxLauncher.java:251)

Caused by: java.lang.ClassNotFoundException:
org.eclipse.osgi.internal.composite.CompositeImpl
at java.net.URLClassLoader.findClass(URLClassLoader.java:496)
at
org.eclipse.osgi.launch.EquinoxFWClassLoader.loadClass(Equin oxFWClassLoader.java:38)
at java.lang.ClassLoader.loadClass(ClassLoader.java:597)


I can't find any reference to this CompositeImpl thing ANYWHERE. I'm
not trying to start anything in a UI, I'm just trying to start the
framework from inside of a java main(). My ultimate goal is to run the
framework code inside a SOAP service under WebSphere, but I can't even
get it to run from a java command line app. :(

Any help is much appreciated.

Jason Henriksen
Re: tearing out my hair trying to start the framework. [message #129823 is a reply to message #129753] Thu, 23 April 2009 15:03 Go to previous messageGo to next message
Jason Henriksen is currently offline Jason HenriksenFriend
Messages: 231
Registered: July 2009
Senior Member
I also get this problem when trying from here:

Exception in thread "main" java.lang.NoClassDefFoundError:
org.eclipse.osgi.internal.composite.CompositeImpl
at java.lang.J9VMInternals.verifyImpl(Native Method)
at java.lang.J9VMInternals.verify(J9VMInternals.java:68)
at java.lang.J9VMInternals.verify(J9VMInternals.java:66)
at java.lang.J9VMInternals.verify(J9VMInternals.java:66)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:129)
at
org.eclipse.osgi.framework.internal.core.Framework.createSys temBundle(Framework.java:280)
at
org.eclipse.osgi.framework.internal.core.Framework.initializ e(Framework.java:223)
at
org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:157)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.startup(Ecli pseStarter.java:286)


So the either way I try to start the framework I get an error.

Please help if you can. If I can't start the framework I'll have to set
Equinox aside for a while. :(

Jason
Re: tearing out my hair trying to start the framework. [message #1828303 is a reply to message #129823] Sat, 06 June 2020 18:37 Go to previous message
milly singh is currently offline milly singhFriend
Messages: 1
Registered: June 2020
Junior Member
tearing out my long bob hair trying to start the framew
org.eclipse.osgi.internal.composite.CompositeImpl
at java.lang.J9VMInternals.verifyImpl(Native Method)
at java.lang.J9VMInternals.verify(J9VMInternals.java:68)
at java.lang.J9VMInternals.verify(J9VMInternals.java:66)
at java.lang.J9VMInternals.verify(J9VMInternals.java:66)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:129)
at
org.eclipse.osgi.framework.internal.core.Framework.createSys temBundle(Framework.java:280)
at
org.eclipse.osgi.framework.internal.core.Framework.initializ e(Framework.java:223)
at
org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:157)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.startup(Ecli pseStarter.java:286)


Previous Topic:P2 Director fails to resolve Java 11 dependency
Next Topic:No copyright or license information for feature-based product
Goto Forum:
  


Current Time: Sun Sep 25 14:58:03 GMT 2022

Powered by FUDForum. Page generated in 0.01429 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top