Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EMFCompare] diff:UpdateUniqueReferenceValue
[EMFCompare] diff:UpdateUniqueReferenceValue [message #127430] Thu, 24 July 2008 09:38 Go to next message
Sabrina Foertsch is currently offline Sabrina FoertschFriend
Messages: 4
Registered: July 2009
Junior Member
hi,
I'm new here and have a question:
Using EMF Compare Editor there are problems with the visualisation of the
following DiffElement (NullpointerException )

<subDiffElements xsi:type="diff:UpdateUniqueReferenceValue">
containing a rightElement and leftElement
and a leftTarget or a rightTarget, but only one target, as the
uniqueReferenceValue has been added or deleted.

Is it a bug ?

When Changing manually "diff:UpdateUniqueReferenceValue" into
"diff:UpdateUniqueReferenceValue" and "..Target" into "..AddedTarget" in
the xmi,
the editor opens the file correctly.


Best regards,
Sabrina
Re: [EMFCompare] diff:UpdateUniqueReferenceValue [message #127451 is a reply to message #127430] Thu, 24 July 2008 10:05 Go to previous message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1881
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------040302070009060309050708
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit

Hi Sabrina,

This seems like a bug as '*AddedTarget" are meant to describe
multi-valued reference differences and "UpdateUniqueReferenceValue" are
for ... well non multi-valued references :). hence
UpdateUniqueReferenceValue *should* work when the value has been
added/removed. Can you fill a bugzilla entry for this?

Thanks

Laurent Goubet
Obeo

Sabrina a
Re: [EMFCompare] diff:UpdateUniqueReferenceValue [message #620141 is a reply to message #127430] Thu, 24 July 2008 10:05 Go to previous message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1881
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------040302070009060309050708
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit

Hi Sabrina,

This seems like a bug as '*AddedTarget" are meant to describe
multi-valued reference differences and "UpdateUniqueReferenceValue" are
for ... well non multi-valued references :). hence
UpdateUniqueReferenceValue *should* work when the value has been
added/removed. Can you fill a bugzilla entry for this?

Thanks

Laurent Goubet
Obeo

Sabrina a
Previous Topic:[EMFCompare] diff:UpdateUniqueReferenceValue
Next Topic:CGLib proxy issue in Teneo 1.0 for One-To-One relationship
Goto Forum:
  


Current Time: Mon Mar 30 14:52:02 GMT 2020

Powered by FUDForum. Page generated in 0.01622 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top