Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » NullPointerException in Tomcat
NullPointerException in Tomcat [message #126659] Wed, 01 April 2009 07:16 Go to next message
Anton Hergenröder is currently offline Anton HergenröderFriend
Messages: 3
Registered: July 2009
Junior Member
Hi,
I'm getting this error while running hello-world RAP-example in tomcat.
It's not a .war file, it's running out of eclipse and all JARs from the
RAP-runtime are in the WEB-INF/lib directory. plugin.xml and xxx.launch
are not exported, do i need them? where exactly do I need them to be?

Any suggestions? Please help me...

type Exception report

message

description The server encountered an internal error () that prevented it
from fulfilling this request.

exception

java.lang.NullPointerException
org.eclipse.ui.internal.Workbench.initializeImages(Workbench .java:1533)
org.eclipse.ui.internal.Workbench.createDisplay(Workbench.ja va:567)
org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:168)
rapexample.Application.createUI(Application.java:15)
org.eclipse.rwt.internal.lifecycle.EntryPointManager.createU I(EntryPointManager.java:92)
org.eclipse.rwt.internal.lifecycle.RWTLifeCycle.createUI(RWT LifeCycle.java:228)
org.eclipse.rwt.internal.lifecycle.RWTLifeCycle$UIThreadCont roller.run(RWTLifeCycle.java:116)
java.lang.Thread.run(Thread.java:619)

note The full stack trace of the root cause is available in the Apache
Tomcat/6.0.18 logs.
Re: NullPointerException in Tomcat [message #126671 is a reply to message #126659] Wed, 01 April 2009 07:48 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Anton,

as a starting point get the org.eclipse.rap.demo.feature project from
the CVS and try to export/build the RAP demo with it. In addition there
are a lot of posts in the newsgroup about how to deploy RAP application
in Tomcat.

Best,
Ivan

Anton Hergenröder wrote:
> Hi,
> I'm getting this error while running hello-world RAP-example in
> tomcat. It's not a .war file, it's running out of eclipse and all JARs
> from the RAP-runtime are in the WEB-INF/lib directory. plugin.xml and
> xxx.launch are not exported, do i need them? where exactly do I need
> them to be?
>
> Any suggestions? Please help me...
>
> type Exception report
>
> message
>
> description The server encountered an internal error () that prevented
> it from fulfilling this request.
>
> exception
>
> java.lang.NullPointerException
> org.eclipse.ui.internal.Workbench.initializeImages(Workbench .java:1533)
>
> org.eclipse.ui.internal.Workbench.createDisplay(Workbench.ja va:567)
> org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:168)
> rapexample.Application.createUI(Application.java:15)
> org.eclipse.rwt.internal.lifecycle.EntryPointManager.createU I(EntryPointManager.java:92)
>
> org.eclipse.rwt.internal.lifecycle.RWTLifeCycle.createUI(RWT LifeCycle.java:228)
>
> org.eclipse.rwt.internal.lifecycle.RWTLifeCycle$UIThreadCont roller.run(RWTLifeCycle.java:116)
>
> java.lang.Thread.run(Thread.java:619)
>
> note The full stack trace of the root cause is available in the Apache
> Tomcat/6.0.18 logs.
>
Re: NullPointerException in Tomcat [message #126717 is a reply to message #126671] Wed, 01 April 2009 09:22 Go to previous messageGo to next message
Anton Hergenröder is currently offline Anton HergenröderFriend
Messages: 3
Registered: July 2009
Junior Member
I've already read a lot about deploying RAP-apps, but i just can't get rid
of this exception :(
Re: NullPointerException in Tomcat [message #126743 is a reply to message #126717] Wed, 01 April 2009 09:49 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Anton,

what is not clear to me is do you use the org.eclipse.rap.demo.feature
and webappBuilder.xml ant script to prepare the application for
deployment? If yes - what is the content of
org.eclipse.rap.demo.feature/build directory after the ant script
execution? Are all the plugins exported successfully?

Best,
Ivan

Anton Hergenröder wrote:
> I've already read a lot about deploying RAP-apps, but i just can't get
> rid of this exception :(
>
Re: NullPointerException in Tomcat [message #126756 is a reply to message #126743] Wed, 01 April 2009 11:11 Go to previous messageGo to next message
Anton Hergenröder is currently offline Anton HergenröderFriend
Messages: 3
Registered: July 2009
Junior Member
I'm using the RAP in a WebApp project, so i can publish it to Tomcat
running as an Eclipse-Server-Configuration. So i think no buildscripts
from RAP are executed. All the RAP runtime jars are exported to the Tomcat
webapp directory (WEB-INF/lib). A lot of javascript and icons from RWT? is
somewhere there as well. The classes are in WEB-INF/classes and the entry
point for the webapp is reached. It fails somewhere else (i can see the
background of the demo for a moment). I need to run the application that
way for development. I hope there is a way to get it right through some
configuration.
Re: NullPointerException in Tomcat [message #126769 is a reply to message #126756] Wed, 01 April 2009 11:45 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Anton,

I will suggest you to try first to deploy a RAP application as it is
shown here [1]. There is a screencast and ready to use example. Once you
have a running RAP application in Tomcat, you will see where to place
your files and which files are needed.

[1]
http://eclipsesource.com/blogs/2007/12/07/rap-deployment-par t-2-deploying-your-application-as-a-war-file/

Best,
Ivan

Anton Hergenröder wrote:
> I'm using the RAP in a WebApp project, so i can publish it to Tomcat
> running as an Eclipse-Server-Configuration. So i think no buildscripts
> from RAP are executed. All the RAP runtime jars are exported to the
> Tomcat webapp directory (WEB-INF/lib). A lot of javascript and icons
> from RWT? is somewhere there as well. The classes are in
> WEB-INF/classes and the entry point for the webapp is reached. It
> fails somewhere else (i can see the background of the demo for a
> moment). I need to run the application that way for development. I
> hope there is a way to get it right through some configuration.
>
Re: NullPointerException in Tomcat [message #127305 is a reply to message #126769] Mon, 06 April 2009 10:18 Go to previous message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1313
Registered: July 2009
Senior Member

Hi Anton,

we don't use web tools here, so we cannot advise with this case. But I
agree with Ivan, you should start with a normal war file deployment.
Then you can see what is needed and can mimic the contents of the war
file in your web tools project.

> [1]
> http://eclipsesource.com/blogs/2007/12/07/rap-deployment-par t-2-deploying-your-application-as-a-war-file/

I'd rather suggest that you refer to the RAP Help with has an chapter on
war deployment, too. It's included in your Eclipse IDE if you have RAP
Tooling installed. The help is more up to date and the blog post above
contains an approach that is not recommendable from our point of view.

Next thing you should do is get an OSGi console (enable -console in your
web.xml) and see which bundles are installed and active.

Best regards, Ralf
Previous Topic:Margin height incorrect sizing
Next Topic:Tomcat ROOT
Goto Forum:
  


Current Time: Sun Dec 05 21:00:06 GMT 2021

Powered by FUDForum. Page generated in 0.02849 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top