Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » comparison of *.xmi via EMF Compare not possible
comparison of *.xmi via EMF Compare not possible [message #122616] Sat, 17 May 2008 09:03 Go to next message
Eclipse UserFriend
Originally posted by: mam05eux.studserv.uni-leipzig.de

Hi,

I need to compare some Models with the ending .xmi using EMF Compare.
The point is that I theoretically know how to enable the comparison via
EMF Compar to these extensions (Window/Preferences/General/Content
Types/Model Files...)

Now my problem:
There is no entry Model Files! instead of this there is an entry called
EMF Compare. OK, I opened it and saw that there already was an extension
called *.xmi!!! But it doesn?t work.
Ok for testing the content-type-bindings I added the extension
*.genmodel and was able to compare the models via EMF Compare!

So can anyone help me going ahead?
Re: comparison of *.xmi via EMF Compare not possible [message #122825 is a reply to message #122616] Thu, 22 May 2008 09:17 Go to previous message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1881
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------080000010900080101020602
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit

Stanley,

Sorry for the late answer. This problem means that another of your
plugins already provides a binding to *.xmi (most probably WTP),
preventing ours to be used in finding the comparator as per bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=220457 .

This is something we can't help as of now ... If you happen to know
which content type is defining the binding to *.xmi we should be able to
work around it as we did for org.eclipse.emf.ecore (causing bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=217986 ).

Laurent Goubet
Obeo

Stanley Hillner a
Re: comparison of *.xmi via EMF Compare not possible [message #618119 is a reply to message #122616] Thu, 22 May 2008 09:17 Go to previous message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1881
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------080000010900080101020602
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit

Stanley,

Sorry for the late answer. This problem means that another of your
plugins already provides a binding to *.xmi (most probably WTP),
preventing ours to be used in finding the comparator as per bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=220457 .

This is something we can't help as of now ... If you happen to know
which content type is defining the binding to *.xmi we should be able to
work around it as we did for org.eclipse.emf.ecore (causing bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=217986 ).

Laurent Goubet
Obeo

Stanley Hillner a
Previous Topic:[CDO 0.8.0] EMap
Next Topic:Teneo Build Announcement Thread
Goto Forum:
  


Current Time: Sat Mar 28 19:03:34 GMT 2020

Powered by FUDForum. Page generated in 0.02013 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top