Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » ClassNotFoundException: org.eclipse.xtext.ecore.EcoreSupportStandaloneSetup(ClassNotFoundException: org.eclipse.xtext.ecore.EcoreSupportStandaloneSetup when running the workflow)
icon8.gif  ClassNotFoundException: org.eclipse.xtext.ecore.EcoreSupportStandaloneSetup [message #910464] Sun, 09 September 2012 19:09 Go to next message
Olaf Bigalk is currently offline Olaf BigalkFriend
Messages: 141
Registered: July 2009
Location: Berlin
Senior Member
Hello,

I have defined a grammar which is importing the Ecor metamodel.
I have an import line for the model in my grammar file.
I have a loadResource line in the language section of the generator component
I have a registerGenModelFile line and a registerGeneratedEPackage line in the StandaloneSetup bean.
And I get this exception:
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.eclipse.emf.mwe2.language.factory.SettingProviderImpl$1$1.setValue(SettingProviderImpl.java:54)
	... 37 more
Caused by: java.lang.NoClassDefFoundError: org/eclipse/xtext/ecore/EcoreSupportStandaloneSetup
	at org.eclipse.xtext.generator.LanguageConfig.setUri(LanguageConfig.java:175)
	... 42 more
Caused by: java.lang.ClassNotFoundException: org.eclipse.xtext.ecore.EcoreSupportStandaloneSetup
	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
	... 43 more


Can any body tell my in which bundle I can find the missing class.
Re: ClassNotFoundException: org.eclipse.xtext.ecore.EcoreSupportStandaloneSetup [message #910469 is a reply to message #910464] Sun, 09 September 2012 19:28 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13464
Registered: July 2009
Senior Member
hi,

there is org.eclipse.xtext.ecore


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: ClassNotFoundException: org.eclipse.xtext.ecore.EcoreSupportStandaloneSetup [message #910490 is a reply to message #910464] Sun, 09 September 2012 20:45 Go to previous messageGo to next message
Olaf Bigalk is currently offline Olaf BigalkFriend
Messages: 141
Registered: July 2009
Location: Berlin
Senior Member
I forgot to mention the issue occures only in eclipse Juno and it seems to be a bug in P2 that the required plugin could not be loaded from the users home plugin installation folder.
Re: ClassNotFoundException: org.eclipse.xtext.ecore.EcoreSupportStandaloneSetup [message #910492 is a reply to message #910490] Sun, 09 September 2012 20:52 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13464
Registered: July 2009
Senior Member
strange i do not know of such issues

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:Guidance on M2M transformation
Next Topic:XText hover swallows marker resolution extension points
Goto Forum:
  


Current Time: Mon May 25 21:58:11 GMT 2020

Powered by FUDForum. Page generated in 0.01984 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top