Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Table cell padding not working when markup is enabled
Table cell padding not working when markup is enabled [message #902941] Tue, 21 August 2012 10:41 Go to next message
sun Missing name is currently offline sun Missing nameFriend
Messages: 4
Registered: July 2009
Junior Member
If markup is enabled for table and padding is specified for table cell in CSS then at top no padding is there and at bottom double padding is there for the cell. Left and right padding is having required effect.

Code which enables markup for the table widget,
table.setData(RWT.MARKUP_ENABLED, Boolean.TRUE);

CSS,
Table-Cell
{
padding: 5px;
}

Please let me know if any other info is required. Is there any work around for this till the time some fix is available?


Have already file a bugzilla - https://bugs.eclipse.org/bugs/show_bug.cgi?id=387538

Regards
Sun
Re: Table cell padding not working when markup is enabled [message #903129 is a reply to message #902941] Wed, 22 August 2012 07:25 Go to previous message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1313
Registered: July 2009
Senior Member

Hi Sun,

The Markup support also accepts style attributes. As a workaround, you
could try to add something like <span style="padding:5px">Test</span>.

HTH, Ralf

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:JPA with Eclipselink MySQL jdbc in Eclipse RAP/RCP
Next Topic:Optimized table automated testing using Selenium WebDriver
Goto Forum:
  


Current Time: Mon Oct 25 13:22:12 GMT 2021

Powered by FUDForum. Page generated in 0.01525 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top