Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot get Internal Browser to work using webkit - [Eclipse 3.7.2 - Ubuntu 11.10]
Cannot get Internal Browser to work using webkit - [Eclipse 3.7.2 - Ubuntu 11.10] [message #899691] Wed, 01 August 2012 20:59 Go to next message
Jonathan Williams is currently offline Jonathan WilliamsFriend
Messages: 1
Registered: August 2012
Junior Member
Hi,

I've been struggling with trying to get the internal browser to work in Eclipse.

I do plug in development, and some of the plugins utilize the internal browser. The problem I'm experiencing is that on Linux, these plug ins fail to launch the internal browser ( MOZILLA_FIVE_HOME not set ). I did the obvious bit of Googling and learned the concensus was to use webkit to avoid some of the headaches of getting a the correct version of XULRunner to work.

I've ensured I have libwebkitgtk installed like so:

$ locate libwebkitgtk
/usr/lib/libwebkitgtk-1.0.so.0
/usr/lib/libwebkitgtk-1.0.so.0.7.3
/usr/lib/libwebkitgtk-3.0.so.0
/usr/lib/libwebkitgtk-3.0.so.0.7.3

and I've consulted the following FAQ entries:
http://www.eclipse.org/swt/faq.php#browserlinux
http://www.eclipse.org/swt/faq.php#browserspecifydefault
http://www.eclipse.org/swt/faq.php#browserwebkitgtk

and haven't been able to get the Window -> Preferences -> General -> Web Browser -> 'Use internal web browser' button to be un-grayed.

Any help is appreciated!
Re: Cannot get Internal Browser to work using webkit - [Eclipse 3.7.2 - Ubuntu 11.10] [message #987496 is a reply to message #899691] Mon, 26 November 2012 21:13 Go to previous message
Mark Mikofski is currently offline Mark MikofskiFriend
Messages: 3
Registered: August 2012
Junior Member
Hi Jonathan,

I'm sure by now you've seen Bug 392967. The issue I believe is that eclipse doesn't recognize libwebkitgtk-3.0, uninstall it and perhaps the internal browser will now work.
Previous Topic:Swing Designer
Next Topic:new to java. pls help me
Goto Forum:
  


Current Time: Tue Apr 20 11:51:28 GMT 2021

Powered by FUDForum. Page generated in 0.03567 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top