Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » guava dependencies
guava dependencies [message #898507] Thu, 26 July 2012 13:52 Go to next message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 430
Registered: July 2009
Location: Gothenburg
Senior Member
Hi!

Two issues here:

* Are there any plans to update the guava dependency to a newer version? I have a project that uses r11 (possibly soon even r12) and I can't use xtend there because of the conflicting versions.

* There is an older post (http://www.eclipse.org/forums/index.php/mv/msg/266685/766789/#msg_766789) where it was pointed out that some xtext plugins reference guava version 1.0.0, instead of presumably 10.0.1. I can't find a bug report for that and it looks like it's the same in the latest versions. I will file a bug report.

best regards,
Vlad
Re: guava dependencies [message #899014 is a reply to message #898507] Mon, 30 July 2012 07:41 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3108
Registered: July 2009
Senior Member
Hi Vlad,

which problems did you face? IIRC we do not restrict the Guave version
with an upper constraint. Having one that uses 1.0.0 as lower bound by
accident should not cause any trouble, either.

Regards,
Sebastian
--
Looking for professional support for Xtext, Xtend or Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 26.07.12 15:52, schrieb Vlad Dumitrescu:
> Hi!
>
> Two issues here:
> * Are there any plans to update the guava dependency to a newer version?
> I have a project that uses r11 (possibly soon even r12) and I can't use
> xtend there because of the conflicting versions.
>
> * There is an older post
> (http://www.eclipse.org/forums/index.php/mv/msg/266685/766789/#msg_766789)
> where it was pointed out that some xtext plugins reference guava version
> 1.0.0, instead of presumably 10.0.1. I can't find a bug report for that
> and it looks like it's the same in the latest versions. I will file a
> bug report.
>
> best regards,
> Vlad
Re: guava dependencies [message #899019 is a reply to message #899014] Mon, 30 July 2012 07:57 Go to previous messageGo to next message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 430
Registered: July 2009
Location: Gothenburg
Senior Member
Sebastian Zarnekow wrote on Mon, 30 July 2012 09:41
Hi Vlad,
which problems did you face? IIRC we do not restrict the Guave version
with an upper constraint. Having one that uses 1.0.0 as lower bound by
accident should not cause any trouble, either.

Am 26.07.12 15:52, schrieb Vlad Dumitrescu:

> * There is an older post
> (http://www.eclipse.org/forums/index.php/mv/msg/266685/766789/#msg_766789)
> where it was pointed out that some xtext plugins reference guava version
> 1.0.0, instead of presumably 10.0.1. I can't find a bug report for that
> and it looks like it's the same in the latest versions. I will file a
> bug report.


I couldn't update some plugins and eclipse complained about conflicting versions of the guava plugins, among other things. Unfortunately I didn't save the logs and I have reinstalled everything since then. It could have been a side-effect or something, you are right that the bogus lower-bound should not do any trouble.

Regarding my other question, do you have plans to upgrade guava to r11?

regards,
Vlad
Re: guava dependencies [message #899694 is a reply to message #899019] Wed, 01 August 2012 21:27 Go to previous message
Benjamin Schwertfeger is currently offline Benjamin SchwertfegerFriend
Messages: 53
Registered: July 2009
Member
Hello Sebastian,
in xtext.xbase.lib the dependency is set to 10.0.1 which is translated to (10.0.1,11.0.0] until the plugin is released. I have a similar problem in my target, but I can select explicit 10.0.1 as target version. Perhaps no constraint or an explicit upper bound could help.

Regards,
Benjamin
Previous Topic:how to generate the ecore model from your grammar
Next Topic:quick fix (ISemanticModification) for file with errors?
Goto Forum:
  


Current Time: Thu Dec 03 01:24:32 GMT 2020

Powered by FUDForum. Page generated in 0.01963 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top