Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Xtext sometimes fails to resolve references in global scope
Xtext sometimes fails to resolve references in global scope [message #896625] Thu, 19 July 2012 07:50
Aaron Digulla is currently offline Aaron DigullaFriend
Messages: 258
Registered: July 2009
Location: Switzerland
Senior Member
I'm using Xtext 2.3.0. I'm only overriding ITypesystem and IAllContainersState.Provider (as per bug 382555).

In my test case, I load two resource sets. One defines libraries and the second contains a reference to one or more libraries ("(libs += [LibDef])*" in the grammar)

My problem: Sometimes, I get "ERROR:Couldn't resolve reference to LibDef 'base'". Specifically, the test passes when I run it from the command line using Tycho to build the bundles and it fails inside of Eclipse when I run it as plain JUnit test.

I also tried to run it as JUnit Plugin test but that fails because of Guice classpath issues (see bug 383889)

My questions:

1. Where in the code does Xtend collect the instances to resolve proxies of type LibDef?

2. Where is the error message "Couldn't resolve reference to" created?

3. How can I dump the active scope when the error is created?
Previous Topic:Adding metadata to emf AST before generator/validator phase?
Next Topic:Problem with get xtext resource for Xtend's doGenerate
Goto Forum:
  


Current Time: Thu Jul 09 08:27:35 GMT 2020

Powered by FUDForum. Page generated in 0.01750 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top