Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » org.eclipse.equinox.p2.core.ProvisionException(RCP product based on features (Eclipse Indigo))
org.eclipse.equinox.p2.core.ProvisionException [message #896612] Thu, 19 July 2012 07:21 Go to next message
sajja Phani is currently offline sajja PhaniFriend
Messages: 26
Registered: August 2011
Junior Member
In my RCP application, I have define a product which is based on features with p2 support. I have added all the dependencies to the features --> plugins. I exported the product for Linux gtk 32 and 64 bit versions.

My development system is Ubuntu 64bit. The exported 64 bit version is running fine on my machine and another 64 bit Fedora system for update (Install New Software).

When I run the 32 bit version it is giving the org.eclipse.equinox.p2.core.ProvisionException in a window and the log says

!SESSION 2012-07-19 11:25:08.149 -----------------------------------------------
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_IN
Command-line arguments:  -os linux -ws gtk -arch x86

!ENTRY in.expertsoftware.sampark.dashboard 1 0 2012-07-19 11:25:09.012
!MESSAGE Starting Dashboard!!

!ENTRY 1 0 2012-07-19 11:25:32.591
!MESSAGE System property http.proxyHost is not set but should be ....

!ENTRY 1 0 2012-07-19 11:25:32.594
!MESSAGE System property http.proxyPort is not set but should be 8080.

!ENTRY org.eclipse.equinox.p2.metadata.repository 4 0 2012-07-19 11:25:38.258
!MESSAGE Unexpected error loading extension: org.eclipse.equinox.p2.metadata.repository.simpleRepository
java.lang.NoClassDefFoundError: Could not initialize class org.apache.commons.httpclient.HttpClient
	at org.eclipse.ecf.provider.filetransfer.httpclient.HttpClientBrowseFileTransferFactory$1.sendBrowseRequest(
	at org.eclipse.ecf.provider.filetransfer.browse.MultiProtocolFileSystemBrowserAdapter.sendBrowseRequest(
	at org.eclipse.equinox.internal.p2.transport.ecf.FileInfoReader.sendBrowseRequest(
	at org.eclipse.equinox.internal.p2.transport.ecf.FileInfoReader.getRemoteFiles(
	at org.eclipse.equinox.internal.p2.transport.ecf.FileInfoReader.getRemoteFile(
	at org.eclipse.equinox.internal.p2.transport.ecf.FileInfoReader.getLastModified(
	at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryTransport.getLastModified(
	at org.eclipse.equinox.internal.p2.repository.CacheManager.createCache(
	at org.eclipse.equinox.internal.p2.metadata.repository.SimpleMetadataRepositoryFactory.getLocalFile(
	at org.eclipse.equinox.internal.p2.metadata.repository.SimpleMetadataRepositoryFactory.load(
	at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.factoryLoad(
	at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(
	at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(
	at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(
	at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(
	at org.eclipse.equinox.p2.ui.LoadMetadataRepositoryJob.doLoad(
	at org.eclipse.equinox.p2.ui.LoadMetadataRepositoryJob.runModal(
	at org.eclipse.equinox.internal.p2.ui.sdk.PreloadingRepositoryHandler$2.runModal(

The org.apache.commons.httpclient plugin is present in the plugins directory.
Even after setting the proxy in Network preferences it is giving the same error.

What might be the problem?

Note: The problem is with Fedora 8 32bit and working fine with Fedora 14 32bit


[Updated on: Fri, 20 July 2012 06:10]

Report message to a moderator

Re: org.eclipse.equinox.p2.core.ProvisionException [message #897717 is a reply to message #896612] Wed, 25 July 2012 07:19 Go to previous message
Sabir pasha is currently offline Sabir pashaFriend
Messages: 70
Registered: February 2010
try with some older version of org.apache.commons.httpclient plugin it looks to me like the httpclient plugin has some issue with Fedora 8 might be you can use a older versin to just cross-check
Previous Topic:Installing plugin into eclipse using command line
Next Topic:Run product in IDE. Features not apear in about dialog.
Goto Forum:

Current Time: Tue Feb 27 19:41:34 GMT 2024

Powered by FUDForum. Page generated in 0.02521 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top