Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » BPEL Designer » [SOLVED] deploy.xml and missing Associated Port([SOLVED] deploy.xml and missing Associated Port plus impossible to write expression value in a "assign" action)
[SOLVED] deploy.xml and missing Associated Port [message #895663] Sat, 14 July 2012 11:57 Go to next message
AxA AxA is currently offline AxA AxAFriend
Messages: 5
Registered: July 2012
Junior Member

I'm following this tutorial: (Can't insert links yet Wink) http***://

And I'm having two main problems:

1) When I create the 2 "assign" actions, I'm not able (as in the screenshots presented in the tutorial) to insert my own expression. I can't write anything in the text field. Eventually, for the sake of completing the tutorial, I manually modified the .bpel file and added the expressions I needed.

2) Although all the files *.bpel, *.wsdl are in the same -bpelContent- folder, when I create the file deploy.xml (in this same folder), in the ODE deployment Editor I don't have any item in the -Associated Port- menu list. And I'm not sure how to manually edit deploy.xml

Eventually, I'm not able to complete the tutorial.
Does anybody know a solution for these issues? Thanks!

[Updated on: Sat, 14 July 2012 19:39]

Report message to a moderator

Re: deploy.xml and missing Associated Port [message #895679 is a reply to message #895663] Sat, 14 July 2012 19:37 Go to previous message
AxA AxA is currently offline AxA AxAFriend
Messages: 5
Registered: July 2012
Junior Member
working around for some hours it seems I got a solution for both the problems:

1) In the tutorial the suggested version of Eclipse to use is either Indigo3.7 or Helios3.6. I was using Juno4.2. I downloaded Indigo3.7 and installed the BPEL plugin (tried both with 0.5.0 and 1.0.0), everything works fine, I can always add text in the expressions now.

2) deploy.xml is actually working fine in all the version (even in Juno). The problem is the GUI, clicking on -AssociatePort- doesn't show any list, until I clicked twice by chance and understood that the menu list is there, it's just hard to make it compare! Eventually the most reliable way to get the list appear is to click once and then use the keyboard arrows.

Previous Topic:Please help! Simple BPEL Process.
Next Topic:Expression editor doesn't work in Juno
Goto Forum:

Current Time: Tue Aug 09 18:08:44 GMT 2022

Powered by FUDForum. Page generated in 0.01963 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top