Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Backward compatibilty of xtext versions in the future expectable?
Backward compatibilty of xtext versions in the future expectable? [message #893779] Thu, 05 July 2012 13:51
Hannes Müller is currently offline Hannes MüllerFriend
Messages: 24
Registered: June 2012
Junior Member
Hello xtext developers,

I have a question because of the backword compatibility of the xtext versions.

I used Xtext a while ago (version 2.1) and after some time I installed Xtext 2.3 and deployed my old files. They just not worked because you have to use the new method "allContents.toIterable" here:
for(e: resource.allContents.toIterable.filter(typeof(Entity))) {

Problem: The old method wasn't supported anymore - even the library wasn't found anymore which was needed for the library.

I know that you developers know this issue because it was discussed in other threads.

Now my question: Must I reckon with those "problems" in the future or will you reach a point in the near future when you can guarantee backward compatibility for future updates? Else I have to think about how to solve the problems which can occur if you install a newer version (maybe stay on a version until you absolutly want a feature which is in a newer version).

Thanks in advance for any answer
Hannes

[Updated on: Thu, 05 July 2012 13:52]

Report message to a moderator

Previous Topic:Using the AST without eclipse
Next Topic:Individuall deployment folder for generated files (xtend2/xtext2)
Goto Forum:
  


Current Time: Mon Feb 24 09:19:53 GMT 2020

Powered by FUDForum. Page generated in 0.05862 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top