Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Installing on E4.2(Installing CDO on E4.2)
[CDO] Installing on E4.2 [message #892393] Thu, 28 June 2012 05:00 Go to next message
Neeraj Bhusare is currently offline Neeraj BhusareFriend
Messages: 138
Registered: July 2009
Location: Canada
Senior Member
Hi,
I am finding it difficult to install "CDO-4.1" on the latest Juno/E4.2 release. Details provided below. Any help/pointers would be highly appreciated.

Update site:
http://download.eclipse.org/modeling/emf/cdo/updates/releases/4.1/

Error message:
Cannot complete the install because one or more required items could not be found.
Software being installed: CDO Electronic Restaurant Example 4.1.0.v20120612-1031 (org.gastro.feature.group 4.1.0.v20120612-1031)
Missing requirement: CDO Electronic Restaurant Example RCP 4.1.0.v20120612-0832 (org.gastro.rcp 4.1.0.v20120612-0832) requires 'bundle org.eclipse.nebula.widgets.gallery [0.0.1,1.0.0)' but it could not be found
Cannot satisfy dependency:
From: CDO Electronic Restaurant Example 4.1.0.v20120612-1031 (org.gastro.feature.group 4.1.0.v20120612-1031)
To: org.gastro.rcp.table [4.0.100.v20120612-0832]

I am using the latest Juno/E4.2 release (Eclipse Modeling Tools), Build id: 20120620-1657


Twitter : @NeerajBhusare
Blog : https://nbhusare.github.io/
Best regards, Neeraj
Re: [CDO] Installing on E4.2 [message #892394 is a reply to message #892393] Thu, 28 June 2012 05:28 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6441
Registered: July 2009
Senior Member
Am 28.06.2012 07:00, schrieb Neeraj Bhusare:
> Hi,
> I am finding it difficult to install "CDO-4.1" on the latest Juno/E4.2 release. Details provided below. Any
> help/pointers would be highly appreciated.
>
> Update site:
> http://download.eclipse.org/modeling/emf/cdo/updates/releases/4.1/
>
> Error message:
> Cannot complete the install because one or more required items could not be found.
> Software being installed: CDO Electronic Restaurant Example 4.1.0.v20120612-1031 (org.gastro.feature.group
> 4.1.0.v20120612-1031)
> Missing requirement: CDO Electronic Restaurant Example RCP 4.1.0.v20120612-0832 (org.gastro.rcp 4.1.0.v20120612-0832)
> requires 'bundle org.eclipse.nebula.widgets.gallery [0.0.1,1.0.0)' but it could not be found
It tells you that you need the Nebula Gallery Widget. The bookmarks.xml file that we list with each build contains all
needed p2 URLs. You can simply import it into p2 and then you should be fine.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper





> Cannot satisfy dependency:
> From: CDO Electronic Restaurant Example 4.1.0.v20120612-1031 (org.gastro.feature.group 4.1.0.v20120612-1031)
> To: org.gastro.rcp.table [4.0.100.v20120612-0832]
>
> I am using the latest Juno/E4.2 release (Eclipse Modeling Tools), Build id: 20120620-1657
>


Re: [CDO] Installing on E4.2 [message #892407 is a reply to message #892394] Thu, 28 June 2012 07:14 Go to previous message
Neeraj Bhusare is currently offline Neeraj BhusareFriend
Messages: 138
Registered: July 2009
Location: Canada
Senior Member
Imported the bookmarks.xml. In addition to the Nebula Gallery Widget, I had to install the Hibernate bundles (http://www.elver.org/eclipse/2.0.0/update) to get the CDO update working. Thanks for the help.

Twitter : @NeerajBhusare
Blog : https://nbhusare.github.io/
Best regards, Neeraj
Previous Topic:how can we import a specific Ecore model in another Ecore
Next Topic:my EMF model generated tests...
Goto Forum:
  


Current Time: Sat Aug 24 02:35:31 GMT 2019

Powered by FUDForum. Page generated in 0.02606 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top