Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » problem: build emf project(problem: build emf project)
icon5.gif  problem: build emf project [message #890157] Thu, 21 June 2012 10:08 Go to next message
Adnen Masmoudi is currently offline Adnen MasmoudiFriend
Messages: 4
Registered: June 2012
Junior Member

Hello, when I build my EMF projet, 2 errors appear:

1) In the build properties, the message is : Build entries must contain at least one value.
And when I go to the sourse of error, I find this line:
source.library.jar =
2)the message is : The JRE container or the class path is not perfect match to the JavaSE 1.6 extention envirenment : sourse MANIFEST.MF.
And when I go to the sourse of error, I find this line:
Bundle-RequiredExecutionEnvironment: JavaSE-1.6


What should I do, please.
Thanks a lot

[Updated on: Thu, 21 June 2012 10:15]

Report message to a moderator

Re: build emf project [message #890171 is a reply to message #890157] Thu, 21 June 2012 11:08 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30372
Registered: July 2009
Senior Member
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
Adnen,<br>
<br>
Comments below.<br>
<br>
<div class="moz-cite-prefix">On 21/06/2012 6:08 AM, Adnen Masmoudi
wrote:<br>
</div>
<blockquote cite="mid:jrurqe$23r$1@xxxxxxxxe.org" type="cite">Hello,
when I build my EMF projet, 2 errors appear:
<br>
<br>
1) In the build properties, the message is : Build entries must
contain at least one value.
<br>
</blockquote>
I expect it generally looks like this:<br>
<blockquote>bin.includes = .,\<br>
               model/,\<br>
               META-INF/,\<br>
               plugin.xml,\<br>
               plugin.properties<br>
jars.compile.order = .<br>
source.. = src/<br>
output.. = bin/<br>
</blockquote>
And that it has no errors.  Which line has an error for you?<br>
<blockquote cite="mid:jrurqe$23r$1@xxxxxxxxe.org" type="cite">And
when I go to the sourse of error, I find this line:
<br>
                  source.library.jar = </blockquote>
Our templates don't generate a line like this so I don't know where
it came from; not from EMF I think.<br>
<blockquote cite="mid:jrurqe$23r$1@xxxxxxxxe.org" type="cite">2)the
message is : The JRE container or the class path is not perfect
match to the JavaSE 1.6 extention envirenment : sourse
MANIFEST.MF.
<br>
And when I go to the sourse of error, I find this line:
<br>
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
<br>
</blockquote>
Look at the Java Compiler properties for the project (or at the
hidden .classpath file in the root of the project).<br>
<blockquote cite="mid:jrurqe$23r$1@xxxxxxxxe.org" type="cite">
<br>
<br>
What should I do, please.
<br>
Thanks a lot </blockquote>
<br>
<br>
</body>
</html>
Re: build emf project [message #890253 is a reply to message #890171] Thu, 21 June 2012 15:40 Go to previous message
Adnen Masmoudi is currently offline Adnen MasmoudiFriend
Messages: 4
Registered: June 2012
Junior Member

????
Previous Topic:[CDO] disable lazy loading
Next Topic:Why EModelElement doesn't inherit from EObject?
Goto Forum:
  


Current Time: Fri Aug 23 22:38:11 GMT 2019

Powered by FUDForum. Page generated in 0.01901 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top