Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » [Solved] Xtext 2.2.1 project build stucks at "Validate resources"
[Solved] Xtext 2.2.1 project build stucks at "Validate resources" [message #890025] Wed, 20 June 2012 16:04 Go to next message
Jonatan Antoni is currently offline Jonatan AntoniFriend
Messages: 18
Registered: December 2010
Location: Frankfurt/Main
Junior Member
Hello,

I have a hugh Xtext 2.2.1 project and the build process repeatly stucks at "Validate resources". The process bar for "Build Project" just stays the same for hours.

Can somebody give me a hint whats going wrong here?

BTW: The project has a language definition with about 150 gramar items. The code generator consists of about 40 Xtend2 classes (~650 kB of Xtend2 code).

Regards,
Jonatan

[Updated on: Fri, 22 June 2012 16:08]

Report message to a moderator

Re: Xtext 2.2.1 project build stucks at "Validate resources" [message #890189 is a reply to message #890025] Thu, 21 June 2012 12:02 Go to previous messageGo to next message
Jonatan Antoni is currently offline Jonatan AntoniFriend
Messages: 18
Registered: December 2010
Location: Frankfurt/Main
Junior Member
Hello,

I have just tried Eclipse Juno RC1 with Xtext 2.3M7 => same effects.

Regards,
Jonatan
Re: Xtext 2.2.1 project build stucks at "Validate resources" [message #890300 is a reply to message #890189] Thu, 21 June 2012 19:57 Go to previous messageGo to next message
Jan Koehnlein is currently offline Jan KoehnleinFriend
Messages: 760
Registered: July 2009
Location: Hamburg
Senior Member
Is it when building the Xtend code or when executing it? If your Xtend
code contains a lot of closures with type inference for the parameters,
it can really help to declare the types explicitly.

Did you try to (significantly) increase heap memory?


Am 21.06.12 14:02, schrieb Jonatan Antoni:
> Hello,
>
> I have just tried Eclipse Juno RC1 with Xtext 2.3M7 => same effects.
>
> Regards,
> Jonatan
>


--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com


---
Get professional support from the Xtext committers at www.typefox.io
Re: Xtext 2.2.1 project build stucks at "Validate resources" [message #890387 is a reply to message #890300] Fri, 22 June 2012 07:46 Go to previous messageGo to next message
Jonatan Antoni is currently offline Jonatan AntoniFriend
Messages: 18
Registered: December 2010
Location: Frankfurt/Main
Junior Member
Hello Jan,

I do not really know what Eclipse is doing in the background while the project is building. I guess it is during building Xtend to Java code. Compiling and executing the resulting java code (our generator) is no problem.

Our Xtend code makes heavy use of closures, and I guess most time with type inference. I will try to remove the type inference.

I have tried heap sizes between 512m and 4096m. I guess more heap space helps a little bit, but not significantly.

Thx,
Jonatan
Re: Xtext 2.2.1 project build stucks at "Validate resources" [message #890593 is a reply to message #890387] Fri, 22 June 2012 16:09 Go to previous messageGo to next message
Jonatan Antoni is currently offline Jonatan AntoniFriend
Messages: 18
Registered: December 2010
Location: Frankfurt/Main
Junior Member
Hello,

I have removed nearly all type inference from my project. Now it feels much faster.

Thx,
Jonatan
Re: Xtext 2.2.1 project build stucks at "Validate resources" [message #891521 is a reply to message #890593] Mon, 25 June 2012 07:12 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3107
Registered: July 2009
Senior Member
Jonatan,

yes, that is a unfortunate workaround. It is usually sufficient to
explicitly state the types of parameters in lambda expressions.

Regards,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 22.06.12 18:09, schrieb Jonatan Antoni:
> Hello,
>
> I have removed nearly all type inference from my project. Now it feels
> much faster.
>
> Thx,
> Jonatan
Re: Xtext 2.2.1 project build stucks at "Validate resources" [message #892775 is a reply to message #891521] Fri, 29 June 2012 14:56 Go to previous messageGo to next message
Jonatan Antoni is currently offline Jonatan AntoniFriend
Messages: 18
Registered: December 2010
Location: Frankfurt/Main
Junior Member
Addition: The build also stucks at validate resources, when the generated xtext model classes are missing.

We do not commit the src-gen folder to the repository. Thus having a clean workspace, all those generated java classes are missing. Try to run the mwe2 workflow in order to let xtext generate these will trigger a workspace build. This ends up in the same problem.

The workaround here is just disable the Xtext project builder. Run the mwe2 workflow. Reenable the Xtext project builder afterwards.

Have you solved this issues with Juno?

Regards,
Jonatan
Re: Xtext 2.2.1 project build stucks at "Validate resources" [message #892947 is a reply to message #892775] Mon, 02 July 2012 06:29 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3107
Registered: July 2009
Senior Member
Yes, compile problems are handled more gracefully in Juno. At least the
situation should be better than with former versions.

Regards,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 29.06.12 16:57, schrieb Jonatan Antoni:
> Addition: The build also stucks at validate resources, when the
> generated xtext model classes are missing.
>
> We do not commit the src-gen folder to the repository. Thus having a
> clean workspace, all those generated java classes are missing. Try to
> run the mwe2 workflow in order to let xtext generate these will trigger
> a workspace build. This ends up in the same problem.
>
> The workaround here is just disable the Xtext project builder. Run the
> mwe2 workflow. Reenable the Xtext project builder afterwards.
>
> Have you solved this issues with Juno?
>
> Regards,
> Jonatan
Re: Xtext 2.2.1 project build stucks at "Validate resources" [message #892951 is a reply to message #892775] Mon, 02 July 2012 06:59 Go to previous message
Jan Koehnlein is currently offline Jan KoehnleinFriend
Messages: 760
Registered: July 2009
Location: Hamburg
Senior Member
Ooops, really? Could you file a bug for this?

Am 29.06.12 16:57, schrieb Jonatan Antoni:
> Addition: The build also stucks at validate resources, when the
> generated xtext model classes are missing.
>
> We do not commit the src-gen folder to the repository. Thus having a
> clean workspace, all those generated java classes are missing. Try to
> run the mwe2 workflow in order to let xtext generate these will trigger
> a workspace build. This ends up in the same problem.
>
> The workaround here is just disable the Xtext project builder. Run the
> mwe2 workflow. Reenable the Xtext project builder afterwards.
>
> Have you solved this issues with Juno?
>
> Regards,
> Jonatan


--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com


---
Get professional support from the Xtext committers at www.typefox.io
Previous Topic:[Newbie] Problem with grammar
Next Topic:gerrit for Xtext?
Goto Forum:
  


Current Time: Sun Feb 16 19:20:31 GMT 2020

Powered by FUDForum. Page generated in 0.04572 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top