Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » EMF Compare with model fragments
EMF Compare with model fragments [message #117721] Fri, 11 April 2008 01:10 Go to next message
Renata Roginsky is currently offline Renata RoginskyFriend
Messages: 10
Registered: July 2009
Junior Member
Hello,

I'm having a problem trying to compare models that have fragments.
MatchService doesn't match the elements in the fragments.

To illustrate the problem I created a very simple model (3 classes) and
extracted one class into a fragment (an *.efx file). Then I created exact
copies of the model file and the fragment file.
When I compare these two models, MatchService is not able to match the
single class that is in the fragment.
DiffModel "reports" a model element (the class in the fragment) added to
one model and removed from the other model.
There are other diffs (a lot), but I don't even understand what they mean.

I have a small project with these models and a test class that does the
comparison, but it doesn't look like I can send an attachment via this
forum.
Let me know if you'd like me to send it and how I can do it.

We are using an older version of EMF compare (0.7) due to older version of
RSM we are stuck with at the moment, but there is a chance we'll be able
to upgrade soon.
Re: EMF Compare with model fragments [message #117758 is a reply to message #117721] Fri, 11 April 2008 07:02 Go to previous message
Cedric Brun is currently offline Cedric BrunFriend
Messages: 431
Registered: July 2009
Senior Member
Hi Renata,
first of all, thanks for your feedback :)

Correct me if I'm wrong, you have this issue with the 0.7 builds of EMF
Compare, right ?

You can track a bug using bugzilla and add your projects and example models
there : https://bugs.eclipse.org/bugs/enter_bug.cgi?product=EMFT

I hope you'll be able to upgrade your RSM version, many bugs like that are
fixed in the 0.7.0 branch. If you can't upgrade be aware that backporting
the 0.8.0 version for older Eclipse/EMF versions can be considered.


Cédric


Please

Renata Roginsky wrote:

> Hello,
>
> I'm having a problem trying to compare models that have fragments.
> MatchService doesn't match the elements in the fragments.
>
> To illustrate the problem I created a very simple model (3 classes) and
> extracted one class into a fragment (an *.efx file). Then I created exact
> copies of the model file and the fragment file.
> When I compare these two models, MatchService is not able to match the
> single class that is in the fragment.
> DiffModel "reports" a model element (the class in the fragment) added to
> one model and removed from the other model.
> There are other diffs (a lot), but I don't even understand what they mean.
>
> I have a small project with these models and a test class that does the
> comparison, but it doesn't look like I can send an attachment via this
> forum.
> Let me know if you'd like me to send it and how I can do it.
>
> We are using an older version of EMF compare (0.7) due to older version of
> RSM we are stuck with at the moment, but there is a chance we'll be able
> to upgrade soon.


http://cedric.brun.io news and articles on eclipse and eclipse modeling.
Re: EMF Compare with model fragments [message #616198 is a reply to message #117721] Fri, 11 April 2008 07:02 Go to previous message
Cedric Brun is currently offline Cedric BrunFriend
Messages: 431
Registered: July 2009
Senior Member
Hi Renata,
first of all, thanks for your feedback :)

Correct me if I'm wrong, you have this issue with the 0.7 builds of EMF
Compare, right ?

You can track a bug using bugzilla and add your projects and example models
there : https://bugs.eclipse.org/bugs/enter_bug.cgi?product=EMFT

I hope you'll be able to upgrade your RSM version, many bugs like that are
fixed in the 0.7.0 branch. If you can't upgrade be aware that backporting
the 0.8.0 version for older Eclipse/EMF versions can be considered.


Cédric


Please

Renata Roginsky wrote:

> Hello,
>
> I'm having a problem trying to compare models that have fragments.
> MatchService doesn't match the elements in the fragments.
>
> To illustrate the problem I created a very simple model (3 classes) and
> extracted one class into a fragment (an *.efx file). Then I created exact
> copies of the model file and the fragment file.
> When I compare these two models, MatchService is not able to match the
> single class that is in the fragment.
> DiffModel "reports" a model element (the class in the fragment) added to
> one model and removed from the other model.
> There are other diffs (a lot), but I don't even understand what they mean.
>
> I have a small project with these models and a test class that does the
> comparison, but it doesn't look like I can send an attachment via this
> forum.
> Let me know if you'd like me to send it and how I can do it.
>
> We are using an older version of EMF compare (0.7) due to older version of
> RSM we are stuck with at the moment, but there is a chance we'll be able
> to upgrade soon.


http://cedric.brun.io news and articles on eclipse and eclipse modeling.
Previous Topic:EMF Compare with model fragments
Next Topic:[CDO] 0.8 Multiplr Inheritence Wrong featureID
Goto Forum:
  


Current Time: Sat Apr 04 19:33:20 GMT 2020

Powered by FUDForum. Page generated in 0.01447 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top