Skip to main content



      Home
Home » Eclipse Projects » Eclipse Platform » Wizard
Wizard [message #116522] Tue, 26 August 2003 04:45 Go to next message
Eclipse UserFriend
Originally posted by: Eric.Jain.isb-sib.ch

Is it possible to have some code run as soon as a wizard page is displayed?

I'm trying to accomplish the following: On the first page of a wizard, query
parameters are collected. When the user advances to the next page, the query
should be run automatically, and the results should be displayed for further
selection.

--
Eric Jain
Re: Wizard [message #116642 is a reply to message #116522] Tue, 26 August 2003 12:58 Go to previous messageGo to next message
Eclipse UserFriend
Eric,
Yes.
getNextPage() method should return the next wizard page that would be
displayed when next button is pressed. (Should return null if the user did
not specify all the required attributes for the current page i.e. next
button would be disabled). After collecting all the information in the
current page, perform the query and pass in the value to the next page.

HTH,
Balaji

"Eric Jain" <Eric.Jain@isb-sib.ch> wrote in message
news:bif6l4$je4$1@eclipse.org...
> Is it possible to have some code run as soon as a wizard page is
displayed?
>
> I'm trying to accomplish the following: On the first page of a wizard,
query
> parameters are collected. When the user advances to the next page, the
query
> should be run automatically, and the results should be displayed for
further
> selection.
>
> --
> Eric Jain
>
>
Re: Wizard [message #116679 is a reply to message #116642] Tue, 26 August 2003 14:00 Go to previous messageGo to next message
Eclipse UserFriend
You can also use this to skip pages in the wizard, for instance

"Balaji" <balajik@us.ibm.com> wrote in message
news:big3lr$h4e$1@eclipse.org...
> Eric,
> Yes.
> getNextPage() method should return the next wizard page that would be
> displayed when next button is pressed. (Should return null if the user did
> not specify all the required attributes for the current page i.e. next
> button would be disabled). After collecting all the information in the
> current page, perform the query and pass in the value to the next page.
>
> HTH,
> Balaji
>
> "Eric Jain" <Eric.Jain@isb-sib.ch> wrote in message
> news:bif6l4$je4$1@eclipse.org...
> > Is it possible to have some code run as soon as a wizard page is
> displayed?
> >
> > I'm trying to accomplish the following: On the first page of a wizard,
> query
> > parameters are collected. When the user advances to the next page, the
> query
> > should be run automatically, and the results should be displayed for
> further
> > selection.
> >
> > --
> > Eric Jain
> >
> >
>
>
Re: Wizard [message #116700 is a reply to message #116679] Tue, 26 August 2003 14:11 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Eric.Jain.isb-sib.ch

>> getNextPage()

> You can also use this to skip pages in the wizard, for instance

Thanks for the tip. In any case, it works, though having functionality such
as running queries being called from a method with the name 'getNextPage'
doesn't make the code any less confusing... Having methods that are called
whenever a page is entered or left would be a much nicer solution, in my
opinion.

--
Eric Jain
Re: Wizard [message #116732 is a reply to message #116700] Tue, 26 August 2003 14:19 Go to previous messageGo to next message
Eclipse UserFriend
You prefer this? You are called with getNextPage(), then you return a page,
then you are called again that the page you just returned has been entered.

The idea is that wizard pages are chained, but you control what page
is shown next, allowing you full control over the page continuation process.
Seems overkill to send you page enter/leave events in this case?

Chris

"Eric Jain" <Eric.Jain@isb-sib.ch> wrote in message
news:big7rr$lku$1@eclipse.org...
> >> getNextPage()
>
> > You can also use this to skip pages in the wizard, for instance
>
> Thanks for the tip. In any case, it works, though having functionality
such
> as running queries being called from a method with the name 'getNextPage'
> doesn't make the code any less confusing... Having methods that are called
> whenever a page is entered or left would be a much nicer solution, in my
> opinion.
>
> --
> Eric Jain
>
>
Re: Wizard [message #117121 is a reply to message #116732] Wed, 27 August 2003 04:10 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Eric.Jain.isb-sib.ch

> You prefer this? You are called with getNextPage(), then you return a
> page, then you are called again that the page you just returned has
> been entered.

My point of view: I have code that needs to be run when the page is loaded,
and apparently the only solution is to put it into a method called
'getNextPage'. Seems strange to me...

--
Eric Jain
Re: Wizard [message #117483 is a reply to message #117121] Wed, 27 August 2003 14:41 Go to previous message
Eclipse UserFriend
Just a design tradeoff. Your case was apparently decided to be of secondary
importance :-)

"Eric Jain" <Eric.Jain@isb-sib.ch> wrote in message
news:bihp0l$u6f$1@eclipse.org...
> > You prefer this? You are called with getNextPage(), then you return a
> > page, then you are called again that the page you just returned has
> > been entered.
>
> My point of view: I have code that needs to be run when the page is
loaded,
> and apparently the only solution is to put it into a method called
> 'getNextPage'. Seems strange to me...
>
> --
> Eric Jain
>
>
Previous Topic:[ANN] CodePro WebCast Thursday 1:00pm EDT
Next Topic:Update Status Line from Perspective
Goto Forum:
  


Current Time: Wed Apr 30 08:54:13 EDT 2025

Powered by FUDForum. Page generated in 0.04718 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top