Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Test and Performance Tools Platform (TPTP) » Unable to profile
Unable to profile [message #111294] Tue, 04 September 2007 10:54 Go to next message
Eclipse UserFriend
Originally posted by: kea031.gmail.com

Hi,
I'm unable to profile an application with either IAC and AC. I'm running
Linux linux-ci 2.6.9-22.ELsmp x86_64 and java 1.6.0-b105 (64bits). I
installed latest Eclipse 3.3 and TPTP 4.4.0.2.
Here's what I've done :

First, I try with the IAC, so I'm not starting the standalone AC. But in
the preferences, under Profiling & Logging / Hosts, there's only
localhost:10002. There isn't any Direct Local Connection. So when I start
a profile, it fails with : Agent Controller is unavailable under port
10002. Make sure that the service is started and the port number is
correct under preferences.

Then, I tried the standalone AC. I configure it, and all the agent.xml.
When I start it, it displays :
Exception in thread "Thread-0" java.lang.NoClassDefFoundError:
org/eclipse/hyades/internal/execution/file/FileServer
but it starts anyway.
I've tested with SampleClient and it works fine.
Under eclipse, when I open the profile dialog, it print this on the
terminal :

Exception in thread
"org.eclipse.hyades.execution.core.task.ReusableThread@637c67f9"
java.lang.NullPointerException
at
org.eclipse.hyades.execution.local.util.AgentControllerDescr iptor.versionIsAtLeast(AgentControllerDescriptor.java:67)
at
org.eclipse.hyades.execution.local.util.AgentControllerDescr iptor.isVersionAtLeast(AgentControllerDescriptor.java:194)
at
org.eclipse.hyades.execution.local.file.FileManagerFactory$3 .run(FileManagerFactory.java:413)
at
org.eclipse.hyades.execution.core.task.ReusableThread.run(Re usableThread.java:131)
at java.lang.Thread.run(Thread.java:619)

But it doesn't crash, so then I start the profile, and it print this on
the terminal :

org.eclipse.tptp.platform.execution.exceptions.TimeoutExcept ion: Launching
Process command timed out.
at
org.eclipse.tptp.platform.execution.client.core.internal.Age ntController.queryAgentByProcessID(AgentController.java:512)
at
org.eclipse.tptp.platform.execution.client.core.internal.Age ntController.getAgent(AgentController.java:866)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.locateTIAgent(TIDelegateHelper.java:767)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.attachToAgent(TIDelegateHelper.java:652)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.attachToAgent(TIDelegateHelper.java:617)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.access$7(TIDelegateHelper.java:615)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper$2.processLaunched(TIDelegateHelper.java:456)
at
org.eclipse.tptp.platform.execution.client.core.internal.Pro cessImpl.launchAC(ProcessImpl.java:598)
at
org.eclipse.tptp.platform.execution.client.core.internal.Pro cessImpl.launch(ProcessImpl.java:132)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launchProcess(TIDelegateHelper.java:491)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:312)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1153)
at
org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:196)
at java.lang.Thread.run(Thread.java:619)

and this on the console :
[Error: EC JPIAgent received message (FATAL ERROR): Internal error (see
log file).]

But I haven't been able to locate the log file. The PTPT logging doesn't
work. I've changed the path to a writeable directory and set the level to
DEBUG, but the log file isn't created.
Can anyone help me with this? I really need to be able to profile
applications, wether with AC or IAC, but neither works.
Thanks.
Re: Unable to profile [message #111398 is a reply to message #111294] Wed, 05 September 2007 09:12 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: kea031.gmail.com

I've tried again with java 1.5.0_12-b04 with the exact same result.
Is there any specific prerequisite for x86-64 linux? Should I use BEA
Jrockit VM? Or update to TPTP-4.4.1-200709030100?
Re: Unable to profile under linux x86-64 [message #111541 is a reply to message #111398] Thu, 06 September 2007 13:56 Go to previous message
Eclipse UserFriend
Originally posted by: kea031.gmail.com

Tried again, with jrockit-R27.3.1-jre1.5.0_11 this time (it's the only
tested x68-64 JRE says the supported configuration page). ACServer dies as
soon as I open the profile dialog. Should I fill a bug report about this?
Does TPTP really supports x86-64?
Previous Topic:Is there an option for Line by Line coverage reporting?
Next Topic:Linux TPTP - Eclipse Runtime Workspace - Wrong Path - Plugin not recongnized
Goto Forum:
  


Current Time: Mon Sep 16 11:08:49 GMT 2019

Powered by FUDForum. Page generated in 0.01411 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top