Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Tomcat as embedded server in osgi
Tomcat as embedded server in osgi [message #856524] Wed, 25 April 2012 18:58 Go to next message
Farooq Kamal is currently offline Farooq KamalFriend
Messages: 40
Registered: January 2010
Location: Karachi, Pakistan
Member
Is there bundle based version of tomcat which could run as an embedded server in standalone mode for RAP applications.

Jetty is letting us down Sad because of a nio channel select bug which suddenly takes the process usage to 100% https://bugs.eclipse.org/bugs/show_bug.cgi?id=357318
Re: Tomcat as embedded server in osgi [message #858933 is a reply to message #856524] Fri, 27 April 2012 11:17 Go to previous messageGo to next message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1313
Registered: July 2009
Senior Member

Hi Farooq,

RĂ¼diger once created a bundle-based version of Tomcat for the RWT
integration tests. You can find the bundle on our build server [1]. I'm
not sure whether this package is suitable for production use, but maybe
it helps you somehow.

Thanks for the pointer to the Jetty bug. This reminds me of a RAP bug
[2] that might be related to this issue.

Best regards, Ralf


[1]
http://build.eclipse.org/rt/rap/base-platforms/extra-dependencies/plugins/
[2] https://bugs.eclipse.org/bugs/show_bug.cgi?id=356988

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Tomcat as embedded server in osgi [message #858949 is a reply to message #858933] Fri, 27 April 2012 11:29 Go to previous message
Farooq Kamal is currently offline Farooq KamalFriend
Messages: 40
Registered: January 2010
Location: Karachi, Pakistan
Member
Thanks Ralf! I will test that in my app. During this time I switched jetty back to org.mortbay.jetty.server_6.1.23.v201012071420 and was able to run it with RAP 1.5 M6. Jetty 6 uses the older IO libraries so hopefully with solve the problem
Previous Topic:1.5M6 Table issue
Next Topic:RAP 1.4.2 TextCellEditor trouble on Firefox 12
Goto Forum:
  


Current Time: Sat Oct 16 00:52:10 GMT 2021

Powered by FUDForum. Page generated in 0.02231 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top