Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » CDO Maintenance Needs?
CDO Maintenance Needs? [message #108463] Sat, 26 January 2008 20:31 Go to next message
Eclipse UserFriend
Originally posted by: stepper.sympedia.de

Hi CDO users,

--> Please report here if you need CDO to run on Eclipse 3.3 and EMF 2.3
platforms!!!

The latest Eclipse 3.4 and EMF 2.4 builds begin to carry some
new/changed API.
Coming CDO versions will use some of these APIs and I plan to create a
maintenance branch for CDO *only* if I see users needing it.
If during the coming week nobody asks explicitely for maintenance on
Eclipse 3.3 and EMF 2.3 future CDO builds might become incompatible!
Please understand that a separate branch with the associated maintenance
is a big effort and it should not be useless.

Regards,
Eike Stepper
----
http://wiki.eclipse.org/CDO
http://wiki.eclipse.org/Net4j
Re: CDO Maintenance Needs? [message #108770 is a reply to message #108463] Mon, 28 January 2008 20:58 Go to previous messageGo to next message
Simon Mc Duff is currently offline Simon Mc DuffFriend
Messages: 596
Registered: July 2009
Senior Member
We are still using EMF 2.3.
I know it is a lot of work making a branches and maintain them.

If I'm the only one.. I would say to not bother with that. I assume we will
upgrade to EMF 2.4 some days.

Otherwise I will apply some modifications to the code to make it run under
2.3.

I know we will need CDOSavePoint. Do you think we will have it under 2.3
release ?
If yes, I will get the latest version that works with emf 2.3.

Thank you





"Eike Stepper" <stepper@sympedia.de> wrote in message
news:479B98BB.5090300@sympedia.de...
> Hi CDO users,
>
> --> Please report here if you need CDO to run on Eclipse 3.3 and EMF 2.3
> platforms!!!
>
> The latest Eclipse 3.4 and EMF 2.4 builds begin to carry some new/changed
> API.
> Coming CDO versions will use some of these APIs and I plan to create a
> maintenance branch for CDO *only* if I see users needing it.
> If during the coming week nobody asks explicitely for maintenance on
> Eclipse 3.3 and EMF 2.3 future CDO builds might become incompatible!
> Please understand that a separate branch with the associated maintenance
> is a big effort and it should not be useless.
>
> Regards,
> Eike Stepper
> ----
> http://wiki.eclipse.org/CDO
> http://wiki.eclipse.org/Net4j
>
>
Re: CDO Maintenance Needs? [message #108860 is a reply to message #108770] Tue, 29 January 2008 08:36 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: stepper.sympedia.de

Hi Simon,

Others have reported to use CDO only with EMF 2.4 so far but I'm still
waiting for Marks opinion before I met a decision. This way or that way
I can defer the breaking changes until we have the CDOSavePoint feature
in the code base ;-) To be honest, most of these changes, IIRC, are not
very essential. There are some additions/enhancements in EMF that I
requested and that I'd like to use (ItemProviderAdapters) and there is a
MANIFEST.MF change that produces a warning (Eclipse-LazyStart ->
Bundle-ActivatopnPolicy).

Regards,
Eike Stepper
----
http://wiki.eclipse.org/CDO
http://wiki.eclipse.org/Net4j



Simon McDuff schrieb:
> We are still using EMF 2.3.
> I know it is a lot of work making a branches and maintain them.
>
> If I'm the only one.. I would say to not bother with that. I assume we will
> upgrade to EMF 2.4 some days.
>
> Otherwise I will apply some modifications to the code to make it run under
> 2.3.
>
> I know we will need CDOSavePoint. Do you think we will have it under 2.3
> release ?
> If yes, I will get the latest version that works with emf 2.3.
>
> Thank you
>
>
>
>
>
> "Eike Stepper" <stepper@sympedia.de> wrote in message
> news:479B98BB.5090300@sympedia.de...
>
>> Hi CDO users,
>>
>> --> Please report here if you need CDO to run on Eclipse 3.3 and EMF 2.3
>> platforms!!!
>>
>> The latest Eclipse 3.4 and EMF 2.4 builds begin to carry some new/changed
>> API.
>> Coming CDO versions will use some of these APIs and I plan to create a
>> maintenance branch for CDO *only* if I see users needing it.
>> If during the coming week nobody asks explicitely for maintenance on
>> Eclipse 3.3 and EMF 2.3 future CDO builds might become incompatible!
>> Please understand that a separate branch with the associated maintenance
>> is a big effort and it should not be useless.
>>
>> Regards,
>> Eike Stepper
>> ----
>> http://wiki.eclipse.org/CDO
>> http://wiki.eclipse.org/Net4j
>>
>>
>>
>
>
>
Re: CDO Maintenance Needs? [message #108897 is a reply to message #108860] Tue, 29 January 2008 11:49 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

Eike,

The builds are tagged so it's always possible to create a branch after
the fact rather than up front.


Eike Stepper wrote:
> Hi Simon,
>
> Others have reported to use CDO only with EMF 2.4 so far but I'm still
> waiting for Marks opinion before I met a decision. This way or that
> way I can defer the breaking changes until we have the CDOSavePoint
> feature in the code base ;-) To be honest, most of these changes,
> IIRC, are not very essential. There are some additions/enhancements in
> EMF that I requested and that I'd like to use (ItemProviderAdapters)
> and there is a MANIFEST.MF change that produces a warning
> (Eclipse-LazyStart -> Bundle-ActivatopnPolicy).
>
> Regards,
> Eike Stepper
> ----
> http://wiki.eclipse.org/CDO
> http://wiki.eclipse.org/Net4j
>
>
>
> Simon McDuff schrieb:
>> We are still using EMF 2.3.
>> I know it is a lot of work making a branches and maintain them.
>>
>> If I'm the only one.. I would say to not bother with that. I assume
>> we will upgrade to EMF 2.4 some days.
>>
>> Otherwise I will apply some modifications to the code to make it run
>> under 2.3.
>>
>> I know we will need CDOSavePoint. Do you think we will have it under
>> 2.3 release ?
>> If yes, I will get the latest version that works with emf 2.3.
>>
>> Thank you
>>
>>
>>
>>
>>
>> "Eike Stepper" <stepper@sympedia.de> wrote in message
>> news:479B98BB.5090300@sympedia.de...
>>
>>> Hi CDO users,
>>>
>>> --> Please report here if you need CDO to run on Eclipse 3.3 and EMF
>>> 2.3 platforms!!!
>>>
>>> The latest Eclipse 3.4 and EMF 2.4 builds begin to carry some
>>> new/changed API.
>>> Coming CDO versions will use some of these APIs and I plan to create
>>> a maintenance branch for CDO *only* if I see users needing it.
>>> If during the coming week nobody asks explicitely for maintenance on
>>> Eclipse 3.3 and EMF 2.3 future CDO builds might become incompatible!
>>> Please understand that a separate branch with the associated
>>> maintenance is a big effort and it should not be useless.
>>>
>>> Regards,
>>> Eike Stepper
>>> ----
>>> http://wiki.eclipse.org/CDO
>>> http://wiki.eclipse.org/Net4j
>>>
>>>
>>>
>>
>>
>>
Re: CDO Maintenance Needs? [message #108910 is a reply to message #108897] Tue, 29 January 2008 12:25 Go to previous message
Eclipse UserFriend
Originally posted by: stepper.sympedia.de

Ed,

Ok, thank you for the info ;-)

Regards,
Eike Stepper
----
http://wiki.eclipse.org/CDO
http://wiki.eclipse.org/Net4j



Ed Merks schrieb:
> Eike,
>
> The builds are tagged so it's always possible to create a branch after
> the fact rather than up front.
>
>
> Eike Stepper wrote:
>> Hi Simon,
>>
>> Others have reported to use CDO only with EMF 2.4 so far but I'm
>> still waiting for Marks opinion before I met a decision. This way or
>> that way I can defer the breaking changes until we have the
>> CDOSavePoint feature in the code base ;-) To be honest, most of these
>> changes, IIRC, are not very essential. There are some
>> additions/enhancements in EMF that I requested and that I'd like to
>> use (ItemProviderAdapters) and there is a MANIFEST.MF change that
>> produces a warning (Eclipse-LazyStart -> Bundle-ActivatopnPolicy).
>>
>> Regards,
>> Eike Stepper
>> ----
>> http://wiki.eclipse.org/CDO
>> http://wiki.eclipse.org/Net4j
>>
>>
>>
>> Simon McDuff schrieb:
>>> We are still using EMF 2.3.
>>> I know it is a lot of work making a branches and maintain them.
>>>
>>> If I'm the only one.. I would say to not bother with that. I assume
>>> we will upgrade to EMF 2.4 some days.
>>>
>>> Otherwise I will apply some modifications to the code to make it run
>>> under 2.3.
>>>
>>> I know we will need CDOSavePoint. Do you think we will have it under
>>> 2.3 release ?
>>> If yes, I will get the latest version that works with emf 2.3.
>>>
>>> Thank you
>>>
>>>
>>>
>>>
>>>
>>> "Eike Stepper" <stepper@sympedia.de> wrote in message
>>> news:479B98BB.5090300@sympedia.de...
>>>
>>>> Hi CDO users,
>>>>
>>>> --> Please report here if you need CDO to run on Eclipse 3.3 and
>>>> EMF 2.3 platforms!!!
>>>>
>>>> The latest Eclipse 3.4 and EMF 2.4 builds begin to carry some
>>>> new/changed API.
>>>> Coming CDO versions will use some of these APIs and I plan to
>>>> create a maintenance branch for CDO *only* if I see users needing it.
>>>> If during the coming week nobody asks explicitely for maintenance
>>>> on Eclipse 3.3 and EMF 2.3 future CDO builds might become
>>>> incompatible!
>>>> Please understand that a separate branch with the associated
>>>> maintenance is a big effort and it should not be useless.
>>>>
>>>> Regards,
>>>> Eike Stepper
>>>> ----
>>>> http://wiki.eclipse.org/CDO
>>>> http://wiki.eclipse.org/Net4j
>>>>
>>>>
>>>>
>>>
>>>
>>>
Re: CDO Maintenance Needs? [message #614123 is a reply to message #108463] Mon, 28 January 2008 20:58 Go to previous message
Simon Mc Duff is currently offline Simon Mc DuffFriend
Messages: 596
Registered: July 2009
Senior Member
We are still using EMF 2.3.
I know it is a lot of work making a branches and maintain them.

If I'm the only one.. I would say to not bother with that. I assume we will
upgrade to EMF 2.4 some days.

Otherwise I will apply some modifications to the code to make it run under
2.3.

I know we will need CDOSavePoint. Do you think we will have it under 2.3
release ?
If yes, I will get the latest version that works with emf 2.3.

Thank you





"Eike Stepper" <stepper@sympedia.de> wrote in message
news:479B98BB.5090300@sympedia.de...
> Hi CDO users,
>
> --> Please report here if you need CDO to run on Eclipse 3.3 and EMF 2.3
> platforms!!!
>
> The latest Eclipse 3.4 and EMF 2.4 builds begin to carry some new/changed
> API.
> Coming CDO versions will use some of these APIs and I plan to create a
> maintenance branch for CDO *only* if I see users needing it.
> If during the coming week nobody asks explicitely for maintenance on
> Eclipse 3.3 and EMF 2.3 future CDO builds might become incompatible!
> Please understand that a separate branch with the associated maintenance
> is a big effort and it should not be useless.
>
> Regards,
> Eike Stepper
> ----
> http://wiki.eclipse.org/CDO
> http://wiki.eclipse.org/Net4j
>
>
Re: CDO Maintenance Needs? [message #614130 is a reply to message #108770] Tue, 29 January 2008 08:36 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6505
Registered: July 2009
Senior Member
Hi Simon,

Others have reported to use CDO only with EMF 2.4 so far but I'm still
waiting for Marks opinion before I met a decision. This way or that way
I can defer the breaking changes until we have the CDOSavePoint feature
in the code base ;-) To be honest, most of these changes, IIRC, are not
very essential. There are some additions/enhancements in EMF that I
requested and that I'd like to use (ItemProviderAdapters) and there is a
MANIFEST.MF change that produces a warning (Eclipse-LazyStart ->
Bundle-ActivatopnPolicy).

Regards,
Eike Stepper
----
http://wiki.eclipse.org/CDO
http://wiki.eclipse.org/Net4j



Simon McDuff schrieb:
> We are still using EMF 2.3.
> I know it is a lot of work making a branches and maintain them.
>
> If I'm the only one.. I would say to not bother with that. I assume we will
> upgrade to EMF 2.4 some days.
>
> Otherwise I will apply some modifications to the code to make it run under
> 2.3.
>
> I know we will need CDOSavePoint. Do you think we will have it under 2.3
> release ?
> If yes, I will get the latest version that works with emf 2.3.
>
> Thank you
>
>
>
>
>
> "Eike Stepper" <stepper@sympedia.de> wrote in message
> news:479B98BB.5090300@sympedia.de...
>
>> Hi CDO users,
>>
>> --> Please report here if you need CDO to run on Eclipse 3.3 and EMF 2.3
>> platforms!!!
>>
>> The latest Eclipse 3.4 and EMF 2.4 builds begin to carry some new/changed
>> API.
>> Coming CDO versions will use some of these APIs and I plan to create a
>> maintenance branch for CDO *only* if I see users needing it.
>> If during the coming week nobody asks explicitely for maintenance on
>> Eclipse 3.3 and EMF 2.3 future CDO builds might become incompatible!
>> Please understand that a separate branch with the associated maintenance
>> is a big effort and it should not be useless.
>>
>> Regards,
>> Eike Stepper
>> ----
>> http://wiki.eclipse.org/CDO
>> http://wiki.eclipse.org/Net4j
>>
>>
>>
>
>
>


Re: CDO Maintenance Needs? [message #614133 is a reply to message #108860] Tue, 29 January 2008 11:49 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31467
Registered: July 2009
Senior Member
Eike,

The builds are tagged so it's always possible to create a branch after
the fact rather than up front.


Eike Stepper wrote:
> Hi Simon,
>
> Others have reported to use CDO only with EMF 2.4 so far but I'm still
> waiting for Marks opinion before I met a decision. This way or that
> way I can defer the breaking changes until we have the CDOSavePoint
> feature in the code base ;-) To be honest, most of these changes,
> IIRC, are not very essential. There are some additions/enhancements in
> EMF that I requested and that I'd like to use (ItemProviderAdapters)
> and there is a MANIFEST.MF change that produces a warning
> (Eclipse-LazyStart -> Bundle-ActivatopnPolicy).
>
> Regards,
> Eike Stepper
> ----
> http://wiki.eclipse.org/CDO
> http://wiki.eclipse.org/Net4j
>
>
>
> Simon McDuff schrieb:
>> We are still using EMF 2.3.
>> I know it is a lot of work making a branches and maintain them.
>>
>> If I'm the only one.. I would say to not bother with that. I assume
>> we will upgrade to EMF 2.4 some days.
>>
>> Otherwise I will apply some modifications to the code to make it run
>> under 2.3.
>>
>> I know we will need CDOSavePoint. Do you think we will have it under
>> 2.3 release ?
>> If yes, I will get the latest version that works with emf 2.3.
>>
>> Thank you
>>
>>
>>
>>
>>
>> "Eike Stepper" <stepper@sympedia.de> wrote in message
>> news:479B98BB.5090300@sympedia.de...
>>
>>> Hi CDO users,
>>>
>>> --> Please report here if you need CDO to run on Eclipse 3.3 and EMF
>>> 2.3 platforms!!!
>>>
>>> The latest Eclipse 3.4 and EMF 2.4 builds begin to carry some
>>> new/changed API.
>>> Coming CDO versions will use some of these APIs and I plan to create
>>> a maintenance branch for CDO *only* if I see users needing it.
>>> If during the coming week nobody asks explicitely for maintenance on
>>> Eclipse 3.3 and EMF 2.3 future CDO builds might become incompatible!
>>> Please understand that a separate branch with the associated
>>> maintenance is a big effort and it should not be useless.
>>>
>>> Regards,
>>> Eike Stepper
>>> ----
>>> http://wiki.eclipse.org/CDO
>>> http://wiki.eclipse.org/Net4j
>>>
>>>
>>>
>>
>>
>>


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: CDO Maintenance Needs? [message #614134 is a reply to message #108897] Tue, 29 January 2008 12:25 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6505
Registered: July 2009
Senior Member
Ed,

Ok, thank you for the info ;-)

Regards,
Eike Stepper
----
http://wiki.eclipse.org/CDO
http://wiki.eclipse.org/Net4j



Ed Merks schrieb:
> Eike,
>
> The builds are tagged so it's always possible to create a branch after
> the fact rather than up front.
>
>
> Eike Stepper wrote:
>> Hi Simon,
>>
>> Others have reported to use CDO only with EMF 2.4 so far but I'm
>> still waiting for Marks opinion before I met a decision. This way or
>> that way I can defer the breaking changes until we have the
>> CDOSavePoint feature in the code base ;-) To be honest, most of these
>> changes, IIRC, are not very essential. There are some
>> additions/enhancements in EMF that I requested and that I'd like to
>> use (ItemProviderAdapters) and there is a MANIFEST.MF change that
>> produces a warning (Eclipse-LazyStart -> Bundle-ActivatopnPolicy).
>>
>> Regards,
>> Eike Stepper
>> ----
>> http://wiki.eclipse.org/CDO
>> http://wiki.eclipse.org/Net4j
>>
>>
>>
>> Simon McDuff schrieb:
>>> We are still using EMF 2.3.
>>> I know it is a lot of work making a branches and maintain them.
>>>
>>> If I'm the only one.. I would say to not bother with that. I assume
>>> we will upgrade to EMF 2.4 some days.
>>>
>>> Otherwise I will apply some modifications to the code to make it run
>>> under 2.3.
>>>
>>> I know we will need CDOSavePoint. Do you think we will have it under
>>> 2.3 release ?
>>> If yes, I will get the latest version that works with emf 2.3.
>>>
>>> Thank you
>>>
>>>
>>>
>>>
>>>
>>> "Eike Stepper" <stepper@sympedia.de> wrote in message
>>> news:479B98BB.5090300@sympedia.de...
>>>
>>>> Hi CDO users,
>>>>
>>>> --> Please report here if you need CDO to run on Eclipse 3.3 and
>>>> EMF 2.3 platforms!!!
>>>>
>>>> The latest Eclipse 3.4 and EMF 2.4 builds begin to carry some
>>>> new/changed API.
>>>> Coming CDO versions will use some of these APIs and I plan to
>>>> create a maintenance branch for CDO *only* if I see users needing it.
>>>> If during the coming week nobody asks explicitely for maintenance
>>>> on Eclipse 3.3 and EMF 2.3 future CDO builds might become
>>>> incompatible!
>>>> Please understand that a separate branch with the associated
>>>> maintenance is a big effort and it should not be useless.
>>>>
>>>> Regards,
>>>> Eike Stepper
>>>> ----
>>>> http://wiki.eclipse.org/CDO
>>>> http://wiki.eclipse.org/Net4j
>>>>
>>>>
>>>>
>>>
>>>
>>>


Previous Topic:Disconnected mode for Hibernate/teneo
Next Topic:[CDO] is it what I want ?
Goto Forum:
  


Current Time: Sun Sep 20 04:38:39 GMT 2020

Powered by FUDForum. Page generated in 0.02049 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top