Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » P2 smoke test of today's I-build: still a few issues, NPEs etc.
P2 smoke test of today's I-build: still a few issues, NPEs etc. [message #108208] Tue, 15 April 2008 21:36 Go to next message
Neale Upstone is currently offline Neale UpstoneFriend
Messages: 50
Registered: July 2009
Member
Hi,

I've just downloaded today's I-build. It's, so far looking better than
P2 was for me in 3.4M6.

Installs from the following sites have been tested so far (I like the
progress bar btw):
- http://download.eclipse.org/tools/ajdt/34/dev/update - SUCCESS
- Eclipse Subversive + SVNKit connect - SUCCESS
- http://update.eclipse.org/eclipse/testUpdates - FAIL - Add site, then
refresh causes NPE.
- http://download.eclipse.org/releases/ganymede
- Install Mylyn (Task List + Bugzilla connector)
- Install WTP (JST & WST)

Close and re-open Software Updates, while install in progress
-> progress still indicated

Allow software update to finish in background
-> Restart: Y / N / Apply dialog appears when finished

"Apply" (NO RESTART) -> Mylyn Task list view appears after prompted
reset of Java perspective. WTP views and prefs avail.


Problems:
- No pre-configured update site.
- NPE on test updates.
- Some oddities when "Refresh" button is pressed
- Was expecting to see other update sites automatically added to the
list, but don't get them (i.e. WTP Updates)

(and ... - Something going odd with PDE, but hopefully unit tests will
pick that out, and that's not seemingly P2 related, but is a pain, as I
cannot switch to running this I-build, so I'm still back on M5).

Nice work on P2 though!

Cheers,

Neale
Re: P2 smoke test of today's I-build: still a few issues, NPEs etc. [message #108223 is a reply to message #108208] Tue, 15 April 2008 21:44 Go to previous message
Neale Upstone is currently offline Neale UpstoneFriend
Messages: 50
Registered: July 2009
Member
Correction: testUpdates URL should have been
http://download.eclipse.org/eclipse/testUpdates/

The NPE is still an issue, but I'm sure that'll get sorted by a
testBadUrl test at some point :)

Correct URL offers nothing... but that might be correct...



Neale wrote:
> Hi,
>
> I've just downloaded today's I-build. It's, so far looking better than
> P2 was for me in 3.4M6.
>
> Installs from the following sites have been tested so far (I like the
> progress bar btw):
> - http://download.eclipse.org/tools/ajdt/34/dev/update - SUCCESS
> - Eclipse Subversive + SVNKit connect - SUCCESS
> - http://update.eclipse.org/eclipse/testUpdates - FAIL - Add site, then
> refresh causes NPE.
> - http://download.eclipse.org/releases/ganymede
> - Install Mylyn (Task List + Bugzilla connector)
> - Install WTP (JST & WST)
>
> Close and re-open Software Updates, while install in progress
> -> progress still indicated
>
> Allow software update to finish in background
> -> Restart: Y / N / Apply dialog appears when finished
>
> "Apply" (NO RESTART) -> Mylyn Task list view appears after prompted
> reset of Java perspective. WTP views and prefs avail.
>
>
> Problems:
> - No pre-configured update site.
> - NPE on test updates.
> - Some oddities when "Refresh" button is pressed
> - Was expecting to see other update sites automatically added to the
> list, but don't get them (i.e. WTP Updates)
>
> (and ... - Something going odd with PDE, but hopefully unit tests will
> pick that out, and that's not seemingly P2 related, but is a pain, as I
> cannot switch to running this I-build, so I'm still back on M5).
>
> Nice work on P2 though!
>
> Cheers,
>
> Neale
Previous Topic:Finding/using OSGi services outside of the framework
Next Topic:P2 and installation locations
Goto Forum:
  


Current Time: Sat Oct 16 13:16:49 GMT 2021

Powered by FUDForum. Page generated in 0.01721 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top