Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » M6 with p2 removed - still not detecting some plugins
M6 with p2 removed - still not detecting some plugins [message #107349] Wed, 02 April 2008 00:13 Go to next message
Neale Upstone is currently offline Neale UpstoneFriend
Messages: 50
Registered: July 2009
Member
Hi,

Can anyone else confirm this:

Having installed M6, and had difficulty with p2, I've followed the
instructions at http://wiki.eclipse.org/Equinox_p2_Removal and started
eclipse with -clean (for good measure).

I can now install features from update sites as I could with previous M
builds, but, when I want to set my target platform, I'm not getting the
same list of plugins listed as being present in eclipse/plugins.

Instead, the options listed are only those plugins that are packaged as
a jar. Old-style folders are ignored. In my case, this means that the
AspectJ runtime cannot be resolved.

The same workspace accessed via 3.4M4 shows many more plugins.

Cheers,

Neale
Re: M6 with p2 removed - still not detecting some plugins [message #107438 is a reply to message #107349] Wed, 02 April 2008 14:52 Go to previous messageGo to next message
Pascal Rapicault is currently offline Pascal RapicaultFriend
Messages: 333
Registered: July 2009
Location: Ottawa
Senior Member
Please open a bug against PDE UI

"Neale" <neale@nealeupstone.com> wrote in message
news:fsuj33$t72$1@build.eclipse.org...
> Hi,
>
> Can anyone else confirm this:
>
> Having installed M6, and had difficulty with p2, I've followed the
> instructions at http://wiki.eclipse.org/Equinox_p2_Removal and started
> eclipse with -clean (for good measure).
>
> I can now install features from update sites as I could with previous M
> builds, but, when I want to set my target platform, I'm not getting the
> same list of plugins listed as being present in eclipse/plugins.
>
> Instead, the options listed are only those plugins that are packaged as a
> jar. Old-style folders are ignored. In my case, this means that the
> AspectJ runtime cannot be resolved.
>
> The same workspace accessed via 3.4M4 shows many more plugins.
>
> Cheers,
>
> Neale
Re: M6 with p2 removed - still not detecting some plugins [message #107448 is a reply to message #107349] Wed, 02 April 2008 15:58 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: zx.us.ibm.com

How are you installing things to the folder you're pointing to as your
target platform?

Cheers,

~ Chris
Re: M6 with p2 removed - still not detecting some plugins [message #107460 is a reply to message #107349] Wed, 02 April 2008 16:00 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: zx.us.ibm.com

Check out https://bugs.eclipse.org/bugs/show_bug.cgi?id=225148

That may be the same issue.

Cheers,

~ Chris
Re: M6 with p2 removed - still not detecting some plugins [message #107499 is a reply to message #107460] Thu, 03 April 2008 10:55 Go to previous message
Neale Upstone is currently offline Neale UpstoneFriend
Messages: 50
Registered: July 2009
Member
Certainly seems a complicated set of use cases to get to grips with, for
p2, but I'm not talking about p2. What I'm seeing is a regression: that
with p2 removed, I don't get the same behaviour as in the previous
M-build (in my case M4, as I didn't grab M5).

I'll open a but, as there's clearly something not right with PDE on this
one.

Hope you're not doing too many late nights on this... p2 is a big bold step!

Cheers,

Neale



Chris Aniszczyk wrote:
> Check out https://bugs.eclipse.org/bugs/show_bug.cgi?id=225148
>
> That may be the same issue.
>
> Cheers,
>
> ~ Chris
Previous Topic:importing existing projects programmatically
Next Topic:Cannot launch the Update UI
Goto Forum:
  


Current Time: Sun Oct 17 01:54:51 GMT 2021

Powered by FUDForum. Page generated in 0.01903 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top