Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » p2 in 3.4m6 dependency check not working?
p2 in 3.4m6 dependency check not working? [message #107334] Tue, 01 April 2008 21:17 Go to next message
Eclipse UserFriend
Originally posted by: jens.ja-web.de

hi,

just did a clean install of the fresh 3.4m6 SDK, win32

I try to get used to the new Software Update feature. I added the two
install URLs for subversion, then I selected one connector for
installation. I saw a "checking dependencies" for a short moment but
then there was only the selected connector offered for installation but
not the other SVN components that are needed.

Also, I choose WTP (from the ganymede update site) and expected to get a
bunch of other plugins due to dependencies but no - only the WTP was
offered for installation.

Does depencency check acutally work? Do packages need updates to make
them compatible with p2 style installation?

thanks
Jens
Re: p2 in 3.4m6 dependency check not working? [message #107431 is a reply to message #107334] Wed, 02 April 2008 14:51 Go to previous messageGo to next message
Pascal Rapicault is currently offline Pascal RapicaultFriend
Messages: 333
Registered: July 2009
Location: Ottawa
Senior Member
The dependency surely works!
In order to simplify the UI, we have decided to no longer show the plugins
and features that result from the installation of a feature, which is why
for example you don't see EMF when you install WTP.

PaScaL
If you proceed with the installation, do you get a functional system?
"Jens Ansorg" <jens@ja-web.de> wrote in message
news:fsu8ph$430$1@build.eclipse.org...
> hi,
>
> just did a clean install of the fresh 3.4m6 SDK, win32
>
> I try to get used to the new Software Update feature. I added the two
> install URLs for subversion, then I selected one connector for
> installation. I saw a "checking dependencies" for a short moment but then
> there was only the selected connector offered for installation but not the
> other SVN components that are needed.
>
> Also, I choose WTP (from the ganymede update site) and expected to get a
> bunch of other plugins due to dependencies but no - only the WTP was
> offered for installation.
>
> Does depencency check acutally work? Do packages need updates to make them
> compatible with p2 style installation?
>
> thanks
> Jens
Re: p2 in 3.4m6 dependency check not working? [message #107540 is a reply to message #107431] Sat, 05 April 2008 16:22 Go to previous message
Eclipse UserFriend
Originally posted by: jens.ja-web.de

Pascal Rapicault schrieb:
> The dependency surely works!
> In order to simplify the UI, we have decided to no longer show the plugins
> and features that result from the installation of a feature, which is why
> for example you don't see EMF when you install WTP.
>

Ok, I see.

I tried again and noticed that it downloaded lots of additional plugins
silently in the background.

I'd prefer to get noticed that Eclipse will download a whole bunch of
other stuff that I did not choose initially.


thanks
Jens
Previous Topic:Swing OSGi and EJBs
Next Topic:Equinox Transforms Hook bundle missing on CVS?
Goto Forum:
  


Current Time: Sat Oct 16 13:08:41 GMT 2021

Powered by FUDForum. Page generated in 0.01733 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top