Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [Teneo] Problem with update site
[Teneo] Problem with update site [message #107084] Wed, 16 January 2008 17:44 Go to next message
David Wynter is currently offline David WynterFriend
Messages: 4624
Registered: July 2009
Senior Member
Hi,

I was putting Teneo and prequisites on a new machine, having forgotten
how I did it first time round on a different machine.

Using update site
-http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml.
First thing that strikes me is that it marks the latest plugins as being
the correct ones, and looking at the EMFT site it looks like these
require 3.4M3, whereas I have Europa ( 3.3 from the 25th September
2007). But then it is hard to choose a correct version because they all
show being dependent on versions either side of Europas. Not sure how
you are supposed to resolve this.

Anyway went ahead assume the whole Update thing knows which version are
correct, get most of the way through and then this error

Update operation has failed
Error retrieving
"plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
returned HTTP response code: "404 Not Found" for URL:
http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.]
Server returned HTTP response code: "404 Not Found" for URL:
http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.


Thx.

David
Re: [Teneo] Problem with update site [message #107128 is a reply to message #107084] Wed, 16 January 2008 18:33 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi David,
I will look into this, in the mean time you can also download directly by following this link:
http://www.eclipse.org/modeling/emft/downloads/?project=tene o

gr. Martin

david wrote:
> Hi,
>
> I was putting Teneo and prequisites on a new machine, having forgotten
> how I did it first time round on a different machine.
>
> Using update site
> -http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml.
> First thing that strikes me is that it marks the latest plugins as being
> the correct ones, and looking at the EMFT site it looks like these
> require 3.4M3, whereas I have Europa ( 3.3 from the 25th September
> 2007). But then it is hard to choose a correct version because they all
> show being dependent on versions either side of Europas. Not sure how
> you are supposed to resolve this.
>
> Anyway went ahead assume the whole Update thing knows which version are
> correct, get most of the way through and then this error
>
> Update operation has failed
> Error retrieving
> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
> returned HTTP response code: "404 Not Found" for URL:
> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.]
>
> Server returned HTTP response code: "404 Not Found" for URL:
> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.
>
>
>
> Thx.
>
> David


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [Teneo] Problem with update site [message #107515 is a reply to message #107128] Thu, 17 January 2008 16:09 Go to previous messageGo to next message
David Wynter is currently offline David WynterFriend
Messages: 4624
Registered: July 2009
Senior Member
Hi,

I used the version dated 6th September, it being closest to the release
date of Europa. Wondering why there is not a version of Teneo that is
specifically matched to Europa release version? I thought the whole
Update Site thing was meant to check this compatible versioning thing.

David

Martin Taal wrote:
> Hi David,
> I will look into this, in the mean time you can also download directly
> by following this link:
> http://www.eclipse.org/modeling/emft/downloads/?project=tene o
>
> gr. Martin
>
> david wrote:
>> Hi,
>>
>> I was putting Teneo and prequisites on a new machine, having forgotten
>> how I did it first time round on a different machine.
>>
>> Using update site
>> -http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml.
>> First thing that strikes me is that it marks the latest plugins as
>> being the correct ones, and looking at the EMFT site it looks like
>> these require 3.4M3, whereas I have Europa ( 3.3 from the 25th
>> September 2007). But then it is hard to choose a correct version
>> because they all show being dependent on versions either side of
>> Europas. Not sure how you are supposed to resolve this.
>>
>> Anyway went ahead assume the whole Update thing knows which version
>> are correct, get most of the way through and then this error
>>
>> Update operation has failed
>> Error retrieving
>> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
>> returned HTTP response code: "404 Not Found" for URL:
>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.]
>>
>> Server returned HTTP response code: "404 Not Found" for URL:
>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.
>>
>>
>>
>> Thx.
>>
>> David
>
>
Re: [Teneo] Problem with update site [message #107528 is a reply to message #107515] Thu, 17 January 2008 16:17 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi David,
The active version of Teneo is 0.8.0 which is for 3.3. I would use the last build (28th of
december), since the 6th of december about 20 issues have been solved.

I just tried the update manager and with me it worked fine (I updated to the 28th dec version).
In which screen did you see the warning about eclipse version 3.4?

gr. Martin

david wrote:
> Hi,
>
> I used the version dated 6th September, it being closest to the release
> date of Europa. Wondering why there is not a version of Teneo that is
> specifically matched to Europa release version? I thought the whole
> Update Site thing was meant to check this compatible versioning thing.
>
> David
>
> Martin Taal wrote:
>> Hi David,
>> I will look into this, in the mean time you can also download directly
>> by following this link:
>> http://www.eclipse.org/modeling/emft/downloads/?project=tene o
>>
>> gr. Martin
>>
>> david wrote:
>>> Hi,
>>>
>>> I was putting Teneo and prequisites on a new machine, having
>>> forgotten how I did it first time round on a different machine.
>>>
>>> Using update site
>>> -http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml.
>>> First thing that strikes me is that it marks the latest plugins as
>>> being the correct ones, and looking at the EMFT site it looks like
>>> these require 3.4M3, whereas I have Europa ( 3.3 from the 25th
>>> September 2007). But then it is hard to choose a correct version
>>> because they all show being dependent on versions either side of
>>> Europas. Not sure how you are supposed to resolve this.
>>>
>>> Anyway went ahead assume the whole Update thing knows which version
>>> are correct, get most of the way through and then this error
>>>
>>> Update operation has failed
>>> Error retrieving
>>> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
>>> returned HTTP response code: "404 Not Found" for URL:
>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.]
>>>
>>> Server returned HTTP response code: "404 Not Found" for URL:
>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.
>>>
>>>
>>>
>>> Thx.
>>>
>>> David
>>
>>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [Teneo] Problem with update site [message #107675 is a reply to message #107528] Fri, 18 January 2008 11:04 Go to previous messageGo to next message
David Wynter is currently offline David WynterFriend
Messages: 4624
Registered: July 2009
Senior Member
Hi,

I did not get a warning about 3.4M I got this, again just now when I retried

Update operation has failed
Error retrieving
"plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
returned HTTP response code: "404 Not Found" for URL:
http://eclipse.mirror.kangaroot.net/modeling/emft/updates/pl ugins/org.apache.commons.lang_2.1.0.v200711021015.jar.]
Server returned HTTP response code: "404 Not Found" for URL:
http://eclipse.mirror.kangaroot.net/modeling/emft/updates/pl ugins/org.apache.commons.lang_2.1.0.v200711021015.jar.

I assume it is using a different update site to when you try.

One thing I noticed was that it was attempting to download Version 0.8.0
from the 3rd January 2008, not the 28-12-2007 version just prior to this
error above. To compound things I cannot work at all. Because I thought
maybe a full "Search for updates of the currently installed features"
would help, now I get a NPE whenever I try to open any xml document.
Seems the Update Site idea is not working in all cases, I thought it was
supposed to be version aware? The only install I have done outside
Update Site was the manual installation of the teneo project with the
version from 28-12-2007.


David

Martin Taal wrote:
> Hi David,
> The active version of Teneo is 0.8.0 which is for 3.3. I would use the
> last build (28th of december), since the 6th of december about 20 issues
> have been solved.
>
> I just tried the update manager and with me it worked fine (I updated to
> the 28th dec version).
> In which screen did you see the warning about eclipse version 3.4?
>
> gr. Martin
>
> david wrote:
>> Hi,
>>
>> I used the version dated 6th September, it being closest to the
>> release date of Europa. Wondering why there is not a version of Teneo
>> that is specifically matched to Europa release version? I thought the
>> whole Update Site thing was meant to check this compatible versioning
>> thing.
>>
>> David
>>
>> Martin Taal wrote:
>>> Hi David,
>>> I will look into this, in the mean time you can also download
>>> directly by following this link:
>>> http://www.eclipse.org/modeling/emft/downloads/?project=tene o
>>>
>>> gr. Martin
>>>
>>> david wrote:
>>>> Hi,
>>>>
>>>> I was putting Teneo and prequisites on a new machine, having
>>>> forgotten how I did it first time round on a different machine.
>>>>
>>>> Using update site
>>>> -http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml.
>>>> First thing that strikes me is that it marks the latest plugins as
>>>> being the correct ones, and looking at the EMFT site it looks like
>>>> these require 3.4M3, whereas I have Europa ( 3.3 from the 25th
>>>> September 2007). But then it is hard to choose a correct version
>>>> because they all show being dependent on versions either side of
>>>> Europas. Not sure how you are supposed to resolve this.
>>>>
>>>> Anyway went ahead assume the whole Update thing knows which version
>>>> are correct, get most of the way through and then this error
>>>>
>>>> Update operation has failed
>>>> Error retrieving
>>>> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
>>>> returned HTTP response code: "404 Not Found" for URL:
>>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.]
>>>>
>>>> Server returned HTTP response code: "404 Not Found" for URL:
>>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.
>>>>
>>>>
>>>>
>>>> Thx.
>>>>
>>>> David
>>>
>>>
>
>
Re: [Teneo] Problem with update site [message #107714 is a reply to message #107675] Fri, 18 January 2008 11:44 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi David,
To me it seems more an issue of the update manager in general than of Teneo specifically...
I think I remember that I also have had these type of issues with the update manager (an npe) a
while back. You can check the error view and the eclipse log file to see if you can get more
information. You can also try a different mirror.

I do not know if the update manager is version aware.

Teneo does not have a dependency on the apache commons plugin so I do not know why in your case the
system tries to download it.

gr. Martin

david wrote:
> Hi,
>
> I did not get a warning about 3.4M I got this, again just now when I
> retried
>
> Update operation has failed
> Error retrieving
> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
> returned HTTP response code: "404 Not Found" for URL:
> http://eclipse.mirror.kangaroot.net/modeling/emft/updates/pl ugins/org.apache.commons.lang_2.1.0.v200711021015.jar.]
>
> Server returned HTTP response code: "404 Not Found" for URL:
> http://eclipse.mirror.kangaroot.net/modeling/emft/updates/pl ugins/org.apache.commons.lang_2.1.0.v200711021015.jar.
>
>
> I assume it is using a different update site to when you try.
>
> One thing I noticed was that it was attempting to download Version 0.8.0
> from the 3rd January 2008, not the 28-12-2007 version just prior to this
> error above. To compound things I cannot work at all. Because I thought
> maybe a full "Search for updates of the currently installed features"
> would help, now I get a NPE whenever I try to open any xml document.
> Seems the Update Site idea is not working in all cases, I thought it was
> supposed to be version aware? The only install I have done outside
> Update Site was the manual installation of the teneo project with the
> version from 28-12-2007.
>
>
> David
>
> Martin Taal wrote:
>> Hi David,
>> The active version of Teneo is 0.8.0 which is for 3.3. I would use the
>> last build (28th of december), since the 6th of december about 20
>> issues have been solved.
>>
>> I just tried the update manager and with me it worked fine (I updated
>> to the 28th dec version).
>> In which screen did you see the warning about eclipse version 3.4?
>>
>> gr. Martin
>>
>> david wrote:
>>> Hi,
>>>
>>> I used the version dated 6th September, it being closest to the
>>> release date of Europa. Wondering why there is not a version of Teneo
>>> that is specifically matched to Europa release version? I thought the
>>> whole Update Site thing was meant to check this compatible versioning
>>> thing.
>>>
>>> David
>>>
>>> Martin Taal wrote:
>>>> Hi David,
>>>> I will look into this, in the mean time you can also download
>>>> directly by following this link:
>>>> http://www.eclipse.org/modeling/emft/downloads/?project=tene o
>>>>
>>>> gr. Martin
>>>>
>>>> david wrote:
>>>>> Hi,
>>>>>
>>>>> I was putting Teneo and prequisites on a new machine, having
>>>>> forgotten how I did it first time round on a different machine.
>>>>>
>>>>> Using update site
>>>>> -http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml.
>>>>> First thing that strikes me is that it marks the latest plugins as
>>>>> being the correct ones, and looking at the EMFT site it looks like
>>>>> these require 3.4M3, whereas I have Europa ( 3.3 from the 25th
>>>>> September 2007). But then it is hard to choose a correct version
>>>>> because they all show being dependent on versions either side of
>>>>> Europas. Not sure how you are supposed to resolve this.
>>>>>
>>>>> Anyway went ahead assume the whole Update thing knows which version
>>>>> are correct, get most of the way through and then this error
>>>>>
>>>>> Update operation has failed
>>>>> Error retrieving
>>>>> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
>>>>> returned HTTP response code: "404 Not Found" for URL:
>>>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.]
>>>>>
>>>>> Server returned HTTP response code: "404 Not Found" for URL:
>>>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar.
>>>>>
>>>>>
>>>>>
>>>>> Thx.
>>>>>
>>>>> David
>>>>
>>>>
>>
>>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [Teneo] Problem with update site [message #614007 is a reply to message #107084] Wed, 16 January 2008 18:33 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi David,
I will look into this, in the mean time you can also download directly by following this link:
http://www.eclipse.org/modeling/emft/downloads/?project=tene o

gr. Martin

david wrote:
> Hi,
>
> I was putting Teneo and prequisites on a new machine, having forgotten
> how I did it first time round on a different machine.
>
> Using update site
> -http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml
> First thing that strikes me is that it marks the latest plugins as being
> the correct ones, and looking at the EMFT site it looks like these
> require 3.4M3, whereas I have Europa ( 3.3 from the 25th September
> 2007). But then it is hard to choose a correct version because they all
> show being dependent on versions either side of Europas. Not sure how
> you are supposed to resolve this.
>
> Anyway went ahead assume the whole Update thing knows which version are
> correct, get most of the way through and then this error
>
> Update operation has failed
> Error retrieving
> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
> returned HTTP response code: "404 Not Found" for URL:
> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar]
>
> Server returned HTTP response code: "404 Not Found" for URL:
> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar
>
>
>
> Thx.
>
> David


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [Teneo] Problem with update site [message #614035 is a reply to message #107128] Thu, 17 January 2008 16:09 Go to previous message
David Wynter is currently offline David WynterFriend
Messages: 4624
Registered: July 2009
Senior Member
Hi,

I used the version dated 6th September, it being closest to the release
date of Europa. Wondering why there is not a version of Teneo that is
specifically matched to Europa release version? I thought the whole
Update Site thing was meant to check this compatible versioning thing.

David

Martin Taal wrote:
> Hi David,
> I will look into this, in the mean time you can also download directly
> by following this link:
> http://www.eclipse.org/modeling/emft/downloads/?project=tene o
>
> gr. Martin
>
> david wrote:
>> Hi,
>>
>> I was putting Teneo and prequisites on a new machine, having forgotten
>> how I did it first time round on a different machine.
>>
>> Using update site
>> -http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml
>> First thing that strikes me is that it marks the latest plugins as
>> being the correct ones, and looking at the EMFT site it looks like
>> these require 3.4M3, whereas I have Europa ( 3.3 from the 25th
>> September 2007). But then it is hard to choose a correct version
>> because they all show being dependent on versions either side of
>> Europas. Not sure how you are supposed to resolve this.
>>
>> Anyway went ahead assume the whole Update thing knows which version
>> are correct, get most of the way through and then this error
>>
>> Update operation has failed
>> Error retrieving
>> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
>> returned HTTP response code: "404 Not Found" for URL:
>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar]
>>
>> Server returned HTTP response code: "404 Not Found" for URL:
>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar
>>
>>
>>
>> Thx.
>>
>> David
>
>
Re: [Teneo] Problem with update site [message #614036 is a reply to message #107515] Thu, 17 January 2008 16:17 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi David,
The active version of Teneo is 0.8.0 which is for 3.3. I would use the last build (28th of
december), since the 6th of december about 20 issues have been solved.

I just tried the update manager and with me it worked fine (I updated to the 28th dec version).
In which screen did you see the warning about eclipse version 3.4?

gr. Martin

david wrote:
> Hi,
>
> I used the version dated 6th September, it being closest to the release
> date of Europa. Wondering why there is not a version of Teneo that is
> specifically matched to Europa release version? I thought the whole
> Update Site thing was meant to check this compatible versioning thing.
>
> David
>
> Martin Taal wrote:
>> Hi David,
>> I will look into this, in the mean time you can also download directly
>> by following this link:
>> http://www.eclipse.org/modeling/emft/downloads/?project=tene o
>>
>> gr. Martin
>>
>> david wrote:
>>> Hi,
>>>
>>> I was putting Teneo and prequisites on a new machine, having
>>> forgotten how I did it first time round on a different machine.
>>>
>>> Using update site
>>> -http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml
>>> First thing that strikes me is that it marks the latest plugins as
>>> being the correct ones, and looking at the EMFT site it looks like
>>> these require 3.4M3, whereas I have Europa ( 3.3 from the 25th
>>> September 2007). But then it is hard to choose a correct version
>>> because they all show being dependent on versions either side of
>>> Europas. Not sure how you are supposed to resolve this.
>>>
>>> Anyway went ahead assume the whole Update thing knows which version
>>> are correct, get most of the way through and then this error
>>>
>>> Update operation has failed
>>> Error retrieving
>>> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
>>> returned HTTP response code: "404 Not Found" for URL:
>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar]
>>>
>>> Server returned HTTP response code: "404 Not Found" for URL:
>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar
>>>
>>>
>>>
>>> Thx.
>>>
>>> David
>>
>>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [Teneo] Problem with update site [message #614047 is a reply to message #107528] Fri, 18 January 2008 11:04 Go to previous message
David Wynter is currently offline David WynterFriend
Messages: 4624
Registered: July 2009
Senior Member
Hi,

I did not get a warning about 3.4M I got this, again just now when I retried

Update operation has failed
Error retrieving
"plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
returned HTTP response code: "404 Not Found" for URL:
http://eclipse.mirror.kangaroot.net/modeling/emft/updates/pl ugins/org.apache.commons.lang_2.1.0.v200711021015.jar]
Server returned HTTP response code: "404 Not Found" for URL:
http://eclipse.mirror.kangaroot.net/modeling/emft/updates/pl ugins/org.apache.commons.lang_2.1.0.v200711021015.jar

I assume it is using a different update site to when you try.

One thing I noticed was that it was attempting to download Version 0.8.0
from the 3rd January 2008, not the 28-12-2007 version just prior to this
error above. To compound things I cannot work at all. Because I thought
maybe a full "Search for updates of the currently installed features"
would help, now I get a NPE whenever I try to open any xml document.
Seems the Update Site idea is not working in all cases, I thought it was
supposed to be version aware? The only install I have done outside
Update Site was the manual installation of the teneo project with the
version from 28-12-2007.


David

Martin Taal wrote:
> Hi David,
> The active version of Teneo is 0.8.0 which is for 3.3. I would use the
> last build (28th of december), since the 6th of december about 20 issues
> have been solved.
>
> I just tried the update manager and with me it worked fine (I updated to
> the 28th dec version).
> In which screen did you see the warning about eclipse version 3.4?
>
> gr. Martin
>
> david wrote:
>> Hi,
>>
>> I used the version dated 6th September, it being closest to the
>> release date of Europa. Wondering why there is not a version of Teneo
>> that is specifically matched to Europa release version? I thought the
>> whole Update Site thing was meant to check this compatible versioning
>> thing.
>>
>> David
>>
>> Martin Taal wrote:
>>> Hi David,
>>> I will look into this, in the mean time you can also download
>>> directly by following this link:
>>> http://www.eclipse.org/modeling/emft/downloads/?project=tene o
>>>
>>> gr. Martin
>>>
>>> david wrote:
>>>> Hi,
>>>>
>>>> I was putting Teneo and prequisites on a new machine, having
>>>> forgotten how I did it first time round on a different machine.
>>>>
>>>> Using update site
>>>> -http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml
>>>> First thing that strikes me is that it marks the latest plugins as
>>>> being the correct ones, and looking at the EMFT site it looks like
>>>> these require 3.4M3, whereas I have Europa ( 3.3 from the 25th
>>>> September 2007). But then it is hard to choose a correct version
>>>> because they all show being dependent on versions either side of
>>>> Europas. Not sure how you are supposed to resolve this.
>>>>
>>>> Anyway went ahead assume the whole Update thing knows which version
>>>> are correct, get most of the way through and then this error
>>>>
>>>> Update operation has failed
>>>> Error retrieving
>>>> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
>>>> returned HTTP response code: "404 Not Found" for URL:
>>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar]
>>>>
>>>> Server returned HTTP response code: "404 Not Found" for URL:
>>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar
>>>>
>>>>
>>>>
>>>> Thx.
>>>>
>>>> David
>>>
>>>
>
>
Re: [Teneo] Problem with update site [message #614050 is a reply to message #107675] Fri, 18 January 2008 11:44 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi David,
To me it seems more an issue of the update manager in general than of Teneo specifically...
I think I remember that I also have had these type of issues with the update manager (an npe) a
while back. You can check the error view and the eclipse log file to see if you can get more
information. You can also try a different mirror.

I do not know if the update manager is version aware.

Teneo does not have a dependency on the apache commons plugin so I do not know why in your case the
system tries to download it.

gr. Martin

david wrote:
> Hi,
>
> I did not get a warning about 3.4M I got this, again just now when I
> retried
>
> Update operation has failed
> Error retrieving
> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
> returned HTTP response code: "404 Not Found" for URL:
> http://eclipse.mirror.kangaroot.net/modeling/emft/updates/pl ugins/org.apache.commons.lang_2.1.0.v200711021015.jar]
>
> Server returned HTTP response code: "404 Not Found" for URL:
> http://eclipse.mirror.kangaroot.net/modeling/emft/updates/pl ugins/org.apache.commons.lang_2.1.0.v200711021015.jar
>
>
> I assume it is using a different update site to when you try.
>
> One thing I noticed was that it was attempting to download Version 0.8.0
> from the 3rd January 2008, not the 28-12-2007 version just prior to this
> error above. To compound things I cannot work at all. Because I thought
> maybe a full "Search for updates of the currently installed features"
> would help, now I get a NPE whenever I try to open any xml document.
> Seems the Update Site idea is not working in all cases, I thought it was
> supposed to be version aware? The only install I have done outside
> Update Site was the manual installation of the teneo project with the
> version from 28-12-2007.
>
>
> David
>
> Martin Taal wrote:
>> Hi David,
>> The active version of Teneo is 0.8.0 which is for 3.3. I would use the
>> last build (28th of december), since the 6th of december about 20
>> issues have been solved.
>>
>> I just tried the update manager and with me it worked fine (I updated
>> to the 28th dec version).
>> In which screen did you see the warning about eclipse version 3.4?
>>
>> gr. Martin
>>
>> david wrote:
>>> Hi,
>>>
>>> I used the version dated 6th September, it being closest to the
>>> release date of Europa. Wondering why there is not a version of Teneo
>>> that is specifically matched to Europa release version? I thought the
>>> whole Update Site thing was meant to check this compatible versioning
>>> thing.
>>>
>>> David
>>>
>>> Martin Taal wrote:
>>>> Hi David,
>>>> I will look into this, in the mean time you can also download
>>>> directly by following this link:
>>>> http://www.eclipse.org/modeling/emft/downloads/?project=tene o
>>>>
>>>> gr. Martin
>>>>
>>>> david wrote:
>>>>> Hi,
>>>>>
>>>>> I was putting Teneo and prequisites on a new machine, having
>>>>> forgotten how I did it first time round on a different machine.
>>>>>
>>>>> Using update site
>>>>> -http://download.eclipse.org/modeling/emft/updates/site-inte rim.xml
>>>>> First thing that strikes me is that it marks the latest plugins as
>>>>> being the correct ones, and looking at the EMFT site it looks like
>>>>> these require 3.4M3, whereas I have Europa ( 3.3 from the 25th
>>>>> September 2007). But then it is hard to choose a correct version
>>>>> because they all show being dependent on versions either side of
>>>>> Europas. Not sure how you are supposed to resolve this.
>>>>>
>>>>> Anyway went ahead assume the whole Update thing knows which version
>>>>> are correct, get most of the way through and then this error
>>>>>
>>>>> Update operation has failed
>>>>> Error retrieving
>>>>> "plugins/org.apache.commons.lang_2.1.0.v200711021015.jar". [Server
>>>>> returned HTTP response code: "404 Not Found" for URL:
>>>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar]
>>>>>
>>>>> Server returned HTTP response code: "404 Not Found" for URL:
>>>>> http://ftp.heanet.ie/pub/eclipse//modeling/emft/updates/plug ins/org.apache.commons.lang_2.1.0.v200711021015.jar
>>>>>
>>>>>
>>>>>
>>>>> Thx.
>>>>>
>>>>> David
>>>>
>>>>
>>
>>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Previous Topic:[Teneo] HbDataStore.reinitialize()
Next Topic:[Ecore Tools] Search references popup menu
Goto Forum:
  


Current Time: Mon Sep 21 10:58:25 GMT 2020

Powered by FUDForum. Page generated in 0.02815 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top