Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BPMN 2.0 Modeler » Couldn't get BPMN2.0-modeler to install
icon5.gif  Couldn't get BPMN2.0-modeler to install [message #837334] Thu, 05 April 2012 14:48 Go to next message
Chuck Huang is currently offline Chuck HuangFriend
Messages: 1
Registered: April 2012
Junior Member
Hi,

I'm currently working under Mac OS X Lion, with eclipse 3.7 Indigo.

When I was trying to install BPMN2.0-Modeler, it got stuck in the dependency checking process.

it always complains about:
Cannot complete the install because of a conflicting dependency.
  Software being installed: BPMN2 Editor 0.0.1.201203301339 (org.eclipse.bpmn2.modeler.feature.feature.group 0.0.1.201203301339)
  Software currently installed: Graphiti SDK (Incubation) 0.7.1.v20110111-0756 (org.eclipse.graphiti.sdk.feature.feature.group 0.7.1.v20110111-0756)
  Only one of the following can be installed at once: 
    Graphiti (Incubation) 0.8.2.v20120215-0845 (org.eclipse.graphiti 0.8.2.v20120215-0845)
    Graphiti (Incubation) 0.7.1.v20110110-1225 (org.eclipse.graphiti 0.7.1.v20110110-1225)
    Graphiti (Incubation) 0.8.0.v20110601-0826 (org.eclipse.graphiti 0.8.0.v20110601-0826)
    Graphiti (Incubation) 0.8.1.v20110907-0857 (org.eclipse.graphiti 0.8.1.v20110907-0857)
  Cannot satisfy dependency:
    From: BPMN2 Editor Core 0.0.1.201203301339 (org.eclipse.bpmn2.modeler.core 0.0.1.201203301339)
    To: bundle org.eclipse.graphiti [0.7.3,1.0.0)
  Cannot satisfy dependency:
    From: BPMN2 Editor 0.0.1.201203301339 (org.eclipse.bpmn2.modeler.feature.feature.group 0.0.1.201203301339)
    To: org.eclipse.bpmn2.modeler.core [0.0.1.201203301339]
  Cannot satisfy dependency:
    From: Graphiti (Incubation) 0.7.1.v20110111-0756 (org.eclipse.graphiti.feature.feature.group 0.7.1.v20110111-0756)
    To: org.eclipse.graphiti [0.7.1.v20110110-1225]
  Cannot satisfy dependency:
    From: Graphiti SDK (Incubation) 0.7.1.v20110111-0756 (org.eclipse.graphiti.sdk.feature.feature.group 0.7.1.v20110111-0756)
    To: org.eclipse.graphiti.feature.feature.group [0.7.1.v20110111-0756]


Any idea how I can resolve it? Thank you very much.

[Updated on: Sat, 07 April 2012 00:05]

Report message to a moderator

Re: Couldn't get BPMN2.0-modeler to install [message #840185 is a reply to message #837334] Mon, 09 April 2012 19:25 Go to previous message
Robert Brodt is currently offline Robert BrodtFriend
Messages: 811
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Looks like you have some incompatible versions of Graphiti installed. Please try removing everything except version 0.8.1 - I haven't tested the editor with any other versions of Graphiti, but I suspect there may be some...issues Wink

Cheers!
Bob
Previous Topic:Data flows in BPMN 2.0 Modeler
Next Topic:Issues when creating a BPMN2 diagram
Goto Forum:
  


Current Time: Wed Oct 16 12:40:07 GMT 2019

Powered by FUDForum. Page generated in 0.01379 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top