Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » [xtend] 2.3 tooling backwards compatible?
[xtend] 2.3 tooling backwards compatible? [message #814354] Tue, 06 March 2012 10:41 Go to next message
Knut Wannheden is currently offline Knut WannhedenFriend
Messages: 298
Registered: July 2009
Senior Member
Hi,

I am wondering if the Xtend 2.3 tooling (i.e. editor and builder participant)
is backwards compatible with respect to Xtend 2.2.1. IOW, can I install Xtend
2.3 plug-ins in my workspace with Xtend 2.2.1 libraries in my PDE target? Or
will the Java code produced by the Xtend 2.3 compiler require 2.3 runtime
libraries in the target?

The reason I'm asking is since it would be very nice to be able to use the new
Xtend debugger in the development environment.

Thanks,

--knut
Re: [xtend] 2.3 tooling backwards compatible? [message #815163 is a reply to message #814354] Wed, 07 March 2012 09:52 Go to previous message
Sven Efftinge is currently offline Sven EfftingeFriend
Messages: 1823
Registered: July 2009
Senior Member
It should but it will definitely generate different Java code (which
does the same). Would be good to learn if it doesn't and why :-)

Am 3/6/12 11:41 AM, schrieb Knut Wannheden:
> Hi,
>
> I am wondering if the Xtend 2.3 tooling (i.e. editor and builder
> participant) is backwards compatible with respect to Xtend 2.2.1. IOW,
> can I install Xtend 2.3 plug-ins in my workspace with Xtend 2.2.1
> libraries in my PDE target? Or will the Java code produced by the Xtend
> 2.3 compiler require 2.3 runtime libraries in the target?
>
> The reason I'm asking is since it would be very nice to be able to use
> the new Xtend debugger in the development environment.
>
> Thanks,
>
> --knut


--
Need professional support for Xtext or other Eclipse Modeling technologies?
Go to: http://xtext.itemis.com
Twitter : @svenefftinge
Blog : http://blog.efftinge.de
Previous Topic:Show API to my language
Next Topic:Xtend 2 - NoSuchElementException while generating without eclipse
Goto Forum:
  


Current Time: Sun Apr 05 14:37:52 GMT 2020

Powered by FUDForum. Page generated in 0.01937 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top