Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Modelling XSD using EMF
Modelling XSD using EMF [message #98546] Mon, 08 October 2007 10:52 Go to next message
Eclipse UserFriend
Originally posted by: mmclaughlin.tssg.org

Hi there,

Thanks in advance for your help.

I have just begun working with EMF/XSD in eclipse 3.3. I have a set of XSD
schema files that I want to model using EMF. My initial problem was that
installing EMF proved highly problematic, since the 'find and install'
option used sites that pointed the installer to bad URLs. Ultimately I
went to the EMF site itself and downloaded the EMF, SDO, and XSD
All-In-One build (2.4.0M2). I also downloaded 'Models', but I wasn't sure
what to do with that folder since no instructions are provided.

Now, I assume that EMF/SDO/XSD are now installed and working properly.
They are listed in 'About Eclipse Platform -> Plug-in Details';
specifically:
(EMF)
org.eclipse.emf,emf.codegen,emf.codegen.ecore,emf.codegen.ec ore.ui,emf.codegen.ui,
emf.common,emf.common.ui,emf.converter,emf.doc,emf.ecore,emf .ecore.change,
emf.ecore.change.edit,emf.ecore.edit,emf.ecore.editor,emf.ec ore.sdo.doc,emf.ecore.sdo.source,
emf.ecore.xmi,emf.edit,emf.edit.ui,emf.examples,emf.examples .library,emf.examples.library.edit,
emf.examples.library.editor,emf.exporter,emf.exporter.html,e mf.importer,emf.importer.ecore,
emf.importer.java,emf.importer.rose,emf.java,emf.java.edit,e mf.java.editor,emf.mapping,
emf.mapping.ecore,emf.mapping.ecore.editor,emf.mapping.ecore 2ecore,emf.mapping.ecore2ecore.editor,
emf.mapping.ecore2xml,emf.mapping.ecore2xml.ui,emf.mapping.u i,emf.source
(XSD)
org.eclipse.xsd.doc,xsd.ecore.converter,xsd.mapping,xsd.mapp ing.editor,xsd.source

(Apologies for the format of this 'dump', I'm new to eclipse and I haven't
figured out how to get a proper dump of installed plug-ins yet.)

I've looked in 'Help -> Manage Configuration' and these plugins seem to be
working properly.

My problem is that I want to essentially follow the tutorial here:
http://www.eclipse.org/modeling/emf/docs/2.x/tutorials/xlibm od/xlibmod_emf2.0.html
or, more specifically, I want to open a new project by doing 'New ->
Project: Eclipse Modeling Framework -> EMF Project' and select something
like 'Load from XSD'. But I can't do this because when the 'Select a Model
Importer' screen appears, the only two options are: 'Ecore model' and
'Rose class model'.

So, do I have everything I need installed? How do I get the XSD Model
importer option to appear? I downloaded 'Models' from
http://www.eclipse.org/modeling/emf/downloads/?project=emf, where do I
install them? (If this is my problem.)

Apologies if any of this is obvious, but I have spent a long time on it
myself, and I haven't had any joy.

Thanks again,
Mark
Re: Modelling XSD using EMF [message #98597 is a reply to message #98546] Mon, 08 October 2007 13:50 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mmclaughlin.tssg.org

I sorted the problem by doing a complete re-install, and the auto updater
worked this time (slow as hell, but it worked). Not sure what the problem
was. Maybe it was the fact I confined myself to Europa repositories only
this time.
Re: Modelling XSD using EMF [message #98610 is a reply to message #98597] Mon, 08 October 2007 14:04 Go to previous message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

Mark,

EMF/XSD 2.4 relies on Eclipse 3.4. So for Eclipse 3.3, you should be
using EMF/XSD 2.3.


Mark McLaughlin wrote:
> I sorted the problem by doing a complete re-install, and the auto
> updater worked this time (slow as hell, but it worked). Not sure what
> the problem was. Maybe it was the fact I confined myself to Europa
> repositories only this time.
>
Re: Modelling XSD using EMF [message #609917 is a reply to message #98546] Mon, 08 October 2007 13:50 Go to previous message
Eclipse UserFriend
Originally posted by: mmclaughlin.tssg.org

I sorted the problem by doing a complete re-install, and the auto updater
worked this time (slow as hell, but it worked). Not sure what the problem
was. Maybe it was the fact I confined myself to Europa repositories only
this time.
Re: Modelling XSD using EMF [message #609921 is a reply to message #98597] Mon, 08 October 2007 14:04 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 33132
Registered: July 2009
Senior Member
Mark,

EMF/XSD 2.4 relies on Eclipse 3.4. So for Eclipse 3.3, you should be
using EMF/XSD 2.3.


Mark McLaughlin wrote:
> I sorted the problem by doing a complete re-install, and the auto
> updater worked this time (slow as hell, but it worked). Not sure what
> the problem was. Maybe it was the fact I confined myself to Europa
> repositories only this time.
>


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Modelling XSD using EMF
Next Topic:Installing EMF driving me NUTS
Goto Forum:
  


Current Time: Sun Apr 14 00:49:57 GMT 2024

Powered by FUDForum. Page generated in 0.09749 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top