Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [CDO][0.8.0] Connector.UserID not pass properly to the server
[CDO][0.8.0] Connector.UserID not pass properly to the server [message #98044] Sun, 30 September 2007 19:28 Go to next message
Simon Mc Duff is currently offline Simon Mc DuffFriend
Messages: 596
Registered: July 2009
Senior Member
Hi Eike,

Connector as a userId.
My client set that value to the current user.

Unfortunately, the server side doesn't have this information.

Is it supposed to behave like that ? I would expect to get the value in the
server side... in the Connector object

Simon
Re: [CDO][0.8.0] Connector.UserID not pass properly to the server [message #98061 is a reply to message #98044] Mon, 01 October 2007 08:20 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: stepper.sympedia.de

Hi Simon,

The userID of the IConnector is supposed to be used by an
IConnectorNegotiator if you have one.
If you open a feature request I can provide a challenge/response based
negotiator that upon successful negotiation makes the userID available
at the server side.

Please note: An IConnectorNegotiator is able to authenticate a user for
the whole IConnector, that is for all IChannels to be opened on that
connector.
If you prefer to have each IChannel authenticated separately please open
a feature request for IChannelNegotiators.There is no infrastructure for
this so far.

Of course you can also request both features ;-)
Please indicate your priority on the Bugzilla (note that Mylyn always
resets priority on *initial* submit).

Cheers
/Eike



Simon McDuff schrieb:
> Hi Eike,
>
> Connector as a userId.
> My client set that value to the current user.
>
> Unfortunately, the server side doesn't have this information.
>
> Is it supposed to behave like that ? I would expect to get the value in the
> server side... in the Connector object
>
> Simon
>
>
>
>
>
>
Re: [CDO][0.8.0] Connector.UserID not pass properly to the server [message #98105 is a reply to message #98061] Mon, 01 October 2007 11:34 Go to previous message
Eclipse UserFriend
Originally posted by: stepper.sympedia.de

https://bugs.eclipse.org/bugs/show_bug.cgi?id=205027
Re: [CDO][0.8.0] Connector.UserID not pass properly to the server [message #609855 is a reply to message #98044] Mon, 01 October 2007 08:20 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6682
Registered: July 2009
Senior Member
Hi Simon,

The userID of the IConnector is supposed to be used by an
IConnectorNegotiator if you have one.
If you open a feature request I can provide a challenge/response based
negotiator that upon successful negotiation makes the userID available
at the server side.

Please note: An IConnectorNegotiator is able to authenticate a user for
the whole IConnector, that is for all IChannels to be opened on that
connector.
If you prefer to have each IChannel authenticated separately please open
a feature request for IChannelNegotiators.There is no infrastructure for
this so far.

Of course you can also request both features ;-)
Please indicate your priority on the Bugzilla (note that Mylyn always
resets priority on *initial* submit).

Cheers
/Eike



Simon McDuff schrieb:
> Hi Eike,
>
> Connector as a userId.
> My client set that value to the current user.
>
> Unfortunately, the server side doesn't have this information.
>
> Is it supposed to behave like that ? I would expect to get the value in the
> server side... in the Connector object
>
> Simon
>
>
>
>
>
>


Re: [CDO][0.8.0] Connector.UserID not pass properly to the server [message #609858 is a reply to message #98061] Mon, 01 October 2007 11:34 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6682
Registered: July 2009
Senior Member
https://bugs.eclipse.org/bugs/show_bug.cgi?id=205027

Previous Topic:[CDO][0.8.0] Connector.UserID not pass properly to the server
Next Topic:still problems with emft updates
Goto Forum:
  


Current Time: Mon Apr 22 23:48:54 GMT 2024

Powered by FUDForum. Page generated in 0.03265 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top