Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Date Formatting Issue
Date Formatting Issue [message #808423] Mon, 27 February 2012 19:21 Go to next message
Michael Harless is currently offline Michael HarlessFriend
Messages: 14
Registered: January 2012
Junior Member
I am attempting to apply a format to two date fields that are within a data string:
"Client: " + dataSetRow["CLIENT"] + " Case No: " + row["CASENO"] + "; Referral: " + dataSetRow["RFRSRCNM"] + " Initial Contact: " + dataSetRow["INITDATE"] + "; Agency Status: " + dataSetRow["AGCYSTS"] + "; Acceptance Date: " + dataSetRow["ACPTDATE"]
Is this possible? I have tried value-of and, unless I'm just not entering it correctly (very possible), it doesn't work. Any assistance is appreciated.
Re: Date Formatting Issue [message #808565 is a reply to message #808423] Mon, 27 February 2012 22:47 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Take a look at this post.
http://birtworld.blogspot.com/2011/02/birt-formatting-numbers-and-dates.html

If you are using a data item look at the Formatter.format function. If
you are using a text element with type set to html you can use something
like:
<VALUE-OF format="MMM-dd-yy hh:mm" > dataSetRow["ACPTDATE"];</VALUE-OF>

Jason

On 2/27/2012 2:21 PM, Michael Harless wrote:
> I am attempting to apply a format to two date fields that are within a
> data string: "Client: " + dataSetRow["CLIENT"] + " Case No: " +
> row["CASENO"] + "; Referral: " + dataSetRow["RFRSRCNM"] + " Initial
> Contact: " + dataSetRow["INITDATE"] + "; Agency Status: " +
> dataSetRow["AGCYSTS"] + "; Acceptance Date: " + dataSetRow["ACPTDATE"]
> Is this possible? I have tried value-of and, unless I'm just not
> entering it correctly (very possible), it doesn't work. Any assistance
> is appreciated.
Re: Date Formatting Issue [message #809107 is a reply to message #808423] Tue, 28 February 2012 13:41 Go to previous messageGo to next message
Michael Harless is currently offline Michael HarlessFriend
Messages: 14
Registered: January 2012
Junior Member
Thanks Jason. I've read and re-read that post and tried the methods... can't get anything to work. Thanks anyway.
Re: Date Formatting Issue [message #809582 is a reply to message #809107] Wed, 29 February 2012 02:34 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Michael,

What version of BIRT are you using? Can you dump some of your data to a
txt file then create a report against it that shows the issue so I can
run and debug it?

Jason

On 2/28/2012 8:41 AM, Michael Harless wrote:
> Thanks Jason. I've read and re-read that post and tried the methods...
> can't get anything to work. Thanks anyway.
Previous Topic:BIRT CHART : Multiple Dataset on one Y - Axis
Next Topic:help with XML datasource
Goto Forum:
  


Current Time: Sun Dec 05 05:55:51 GMT 2021

Powered by FUDForum. Page generated in 0.01979 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top